Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema DSL-2740 E1: conviene prenderlo?
#1
Ciao Carciofone, di solito scrivo su HWupgrade. Ho trovato questo bellissimo forum sui D-Link e voglio farti la stessa domanda che ho postato di là, ma mi hanno stoppato gli admin. In passato ti ho chiesto vari consigli e magari ti ricordi di me perchè ho lo stesso nick di Stan-o (quello dei video demenziali inglesi) anche su Hardware Upgrade.
Vorrei che mi dicessi qualcosa sul 2740B E1 te che sei un guru. Io col C2 che mi hai consigliato quasi un anno fa mi sono sempre trovato bene e non ho nemmeno mai avuto il problema della scheda wireless che si toglie e i vari blocchi. Lo accendo e va. Punto.
Adsso volevo consigliarlo a mio cognato e sabato lo stavamo per prendere al Mediaworl, ma mi pareva di aver letto male su HWUpgrade del E1 e l'ho stoppato.
Il fatto è che si trova solo quello, oppure il 2740R nel kit con la pennetta.
Che faccio? C'è altro in giro di valido?
Cita messaggio
#2
Il mio pensiero sull'E1 l'ho esposto qui precedentemente:

Citazione:Cerco di chiarire una volta per tutte il mio pensiero su sto benedetto D-Link DSL-2740B (la B finale sta per chipset Broadcom e non è R, cioè Ralink!).
Da mesi uso in casa una versione C2 (non E1) e la reputo una buona macchina, con una soddisfaciente copertura wireless (molto superiore al vecchio Linksys WAG200G che avevo), discretamente veloce (ma non velocissima, come dimostro nei test di velocità pubblicati altrove), decisamente affidabile ( che ricordi mai un blocco di funzionamento), performante con il P2P (data la quantità di RAM di 32 MB che incide parecchio sulle performances complessive).
Ha un grave difetto: periodicamente, ogni x mesi, la scheda wireless aggiuntiva interna, forse per problemi di sbalzi termici, può disallinearsi dal pettine di connessione sulla scheda madre e dare problemi di blocco all'avvio alle basse temperature che si risolvono lasciando scaldare l'apparecchiatura per qualche secondo sotto tensione.
Riguardo alla capacità di connessione in situazioni disastrate o difficili non posso dire nulla perchè è collegato ad una linea adsl che dire eccellente è poco.

La nuova versione hardware E1 mantiene le stesse caratteristiche di base, ma ha 8 MB di ROM, 32 MB di RAM, ha un nuovo chipset wireless 2T2R e ha varie opzioni in più nel firmware (wireless temporizzato, porta LAN che diventa WAN le maggiori).
Soffre, però, di gravi difetti di gioventù che si spera vengano risolti con l'aggiornamento del firmware e che riguardano la compatibilità con le linee AnnexA.
Ora, la casistica è veramente anomala, perchè taluni lo tirano fuori dalla scatola col firmware di fabbrica 5.15 e lo usano senza problemi, mentre altri non trovano verso di farlo connettere. Il firmware più stabile è solitamente quello disponibile sull'ftp tedesco che serve a linee simili alle nostre.

L'unica cosa che posso aggiungere è che a giorni ne avrò uno da sezionare e allora vedremo come stanno le cose. Per intanto avevo lanciato questa proposta e se qualcuno vuole aderire, intanto raccogliamo info:

Citazione:Facciamo così: se qualcuno è disponibile può indicare il breve la versione del firmware per la rev. E1 e dire i problemi che riscontra. Es.:

Firmware EU_5.14Buildxy:
- non mi connetto con PPPoA-VC MTU 1500 su Alice
- il wireless in modalità N a 40 Mhz ha 9 canali radio
- il DDNS non funziona correttamente...
etc...

@Stan-o: ti rigrazio delle lusinghe, ma ci sono molti altri utenti che sanno il fatto loro su questo forum.
L'unica cosa di cui ti vorrei pregare è di essere più sintetico la prox volta: forum vari e tutti i PM, nonchè le email "pullulano" di tue richieste in proposito. Capirai bene che si crea un effetto spam che rallenta la lettura e crea confusione se metti un dato qua e uno là e poi devo andare io a ricomporre il quadro.
Cita messaggio
#3
Sì, scusa per la confusione. Ho letto anche la tua recensione e ho messo una domanda. Il problema del wireless sarebbe importante da chiarire.
Cita messaggio
#4
Ma allora questo modello è diventato stabile e si può prendere anche se ha ancora qualcosa che nn va?
Perchè sto seguendo i 3d di altri modelli e il dgn3500 che mi piaceva ha un sacco di problemi di stabilità, wireless, disconnessioni random, blocchi...
Uff ma ste ditte li vendono e poi li aggiustano dopo 6 mesi.
Cita messaggio
#5
Citazione:Attenzione: chi ha una connessione ALICE su PPPoE-LLC o altro provider su PPPoE potrebbe fare un test di conferma con il DSL-2740B E1 firmware 5.17B49?

1) salvarsi necessariamente il file di configurazione del router così come vi funziona ora Maintenance\Save Restore Settings\Save Settings to Local Hard Drive
2) staccare il doppino telefonico e cambiare la connessione in PPPoE LLC MTU 1492

Navigate così? (Dovrebbe essere risposta negativa, ma router connesso).

3) aggiungete ora manualmente i DNS nelle proprietà della scheda di rete connessa al router (oppure anche nel router, ma sono 2 prove differenti).

Navigate così? (Dovrebbe essere risposta positiva).

N.B.: le impostazioni avanzate dell'ADSL e la selezione del Pair lasciatele come è spiegato sulla Miniguida di sopravvivenza su Inner.

Sebbene nessuno abbia accolto l'appello al test, comunico che grazie ad un'intuizione di un utente abbiamo circoscritto di molto il presunto bug di connettività in modalità PPPoE LLC delle ADSL 20 mega con il firmware 5.17B49, derivante non da un difetto del driver di connessione, ma dall'erroneo funzionamento del DHCP del router.
Tutte le info sul D-Link forum.

Allo stato, quindi, risultano questi 2 bugs maggiori nel firmware 5.17B49:

1) erroneo funzionamento del DHCP nel caso di connessione di tipo PPPoE, aggirabile con un trick;

2) mancato funzionamento della MAC address list come segnalato anche qui dall'utente MarkoRoussinuovo;

oltre ad altri bugs minori dell'interfaccia.


Allo stato, quindi, non c'è alcuna ragione per continuare ad usare firmware precedenti al 5.17B49 ferme restando le avvertenze della mini-guida di sopravvivenza.
Cita messaggio
#6
Ciao a tutti, ho acquistato questo modem router da poco, per mia ignoranza e male informazione non sapevo l'esistenza delle due versioni, infatti ora ho l'E1 con firmware EU_5.14.
Una disgrazia! Siamo collegati in 10 persone, su questo router, che ogni 4-5 ore deve essere resettato perchè non riesce più a connettersi, l'errore che mi dà è "impossibile contattare il server DNS", ma questo non può essere vero in quanto ho provato quelli di Alice, quelli di google, gli openDNS, e niente il problema persiste, l'unica soluzione è resettare da capo il tutto.
Ho letto che C@rciofone ha consigliato il firmware 5.17B49, che ha cmq bug Big Grin ma questo sarebbe di poco conto se il mio problema principale verrebbe risolto...secondo voi riesco a risolvere questa piaga?

Grazie mille a tutti!


ps: di solito quando mi iscrivo in un forum, passo per la sezione benvenuti o simili, non l'ho notata in questo forum, chiedo scusa nel caso ci fosse.
Cita messaggio
#7
Ciao e ben venuto!
Per quanto riguarda il tuo router, è praticamente imperativo l'aggiornamento con il firmware 5.17 perchè la gran parte dei bugs del 5.14 dipende dal mancato aggiornamento di data e ora del router che sballa tutte le funzioni che dipendono da quello (tempi di rilascio del DHCP, timerizzazioni etc...). Fai riferimento alla discussione ufficiale in merito: http://www.dlink-forum.info/showthread.php?tid=213
In particolare la configurazione che dovrebbe funzionare è illustrata nella mini guida di sopravvivenza: http://www.dlink-forum.info/showthread.p...41#pid2441
Immetti i parametri con l'interfaccia inglese interagendo il meno possibile, se non necessario, con quelli non implicati nella tua configurazione e al termine salvati un file di configurazione in modo da poterlo ricaricare subito dopo un reset se fosse necessario in futuro.
Fai particolare attenzione alla sezione advanced adsl in cui non c'è nulla da cambiare, soprattutto lascia disabilitato SRA e la posizione del doppino in Inner pair (default), dato che in Italia non ci sono Outer pair e cambiandolo cominciano numerosi problemi.
La rete wireless principale va impostata dalla scheda Setup, lasciando la modalità b-G-n per maggiore compatibilità sui 20\40 Mhz (Auto) e scegliendo magari manualmente un canale libero usando inssider.exe per non avere cadute di segnale.
Non usare il MAC filter perchè non funziona, mentre con PPPoA VC di modalità di connessione non dovresti avere problemi. Con PPPoE a taluni funziona correttamente, mentre ad altri è necessario indicare i DNS nelle proprietà avanzate delle schede di rete dei PC.
Cita messaggio
#8
Grazie mille per la repentina risposta, dal tuo post ho letto che il firmware 5.17 va in PPPoA. Sarebbe comunque possibile andare in PPPoE o ci possono essere problemi di instabilità alla connessione dato che siamo in 10 a connetterci?
Cita messaggio
#9
(17-05-2010, 13:33)leodavi Ha scritto:Grazie mille per la repentina risposta, dal tuo post ho letto che il firmware 5.17 va in PPPoA. Sarebbe comunque possibile andare in PPPoE o ci possono essere problemi di instabilità alla connessione dato che siamo in 10 a connetterci?
Se non dovesse andare autonomamente si tratterà di impostare manualmente i DNS e dovrebbe andare anche con PPPoE LLC.
Sul fatto che poi siate in 10 a connettervi non posso dirti più di tanto. Tutti in wireless, qualcuno in ethernet (auspicabile!). Sarà un bel banco di prova e dipende anche dal tipo di uso che ognuno ne fa. Logico che non potrenno usare mulo e torrent tutti quanti e ti toccherà mettere mano ai Qos e DHCP statico in caso.
Cita messaggio
#10
Grazie mille! il router per ora sembra non dare problemi, dato che anche all'acquisto non ne ha dati per 2 giorni aspetto a parlare ;D se tra tre giorni sarò ancora connesso ti devo un caffè (o birra, a seconda della tua preferenza ;D ).
Ultime 2 domande e poi mi tolgo dalle scatole:

1. ci sarebbe un modo per filtrare il traffico p2p? ovvero limitarlo? perchè siamo tutti studenti e qualcuno è capoccione, anche se le cose gliele dici non ascoltano ;D
2. dato che il filtro mac non funziona ci sarebbe qualche programma esterno, o qualche marchingegno per mettermi al sicuro? sono costretto a fare qualcosa dato che sono stato hackerato in passato da altri studenti

grazie mille ancora davvero gentile!!!
Cita messaggio
#11
Intanto assegna un IP statico nel router a seconda dei mac adress degli utenti che si collegano: li vedi in setup\Lan Setup (DHCP Reservations List ).
Poi devi scegliere la tua politica di rete: se non gli apri le porte nel port forwarding emule avrà quasi sicuramente ID basso e disabilitando l'upnp nemmeno i torrent andranno benissimo.
Se poi decidi di fare una regolamentazione seria, allora hai a disposizione la regolamentazione fine del Qos con cui puoi diventare "cattivo" per davvero (Advanced\Qos setup\wireless qos oppure lan qos).
Scegli l'IP bersaglio per tutti i protocolli (ANY) con tutte le porte 1-65535 e limiti, assegnando una priorità bassa (1 alta priorità- 255 bassa priorità), tutto il suo traffico verso l'ip del router\gateway.
Fai così per tutti e poi vedi te se limitare le porte regolamentate ad es a quelle superiori a 1000 o altro.
I pc saranno sempre limitati perchè con il DHCP statico avranno sempre lo stesso IP ad ogni connessione (a meno che non cambino fittiziamente il MAC Adress della scheda di rete connessa, ma ecco che in questo caso se il MAC filter funzionasse, non riuscirebbero più a connettersi).

Le regole le puoi poi aumentare, prevedendo priorità alta per il traffico su certe porte e bassa per le altre (ad es. sopra\sotto le 1500). Se una porta non ha priorità stabilita ce l'ha sempre alta.

Per la sicurezza della rete wireless, una volta abilitato il wpa-psk o il wpa2-psk, allo stato non c'è modo per un utente normale che non ha la password di accedere al network (eventualmente lo metti in modalità nascosta, ma alcune schede potrebbero avere problemi a connettersi). Evita il WEP.
Cita messaggio
#12
ok ok gentilissimo e velocissimo ;D
ora aspetto che la stabilità del router diventi definitiva e poi seguo i tuoi ottimi consigli!

grazieee
Cita messaggio
#13
salve,
scusate se riprendo il post ma anche io ho un problema simile a leodavi.
ho un pc fisso collegato in ethernet al modem, e altri 5 portatili (di parenti, l'abbonamento internet è mio, loro sono connessi gratis per gentil concesione) collegati via wifi. vorrei limitare/ridurre la banda di tutti i portatili in modo che possano usare internet solo per navigare e non per scaricare, mentre col mio pc fisso vorrei essere in grado di usare internet a mio piacimento e quindi anche p2p.
ho letto le istruzioni fornite da c@rciofone ma ho alcuni dubbi (il mio modem è un dsl-2740b c2 firmware eu_2.97):
in Lan Setup devo impostare l'ip statico solo ai 2 portatili che voglio "limitare"?
[Immagine: modem1w.th.jpg]

è normale che Number of Dynamic DHCP Clients sia 1 e non 2?

inoltre, cosa dovrei impostare in Advanced\Qos setup\Wireless Qos tenendo conto dell'immagine precedente?( ho provato ad abbozzare una configurazione ma non mi convince...)
[Immagine: modem2r.th.jpg]

per il mio pc e per gli altri portatili che voglio lasciare "liberi" devo impostare qualcosa?
come faccio a verificare se aimpostazioni ultimate il tutto funziona?
vi ringrazio per l'immensa pazienza, come avete capito non sono molto esperto... ;D
saluti
Cita messaggio
#14
Nella DHCP reservation list io metterei tutti i pc che possono collegarsi al router in modo da sapere sempre che ip hanno (magari restringi il range dhcp da 192.168.1.2 a 192.168.1.50 e ai tuoi assegni 2,3,4,5 etc agl altri 20,21,22,... in modo da distingurli bene).
I dinamic client connessi indicati sono quelli il cui ip non è ancora scaduto e si sono connessi almeno una volta nelle ultime 24 h. Se hai appena acceso il router e sei connesso solo tu, allora è normale che ce ne sia uno solo.

Riguardo al QOS la regola limita la priorità, mentre se non c'è regola la priorità è massima.
Quanto alla regola in sè, non mi sembra corretta: se i due pc che vuoi limitare sono a e b con quegli ip, la limitazione deve valere per il traffico che generano verso il gateway e non verso se stessi, quindi verso l'ip del router. Ora sarebbe da verificare l'ordine di immissione della regola, perchè immagino che il grosso del traffico fastidioso sia in download e non in upload quindi ad essere limitato dovrebbe essere il traffico del gateway verso i due pc (quest'ultima cosa va verificata sul campo).
Quindi: traffico originato dal range dei due IP 7 e 8 verso il router 192.168.1.1, per tutti i protocolli, per tutte le porte (ma potresti anche mettere da 500 a 65535 ad es.), priorità metterei un 150, poi eventualmente a salire.
Non escluderei una seconda regola se il Qos dovesse essere unidirezionale con gli ip invertiti rispetto alla prima per un eventuale upload, ma non dovrebbe essere necessaria.
Cita messaggio
#15
ciao, grazie per la risposta e per la celerità Smile
ho provato ad impostare:
[Immagine: modem4.th.jpg]

tale configurazione può andar bene?
ancora grazie e buona giornata
Cita messaggio
#16
Sì, dovrebbe essere corretta. Testala per un pò e vedi se noti miglioramenti. Tieni presente che il qos non si attiva se il pc per cui è settato è l'unico in lan, ma solo se sono presenti altri pc con priorità maggiore.
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)