Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
DNS-320 e lighttpd
#1
Question 
Salve. Ho un piccolo problemino.
Ho installato con successo fonz fun_plug 0.5
Installato nano editor -> OK
Installato MySQL -> OK
Installato lighttpd -> !!!
Cioè va tutto a buon fine, tant'è che se faccio da terminale:
"sh /ffp/start/lighttpd.sh status"
Il sistema mi risponde:
"lighttpd-angel running as pid 20781"
Ma se metto delle pagine di test nelle cartelle puntate da lighttpd.conf in documentroot, mi appare solo la pagina di amministrazione del nas.
Cioè da terminale il sistema mi risponde che funziona, ma all'atto pratico non funziona. Consigli?
Aiutatemi vi prego, ho bisogno di far funzionare PHPMyAdmin

PS: il server mi dovrebbe rispondere sulla porta 80, mentre la pagina di amministrazione dovrebbe rispondermi sulla porta 81. In realtà sulla 80 risponde la pagina di amministrazione del Dlink, sulla porta 81 non risponde nessuno!!!
Cita messaggio
#2
(16-03-2014, 22:14)inggae Ha scritto: mentre la pagina di amministrazione dovrebbe rispondermi sulla porta 81.

Da dove hai modificato questa impostazione?
Non possono esserci due server http con la stessa porta, ti conviene cambiarla da lighttpd.conf e mettere ad esempio la 3000
Codice:
server.port = 3000
Cita messaggio
#3
(17-03-2014, 20:11)m4ss1 Ha scritto:
(16-03-2014, 22:14)inggae Ha scritto: mentre la pagina di amministrazione dovrebbe rispondermi sulla porta 81.

Da dove hai modificato questa impostazione?
Non possono esserci due server http con la stessa porta, ti conviene cambiarla da lighttpd.conf e mettere ad esempio la 3000
Codice:
server.port = 3000

Niente, non ne vuole sapere. Non so più dove sbattere la testa!!!
Una domandina. Io ho seguito pedissequamente la guida su nas-tweaks.
Quando mi dice di uploadare un file index.html via esplora risorse non ho i permessi.
Allora con chmod 777 li imposto. Devo lasciare così o riportarli a 755?
Cita messaggio
#4
Stai sicuramente seguendo questa guida, hai seguito bene questi passaggi?

and enable a script which disables the standard HTML server called webs (if you are running a DNS-320 / DNS-325 please skip this step and go to the following section):
Codice:
chmod a+x /ffp/start/kickwebs.sh
The standard “webs” server then restarts automatically within a few minutes, but moves to port 81 because the standard HTTP port (80) is already occupied by the lighttpd server.

If you are running a DNS-320 or a DNS-325, you need to enable “kickwebs_dns320.sh” for kicking the internal lighttpd (which is used for the Webinterface of the Device) from Port 80:
Codice:
chmod a+x /ffp/start/kickwebs_dns320.sh
Note that the chmod commands only take effect on the next reboot. If you would reboot now, however, nothing changes. If you want to try, you can see test this manually using:
Codice:
sh /ffp/start/kickwebs.sh start # When you run a Device other than DNS-320 / DNS-325
sh /ffp/start/kickwebs_dns320.sh start # When you run a DNS-320 / DNS-325
sh /ffp/start/lighttpd.sh start
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)