Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
DSL-2740R: DynDNS non funziona
#1
Ciao,
recentemente ho sostituito un routern US Robotics con un D-Link DSL-2740R.

Con il vecchio dispositivo ero riuscito a configurare il dyndns senza troppi problemi (l'obiettivo era raggiungere il pc con VNC).

Con il nuovo dispositivo e seguendo le FAQS qui sotto
http://www.dlink-forum.info/showthread.php?tid=158

ho configurato apparentemente in modo corretto il router, ma purtroppo, digitando il link correttamente VNC mi restituisce l'errore "Failed to connect to server".
Se provo ad effettuare una connessione dentro la LAN e utilizzo l'indirizzo IP diretto funziona, ma se provo ad utilizzare l'indirizzo utente.dyndns-****.com mi restituisce l'errore.

Avete qualche suggerimento?
Ho provato a cercare in giro un'emulatore della mia versione, ma la cosa più simile che ho trovato è di un'altra versione
http://support.dlink.com/emulators/dir82..._info.html
#2
Che voce del Dyndns hai scelto nel menù a tendina in Advanced\DNS Setup?
Dovrebbe esserci sia DynDNS free che custom. Provali entrambi. Usa una password di 6-8 caratteri max.
#3
Ho avuto anche io lo stesso problema.
Non ne sono ancora sicuro ma credo che nella classe di dispositivi DSL-2X40R il DNS loopback è disabilitato per cui accade questo fenomeno (se non ho capito male, se il dns non viene risolto sullo stesso indirizzo di chiamata).
Per provare il funzionamento del Dyndns, come soluzione di ripiego, occorre impostare la connessione attraverso un proxy server esterno tra quelli pubblici disponibili.
Usando questo espediente, il dyndns funziona.
Cosa dice il router del mio avatar? "Hey, don't look at me. Not me that ain't working..."
#4
(28-02-2011, 7:29)Alby Ha scritto: Che voce del Dyndns hai scelto nel menù a tendina in Advanced\DNS Setup?
Dovrebbe esserci sia DynDNS free che custom. Provali entrambi. Usa una password di 6-8 caratteri max.

Ciao,
le alternative disponibili sono:
dlinkddns.com(Free)
DynDNS.org(Free)

La più corretta è la seconda ma in entrambi i casi non funziona.
#5
Prova ad impostare una password al massimo di 8 lettere e senza caratteri speciali come €[^
#6
(01-03-2011, 10:59)m4ss1 Ha scritto: Prova ad impostare una password al massimo di 8 lettere e senza caratteri speciali come €[^

lo avevo già impostato, 8 caratteri alfanumerici, nessun carattere speciale
#7
(28-02-2011, 16:36)bobbox Ha scritto: Ho avuto anche io lo stesso problema.
Non ne sono ancora sicuro ma credo che nella classe di dispositivi DSL-2X40R il DNS loopback è disabilitato per cui accade questo fenomeno (se non ho capito male, se il dns risolve sullo stesso indirizzo di chiamata).
Per provare il funzionamento del Dyndns, come soluzione di ripiego, occorre impostare la connessione attraverso un proxy server esterno tra quelli pubblici disponibili.
Usando questo espediente, il dyndns funziona.

ok ... non sono una cima ma con google qualcosuccia credo di aver capito.
In pratica dovrei (e non so bene come) impostare sul router un proxy pubblico in modo da evitare problemi con il DNS.

Così facendo il proxy dovrebbe riconoscere correttamente l'indirizzo di dyndns? Questa sera ci provo un po' a caso ... spero di non dover chiedere come fare passo a passo. Sad

Grazie 1000, farò sapere l'esito
#8
Lo verifichi facilmente impostando un proxy server sul browser
Cosa dice il router del mio avatar? "Hey, don't look at me. Not me that ain't working..."
#9
Suggest: crea un nuovo account con le estensioni previste oggi da dyndns che funzionano con la funzione free e non più con la vecchia custom.
#10
Questo è il proxy server che utilizzo per testare dyndns nel browser (IE, Firefox, etc).
Ricordati di disattivarlo quando hai completato le prove.
[Immagine: capturecbg.png]
Cosa dice il router del mio avatar? "Hey, don't look at me. Not me that ain't working..."
#11
(01-03-2011, 19:45)Alby Ha scritto: Suggest: crea un nuovo account con le estensioni previste oggi da dyndns che funzionano con la funzione free e non più con la vecchia custom.

ho provato a creare un nuovo account con dyndns questa volta con dominio dyndns.org ... ma anche questa volta il problema sussiste. Dodgy
#12
(02-03-2011, 0:26)bobbox Ha scritto: Questo è il proxy server che utilizzo per testare dyndns nel browser (IE, Firefox, etc).
Ricordati di disattivarlo quando hai completato le prove.
[Immagine: capturecbg.png]

Ok, fuochino ...
nel senso che attualmente continuo a visualizzare il messaggio di errore con VNC, ma configurando il proxy come indicato effettivamente noto che su browser le cose cambiano.

Se imposto il proxy appare un messaggio di
Codice:
Error: Gateway Timeout
connection refused

Mentre se lo lascio invariato mi viene reindirizzato alla pagina di configurazione del router.

Ora devo capire come fare per far si che VNC riconosca l'indirizzo.[/code]


#13
@buboarioch: non ho capito bene cosa intendi per usare il proxy. Cioè lo imposti nel pc su cui lanci il Viewer, perchè logicamente, altrimenti, il dyndns non funziona dalla tua stessa LAN, o cosa?
Se quella sopra fosse l'ipotesi, logicamente non potrai MAI verificare la funzionalità del dyndns dalla tua stessa LAN, perchè per il router avresti il suo IP pubblico che interroga sè stesso e quindi non fa nemmeno uscire in WAN quella richiesta. I test li puoi fare o tramite un proxy che mascheri l'IP di origine come ti ha suggerito bobbox, oppure da una connessione 56k, o hsdpa diversa dalla tua. Come ha detto già bobbox il DNS loopback su tutti i router recenti che trovi in questo forum non funziona com'è opportuno che sia.
In sintesi, non esiste alcun bug del firmware, ma è un comportamento normale dettato da scelte progettuali del firmware. Ovviamente da un altro IP pubblico vnc funziona sull'indirizzo tuo.indirizzo.dyndns.com:porta se è correttamente eseguito il portforwarding sul router.
#14
Un ringraziamento a tutti ... ho capito l'errore Smile
Ero abituato con un router ethernet che mi faceva fare qualsiasi cosa e davo per assodato che tutti lavorassero nello stesso modo.

Grazie mille.
Ciao
#15
(06-03-2011, 22:23)buboarioch Ha scritto: Un ringraziamento a tutti ... ho capito l'errore Smile
Ero abituato con un router ethernet che mi faceva fare qualsiasi cosa e davo per assodato che tutti lavorassero nello stesso modo.

Grazie mille.
Ciao

Ti prego spiegami come hai fatto!!!
non una ip camera Foscam e prima con il router infostrada sono riuscito a configurare dyndns in un istante, con il 2740r... Nulla!

Grazie Luca


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)