Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
DSL-2640B B2: led Power rosso
#1
Salve, sono il fortunato possessore di un DSL-2640B che da qualche giorno è morto (credo a causa di qualche sbalzo di tensione, non so se è possibile), i sintomi sono il power led rosso e nessuna risposta se col browser tento di andare all'indirizzo http://192.168.1.1/ Sad

Leggendo un po' in giro ho letto che forse lo si può recuperare ricaricando il firmware via seriale.
Potreste gentilmente spiegnarmi come è possibile fare ciò o segnalarmi qualche guida da leggere?
o secondo voi è meglio mandarlo in assistenza visto che ha solo 5 mesi di vita?

Grazie a tutti
#2
Dai un'occhiata alla sezione Procedura di recovery DSL-2640B al link di seguito:

DSL-2640B - Modem Router Wireless G ADSL2+
La prima cosa da leggere in questo forum | Siti globali D-Link

Siate CHIARI SINTETICI E DETTAGLIATI altrimenti non possiamo aiutarvi!!!

N.B. Purtroppo non ho il tempo di rispondere in PVT: 1) usa un motore di ricerca; 2) usa la funzione "Cerca" del forum; 3) chiedi nel forum. GRZ!!!
Questo forum non è un centro assistenza, ma una comunità.
Prima di chiedere a NOI di risolvere il problema che hai TU, chiediti come TU puoi dare una mano a TUTTI.

#3
ho provato a mettere come ip del pc 192.168.1.10 ma niente da fare la pagina 192.168.1.1 non si apre

che faccio??? aiutatemi
#4
So che la domanda è banale, ma nella tua descrizione non hai detto se ha fatto un reset hardware con l'apposito tastino di almeno 40 sec continuativi. Poi puoi tentare il recovery.
L'interfaccia web potrebbe in teoria non essere raggiungibile anche per altre ragioni, ad es per un'errata configurazione della rete (altri modempenne cell collegate) o a causa di un virus che hodifichi il file host.
#5
ho provato a fare il reset hw in due modi.
1) a router spento schiaccio il reset, accendo il router con il reset ancora schiacciato e lo tengo schiacciato per 1 minuto
2) accendo il router e poi schiaccio il reset per 1 minuto

la rete è ben configurata perché se al posto del DSL-2640B collego un vecchio DSL-320T, allora 192.168.1.1 è raggiungibile.

posso ricaricare il firmware via seriale?
#6
Il più indicato per darti dritte di questo tipo è Bovirus. Contattalo personalmente, se non sei troppo distante te lo fa lui, poi.
#7
ho mandato un pm a bovirus... vi tengo informati sulle evulzioni, così magari posso essere d'aiuto anche a qualche altro
#8
Immagine completa Flash ROM e CFE DSL-2640B disponibile (da utilizzare con JTAG)

DSL-2640B - Immagine completa memoria Flash (4MB) - Include CFE

DSL-2640B - Immagine CFE (bootloader) - 256 KB

TJTAG 3.0.1 - programma backup/flashing processori Broadcom

Prima di flashare prendere nota dei parametri di configurazione della board
#9
ragazzi,io ho lo stesso problema,ho provato a scaricare questi 3 file ma non me li fa scaricarfe perkè il server vuole nome utente e password,li metto ma m rimanda sempre ala solita finestra...
che cosa posso fare?
ciao
#10
Se non hai un router Infostrada/Wind, scarica il file di seguito:
(15-10-2008, 20:01)D-Link Forum Ha scritto:Firmware DSL-2640B v. 4.01B10023EB00 (25.03.2009) Dlink Beta (suggerito)
scompattalo e segui queste istruzioni:
(15-10-2008, 20:01)D-Link Forum Ha scritto:Procedura di recovery DSL-2640B
Se l'operazione di aggiornamento del firmware dovesse andar male è possibile ripristinare il router seguendo questa semplice guida.

Collegare il router spento al PC mediante il cavetto ethernet e impostare nelle proprietà avanzate della scheda ethernet del PC l'indirizzo IP fisso 192.168.1.10 (Gateway 192.168.1.1); accendere il router e aprire Internet Explorer. Digitare nella barra degli indirizzi http://192.168.1.1

[Immagine: 2740brn5.jpg]

Selezionare a questo punto il firmware precedentemente scaricato cliccando sul tasto "sfoglia" e premere su "Update software". Dopo un'attesa di circa 2 minuti il router ritornerà perfettamente funzionante.

[Immagine: recovery2kn2.th.jpg]
I file che volevi scaricare servono solo se hai un cavetto JTAG!
La prima cosa da leggere in questo forum | Siti globali D-Link

Siate CHIARI SINTETICI E DETTAGLIATI altrimenti non possiamo aiutarvi!!!

N.B. Purtroppo non ho il tempo di rispondere in PVT: 1) usa un motore di ricerca; 2) usa la funzione "Cerca" del forum; 3) chiedi nel forum. GRZ!!!
Questo forum non è un centro assistenza, ma una comunità.
Prima di chiedere a NOI di risolvere il problema che hai TU, chiediti come TU puoi dare una mano a TUTTI.

#11
(14-09-2009, 17:58)bovirus Ha scritto: Immagine completa Flash ROM e CFE DSL-2640B disponibile (da utilizzare con JTAG)

DSL-2640B - Immagine completa memoria Flash (4MB) - Include CFE

DSL-2640B - Immagine CFE (bootloader) - 256 KB

TJTAG 3.0.1 - programma backup/flashing processori Broadcom

Prima di flashare prendere nota dei parametri di configurazione della board




scusate io ho bisogno di questi file ma mi chiede nome utente e password, qualcuno mi può aiutare?
Grazie
#12
Link sistemati.

#13
grazie di cuore bovirus
#14
salve a tutti ho un problema con il mio router, premetto che ho fatto la procedure di recovery e una volta selezionato il firmware e mandato il comando sembra che carica il firmware ma dopo 5 minuti il router è come se non avesse caricato niente così ho provato con la procedura con cavo console ma mi si ferma dopo un po' di tempo. di seguito vi allego il log con la procedura con cavo console.


Freeing unused kernel memory: 72k freed
init started: BusyBox v1.00 (2008.10.14-02:31+0000) multi-call binary
Algorithmics/MIPS FPU Emulator v1.5
mount: Mounting none on /proc/bus/usb failed: No such file or directory


BusyBox v1.00 (2008.10.14-02:31+0000) Built-in shell (msh)
Enter 'help' for a list of built-in commands.


Loading drivers and kernel modules...

atmapi: module license 'Proprietary' taints kernel.
adsl: adsl_init entry
blaadd: blaa_detect entry
/proc/mcast_rate_limit created
Broadcom BCMPROCFS v1.0 initialized
Broadcom BCM6348B0 Ethernet Network Device v0.3 Oct 14 2008 10:24:11
Config Ethernet Switch Through SPI Slave Select 0
dgasp: kerSysRegisterDyingGaspHandler: eth0 registered
eth0: MAC Address: 00:24:01:4D:0A:71
PCI: Setting latency timer of device 0000:00:01.0 to 64
PCI: Enabling device 0000:00:01.0 (0004 -> 0006)
wl: srom not detected, using main memory mapped srom info (wombo board)
wl0: wlc_attach: use mac addr from the system pool by id: 0x776c0000
wl0: MAC Address: 02:24:01:4D:0A:71
wl0: Broadcom BCM4318 802.11 Wireless Controller 4.150.10.5.cpe2.0
dgasp: kerSysRegisterDyingGaspHandler: wl0 registered
BcmAdsl_Initialize=0xC005F3F8, g_pFnNotifyCallback=0xC0078204
AnnexCParam=0x7FFF7EB8 AnnexAParam=0x00000980 adsl2=0x00000000
pSdramPHY=0xA07FFFF8, 0x20000 0x0
AdslCoreHwReset: AdslOemDataAddr = 0xA07FCD04
AnnexCParam=0x7FFF7EB8 AnnexAParam=0x00000980 adsl2=0x00000000
dgasp: kerSysRegisterDyingGaspHandler: dsl0 registered
ATM proc init !!!
atmctl: page allocation failure. order:5, mode:0xd1
Call Trace: [<8005349c>] [<80053404>] [<800534fc>] [<8003e900>] [<c002597c>] [<c002685c>] [<c0026838>] [<801d0000>] [<c002672c>] [<c0027164>] [<c002931c>] [<800120d8>] [<c002ba10>] [<8007741c>] [<c0020ebc>] [<8007b510>] [<c001f090>] [<c0020e34>] [<c001f0b0>] [<c001f100>] [<c001f40c>] [<c001f470>] [<c001f5c0>] [<c001f6f0>] [<c001f7f4>] [<c001f8d0>] [<c001f9d8>] [<c001fb0c>] [<c001fc50>] [<c001fd88>] [<c001fe94>] [<c0020888>] [<c001ffcc>] [<c0020768>] [<c001f1ac>] [<c001f308>] [<c001fd58>] [<80081594>] [<8006c880>] [<8006c850>] [<8001a708>] [<8009b300>]
ATM Operation Failed , 4
atmctl: ATM driver return code, memory allocation error
atmctl: ATM driver return code, state error
atmctl: memory allocation error
atmctl: memory allocation error
atmctl: invalid vcc address '0.8.35'
atmctl: memory allocation error
atmctl: invalid vcc address '0.8.37'
ip_tables: © 2000-2002 Netfilter core team
ip_conntrack version 2.1 (61 buckets, 0 max) - 368 bytes per conntrack
ip_conntrack_pptp version 2.1 loaded
ip_nat_pptp version 2.0 loaded
ip_ct_h323: init success
ip_nat_h323: init success
insmod: cannot open module `/lib/modules/2.6.8.1/kernel/net/ipv4/netfilter/broadcom/ip_conntrack_ipsec.ko': No such file or directory
insmod: cannot open module `/lib/modules/2.6.8.1/kernel/net/ipv4/netfilter/broadcom/ip_nat_ipsec.ko': No such file or directory
BRCM NAT Caching v0.1 Jul 3 2007 10:16:19
BRCM NAT Cache: Hooking hit function @ c0084c48
ip_conntrack_rtsp v0.01 loading
ip_nat_rtsp v0.01 loading
ipt_time loading

==> Bcm963xx Software Version: WT_3-10-02-2Y00.A2pB022e.d20e.dlinkdleDSL-2640B <==

device eth0 entered promiscuous mode
br0: port 1(eth0) entering learning state
br0: topology change detected, propagating
br0: port 1(eth0) entering forwarding state
RTNETLINK answers: No such file or directory
HTB init, kernel part version 3.17
Setting SSID "InfostradaWiFi"
Setting country code using abbreviation: "IT"
wlctl: Not Found
wlctl: Not Found
wlctl: Not Found
channel 1 selected
device wl0 entered promiscuous mode
br0: port 2(wl0) entering learning state
br0: topology change detected, propagating
br0: port 2(wl0) entering forwarding state
BcmRfc2684_init interface is not up nas_0_8_35!
pvc2684ctl -a -v 0.8.35 -f &
pvc2684d: Interface "nas_0_8_35" created sucessfully

pvc2684d: Could not configure interface:Input/output error

Interface nas524323 already in use
SIOCSIFHWADDR: No such device
SIOCGIFFLAGS: No such device
interface nas_0_8_35 does not exist!
BcmRfc2684_init interface is not up nas_0_8_37!
pvc2684ctl -a -v 0.8.37 &
pvc2684d: Interface "nas_0_8_37" created sucessfully

pvc2684d: Could not configure interface:Input/output error

Interface nas524325 already in use
SIOCSIFHWADDR: No such device
SIOCGIFFLAGS: No such device
device eth0 left promiscuous mode
br0: port 1(eth0) entering disabled state
eth0.2: MAC Address: 00:24:01:4D:0A:71
eth0.3: MAC Address: 00:24:01:4D:0A:71
eth0.4: MAC Address: 00:24:01:4D:0A:71
eth0.5: MAC Address: 00:24:01:4D:0A:71
device eth0.2 entered promiscuous mode
br0: port 1(eth0.2) entering learning state
br0: topology change detected, propagating
br0: port 1(eth0.2) entering forwarding state
device eth0.3 entered promiscuous mode
br0: port 3(eth0.3) entering learning state
br0: topology change detected, propagating
br0: port 3(eth0.3) entering forwarding state
device eth0.4 entered promiscuous mode
br0: port 4(eth0.4) entering learning state
br0: topology change detected, propagating
br0: port 4(eth0.4) entering forwarding state
device eth0.5 entered promiscuous mode
br0: port 5(eth0.5) entering learning state
br0: topology change detected, propagating
br0: port 5(eth0.5) entering forwarding state
device wl0 left promiscuous mode
br0: port 2(wl0) entering disabled state
device wl0 entered promiscuous mode
br0: port 2(wl0) entering learning state
br0: topology change detected, propagating
br0: port 2(wl0) entering forwarding state
sntp: host not found
Done
Warning: Low memory condition - consider removing some software components
Warning: Low memory condition - consider removing some software components
Warning: Low memory condition - consider removing some software components
Warning: Low memory condition - consider removing some software components
Warning: Low memory condition - consider removing some software components
Warning: Low memory condition - consider removing some software components
Warning: Low memory condition - consider removing some software components
Warning: Low memory condition - consider removing some software components
Warning: Low memory condition - consider removing some software components
Warning: Low memory condition - consider removing some software components
Warning: Low memory condition - consider removing some software components
Warning: Low memory condition - consider removing some software components
Warning: Low memory condition - consider removing some software components
Warning: Low memory condition - consider removing some software components
Warning: Low memory condition - consider removing some software components
igmp: page allocation failure. order:0, mode:0xd2
Call Trace: [<8005349c>] [<80053384>] [<80068ee8>] [<8006a630>] [<800a700c>] [<8006a92c>] [<800a9434>] [<800a6f0c>] [<8006e60c>] [<800a1f44>] [<80054c74>] [<80064834>] [<800a5d44>] [<8005c0a4>] [<8004eae4>] [<800555dc>] [<8005b150>] [<8005b150>] [<8005672c>] [<800531f0>] [<80056be4>] [<8004f7d4>] [<8005fb2c>] [<8007b598>] [<8005fffc>] [<80020ac8>] [<80020a4c>] [<80069328>] [<80081c98>] [<801865d4>] [<801d0000>] [<80186d18>] [<8003ef0c>] [<8003f034>] [<8002526c>] [<8001a708>] [<8009b300>]
Error allocating memory for LitDecoder m_Coders!
CPU 0 Unable to handle kernel paging request at virtual address 00000004, epc == 800a7254, ra == 800a7690
Oops in arch/mips/mm/fault.c::do_page_fault, line 167[#1]:
Cpu 0
$ 0 : 00000000 1000fd00 00000004 00000008
$ 4 : 000000fd 00000000 00000000 801dc050
$ 8 : 00000000 00000000 00000400 8018af80
$12 : 801e0000 fffffffe 00000010 ffffffff
$16 : 801e0000 0000000c 801db6e8 00000005
$20 : 00001134 80519b28 8061c490 8061c5e0
$24 : 00000001 00000007
$28 : 80518000 80519a60 80519b48 800a7690
Hi : 00000000
Lo : 00002710
epc : 800a7254 Tainted: P
ra : 800a7690 Status: 1000fd03 KERNEL EXL IE
Cause : 0080000c
BadVA : 00000031
PrId : 00029107
Modules linked in: vnet iptable_raw ipt_time ipt_state ipt_mark ipt_limit ipt_iprange ipt_connlimit ipt_TCPMSS ipt_REDIRECT ipt_NOTRACK ipt_MASQUERADE ipt_MARK ipt_LOG ipt_FTOS ip_queue ip_nat_tftp ip_nat_snmp_basic ip_nat_sip ip_nat_rtsp ip_nat_irc ip_nat_ftp ip_conntrack_tftp ip_conntrack_sip ip_conntrack_rtsp ip_conntrack_irc ip_conntrack_ftp nat_cache ip_nat_h323 ip_conntrack_h323 ip_nat_pptp ip_conntrack_pptp ip_nat_gre ip_conntrack_gre iptable_mangle iptable_nat ip_conntrack iptable_filter ip_tables wl bcm_enet bcmprocfs br2684 blaa_dd adsldd atmapi
Process igmp (pid: 288, threadinfo=80518000, task=807790a0)
Stack : 801da500 00000090 801da508 8006a630 801e0000 801db6e8 00002000 00000005
800a7690 00000003 00000002 801db6e8 800a7034 80519b28 8061c490 00000002
00000000 801da53c 00000000 800a9434 004e21ac 00000000 00000000 00002000
801e0000 801db6d8 00002000 00000005 00001134 80519b28 8061c490 8061c5e0
80519b48 800a6f28 80519ae8 80519ae8 80514a7c 00000000 00000000 00001134
...
Call Trace: [<8006a630>] [<800a7690>] [<800a7034>] [<800a9434>] [<800a6f28>] [<800a1f44>] [<80054c74>] [<80064834>] [<800a5d44>] [<8005c0a4>] [<8004eae4>] [<800555dc>] [<8005b150>] [<8005b150>] [<8005672c>] [<800531f0>] [<80056be4>] [<8004f7d4>] [<8005fb2c>] [<8007b598>] [<8005fffc>] [<80020ac8>] [<80020a4c>] [<80069328>] [<80081c98>] [<801865d4>] [<801d0000>] [<80186d18>] [<8003ef0c>] [<8003f034>] [<8002526c>] [<8001a708>] [<8009b300>]

Code: 24a20004 240400fe 2484ffff <ac4a0000> 0481fffd 24420004 24c60001 28c20003 1440fff7
pppd: page allocation failure. order:0, mode:0x1d2
Call Trace: [<8005349c>] [<80053384>] [<80056b64>] [<8004f7d4>] [<8005fb2c>] [<8005f3d4>] [<8005fffc>] [<80020ac8>] [<80020a4c>] [<800bdf98>] [<800f491c>] [<801865d4>] [<80081594>] [<8002526c>] [<80012988>] [<8009b300>]
init: page allocation failure. order:0, mode:0x1d2
Call Trace: [<8005349c>] [<80053384>] [<80056b64>] [<8004f7d4>] [<8005fb2c>] [<8005fffc>] [<800886f0>] [<80086640>] [<80020ac8>] [<80020a4c>] [<80033c0c>] [<80099fb4>] [<80037390>] [<80037390>] [<8003919c>] [<80035880>] [<800ca8f4>] [<80032a70>] [<80032a70>] [<8002526c>] [<8001a708>] [<800105bc>] [<8009b300>]

cfm: page allocation failure. order:0, mode:0x1d2
Call Trace: [<8005349c>] [<80053384>] [<80056b64>] [<8004f7d4>] [<8005fb2c>] [<8005fffc>] [<80081c80>] [<80020ac8>] [<80020a4c>] [<80081c98>] [<80069728>] [<80082600>] [<800824b4>] [<8002526c>] [<8001a708>] [<8009b300>]
#15
Che revisione hardware hai? Che versione di firmware?
Che versione firmware vuoi installare?

L'aggiornamento non viene accettato, di solito, quando il nuovo firmware non è compatibile!
La prima cosa da leggere in questo forum | Siti globali D-Link

Siate CHIARI SINTETICI E DETTAGLIATI altrimenti non possiamo aiutarvi!!!

N.B. Purtroppo non ho il tempo di rispondere in PVT: 1) usa un motore di ricerca; 2) usa la funzione "Cerca" del forum; 3) chiedi nel forum. GRZ!!!
Questo forum non è un centro assistenza, ma una comunità.
Prima di chiedere a NOI di risolvere il problema che hai TU, chiediti come TU puoi dare una mano a TUTTI.

#16
allora ho un 2640b hw b2 il firmware installato è il wt 1.00 quello di infostrada e vorrei mettere un qualsiasi firmware basta ke mi funzioni perchè mi da il led power rosso e non mi accede alrouter
#17
(17-03-2011, 11:29)ladermo Ha scritto: premetto che ho fatto la procedure di recovery e una volta selezionato il firmware e mandato il comando sembra che carica il firmware ma dopo 5 minuti il router è come se non avesse caricato niente
(17-03-2011, 12:37)ladermo Ha scritto: ho un 2640b hw b2 il firmware installato è il wt 1.00 quello di infostrada
(17-03-2011, 11:29)ladermo Ha scritto: WT_3-10-02-2Y00.A2pB022e.d20e.dlinkdle
(17-03-2011, 12:37)ladermo Ha scritto: vorrei mettere un qualsiasi firmware basta ke mi funzioni perchè mi da il led power rosso e non mi accede alrouter

Se, quindi, il recovery ti funziona conviene aggiornare con un firmware sbloccato, cioè privo di firma.
(15-10-2008, 20:01)D-Link Forum Ha scritto: DSL-2640B rev. B2 - Firmware v. 4.00.310022900 (02.07.2008) Dlink UK - sbloccato x downgrade
La prima cosa da leggere in questo forum | Siti globali D-Link

Siate CHIARI SINTETICI E DETTAGLIATI altrimenti non possiamo aiutarvi!!!

N.B. Purtroppo non ho il tempo di rispondere in PVT: 1) usa un motore di ricerca; 2) usa la funzione "Cerca" del forum; 3) chiedi nel forum. GRZ!!!
Questo forum non è un centro assistenza, ma una comunità.
Prima di chiedere a NOI di risolvere il problema che hai TU, chiediti come TU puoi dare una mano a TUTTI.

#18
ok ora provo e ti faccio sapere
#19
eh no niente da fare ora non riesco + ad accedere al recovery
#20
ora nemmeno con il cavo console va......


Vai al forum:


Utenti che stanno guardando questa discussione: 2 Ospite(i)