21 Settembre 2020, 05:47:21

D-Link DNS-325 ShareCenter® 2-Bay Network Storage for Media Streaming

Aperto da Carciofone, 02 Luglio 2011, 06:55:55

Carciofone

In linea generale ti posso dire questo sul funzionamento del NAS:

1) in tutti i casi in cui il 325 mi ha segnalato un disk failure, aveva ragione. Ricordo in un ufficio che ci hanno sostituito 4 coppie di Caviar red da 2 TB che il nas non riusciva a formattare (acquistati da Yeppon). Alla fine funzionarono solo due  Caviar RED che ci spedì direttamente l'assistenza WD perchè Yeppon non volveva più fare i resi. Non ti dico che imballaggi pietosi che aveva fatto Yeppon per la spedizione e quindi sicuramente i dischi si erano danneggiati nel trasporto.

2) La procedura di ricostruzione del raid 1, dato che uno dei dischi, comuque si auspica funzioni, funziona così: si sostituisce sempre a macchina spenta il disco difettoso che al riavvio della macchina si viene richiesti di formattare dall'interfaccia web e, dopo aver disabilitato la funzione di ricostruzione automatica del raid, si potrà procedere alla ricostruzione manuale seguendo l'apposito menù.
Puoi trovare la guida passo passo con le immagini in tedesco qui: ftp://ftp.dlink.de/dns/dns-325/documentation/DNS-325_howto_reva_RAID1_wiederherstellen.pdf
ed in inglese per passi qui: http://support.dlink.ca/FAQView.aspx?f=cTRNt65a46Oy1aWId929bQ%3d%3d
Il punto fondamentale da capire è che i comandi aggiuntivi nel NAS appaiono solo quando un disco viene riconosciuto come completamente nuovo, sicchè se ad es si vuole riutilizzare un vecchio disco o quello che c'era prima io farei così: dopo averlo connesso ad un pc o a una dockstation per HD, rimuovi tutte le partizioni da Windows con uno dei programmi free che girano (ad es. EaseUS Partition Master) ed eventualmente in più lo riformatti in ntfs o fat32.
Al reinserimento nel NAS non dovrebbero esserci rischi per il disco superstite perchè il NAS dovrebbe proporre di riformattare SOLO il disco nuovo.
Suggerisco di effetture le ricostruzioni raid solo manualmente, perchè se ogni volta che il manca la corrente e il nas non si spegne correttamente venisse avviata la procedura automatica (che può durare ore) ...

3) La procedura più celere per copiare dati tra un volume1 e un volume2 è sicuramente tramite l'app File Personali dell'interfaccia web del nas, perchè è una procedura che non impegna la rete e può continuare anche se si chiude la finestra del browser di accesso al nas. Ovviamente può richiedere varie ore.

4) In generale la lettura dei file da ext4 è possibile anche da windows mediante questo programma: http://www.mambro.it/leggere-e-scrivere-partizioni-ext4ext3ext2-in-windows-10/
Ovviamente bisogna avere spazio su cui copiarli.
Esistono poi soluzioni proprietarie come queste: http://d-link.nas-recovery.software/

Starlooker

Citazione di: C@rciofone il 26 Novembre 2017, 10:53:35In linea generale ti posso dire .....

Riguardo alla sostituzione del disco danneggiato devo dirti che .... stavolta non ne vuole sapere di andare .Ho provato tutte le fomattazioni possibili nfts ext2 ext 3 ext 4 ,  nessuna formattazione e nessuna unita logica :NULLA ||

L'unica  procedura che attivail menu di riattivazione/formattazione  del raid e' questa :

- formattare il disco "da inserire"  , SOLO come volume  di raid O  poiché non compare opzione formatta se e' ancora presente il disco Raid 1 superstite/sano .

Una volta inserito il disco formattato e il disco sano , il sistema riconosce due dischi in raid zero volume 1 e volume 2-
Compare l'opzione formatta il nuovo disco inserito  con la spunta formatta in raid 1 .

Peccato che secondo lui il  " nuovo disco " sia quello pieno e non quello vuoto !!!

se inverti i dischi se ne accorge e  persevera nel voler formattare il medesimo disco !! quello buono !!

Io non ho mai avuto un disco danneggiato  ma alcune volte ho avuto l'allert Raid degraded .
TUTTE le volte e' stato un calvario  ripristinare e  non sempre compare il menu aggiuntivo e spesso confonde i volumi.

Ora tutto sarebbe NON grave se i messaggi di errore non fossero  di  pericolosa e idiotica ambiguità !

il disco ( i dischi )  appena inserito sta per essere formattato ( formattati )  e il disco esistente  sara' mantenuto. "

1) se hai appena fatto delle prove sulla integrita' dei dischi ..quale e' l'ultimo inserito ?
2) la procedura sta mostrando uno dei due dischi ; quale dei 2? quello nuovo  , quello vecchio , quello salvato , quello che sta per formattare ? che ne sappiamo ?

Inutile lamentarsi lo capisco ma visto che parliamo di articolo appositamente concepito per la SICUREZZA dei dati mi aspetterei ZERO pericoli  e NON un terno al lotto !!

Non mi rassegno a credere che non fosse stato possibile creare procedure più BOVINE  ma a prova di GNOCCO !!

Magari tipo quelle dei raid Motherbord  .

0 )Crea nuovo raid
1) Ricomponi ride
   - Disco dati slot X
   - Disco nuovo slot y

Poi i messaggi di errore !!
Attenzione  il disco slot X verra riversato su disco slot y - I dati su Y andranno perduti.

***** *** **
Come dicevo alla fine se copi a mano un disco pieno su quello vuoto ... poi puo' raidare come gli pare A su B o B su A chi se  frega !
Ma possibile che non ci sia un modo oltre che my file per copiarsi un disco formattato da dlink 325 ?  . ,, a velocita' di bus ?

Io se la trovassi mi toglierei tutti i pensieri e ... a Kukkulo tutti i programmatori e esperti ( ,,..de che ?? ) dell' assistenza dlink .
Ho un pc con diverse slot sata III  , se potessi inserire i due dischi e copiarli  o " immaginarli  " uno sull'altro .
Magari Booto da cd Ubuntu ..

Ho provato con my file interno al nas , ma me ne ha copiati la meta' anche se li avevo selezionati tutti e ci ha messo quasi 2 giorni !! Io dico che si poteva precedere un applicazione di disc managment  migliore no ??

Se avete qualche idea fatemi sapere .
Intanto provo e verifico i link ricevuti.

Grazie per i consigli ricevuti e magari per i prossimi .

Carciofone

Immagino la tua frustrazione, anche con riferimento all'imprecisione dei messaggi guida.
La procedura di copia che vuoi seguire tu da disco "buono" ext4 a disco nuovo riformattato temo sia possibile a quel punto solo sotto linux, perchè solo linux scrive correttamente su quel FS, in cui ad es non esiste un limite alla lunghezza dei nomi e dei percorsi files e ii nomi files sono diversi se scritti in maiuscole e\o minuscole.
Sicuramente la cosa dovrebbe essere possibile usando anche una distro live e montando manualemnte i due dischi sul controller di un pc.
La volta che affrontai il problema di dover mandare in assistenza i caviar sicuramente procedetti alla ricostruzione del raid secondo le istruzioni della guida tedesca, perchè ricordo che alla fine uno dei dischi funzionava e l'altro fu spedito a wd e nelle more dell'invio del nuovo disco, il nas era regolarmente operativo con un disco solo.

Inoltre uno dei mod mi ha ricordato di aver affrontato con successo il problema della ricostruzione del RAID1 in passato con il DNS-320 e suggerisce di non mettere nel NAS un disco nuovo formattato, bensì non formattato e senza partizioni (a differenza di quanto ti ho suggerito sinora). Sul resto della procedura, poi, serve un atto di fede, nel senso che si dà per presupposto che la procedura non sbagli disco da formattare, ovviamente e per far questo il disco buono non va rimosso dal suo slot originario e se lo si è fatto si può provare a ripristinare la situazione inserendolo nello slot originario e lasciano vuoto l'altro. All'accensione tutti i files dovrebbero essere accessibili.
Link: https://www.dlink-forum.info/index.php?topic=2525.msg26430#msg26430

PS: comunque i 3 GB di film, ancora non sono persi, dài ...  ;)

m4ss1

Citazione di: C@rciofone il 27 Novembre 2017, 10:47:08Inoltre uno dei mod mi ha ricordato di aver affrontato con successo il problema della ricostruzione del RAID1 in passato con il DNS-320 e suggerisce di non mettere nel NAS un disco nuovo formattato, bensì non formattato e senza partizioni (a differenza di quanto ti ho suggerito sinora).

Confermo, ho da poco ripetuto l'operazione con il DNS-320L e il nuovo disco non deve avere partizioni.
Per eliminarle ho usato il programma gratuito MiniTool Partition Wizard Free Edition.

Starlooker

Io ho usato  Gparted , ho provato
- nessuna formattazione
- no partizioni
- si partizioni
- formattazione nfts
.ext3
- ext4

LO VEDE MA NON CHIEDE DI FORMATTARLO. Lo chiame Volume 2  ..e non lo legge !!
..........................
Ma poi perché tante MESSE ??? un disco e' un disco !! Perché DNS 325 non se lo formatta da solo senza tante cincischie e fa quanto dovuto ? ?
........................
n.b. ho un 325  , ho gia' visto che il sotware del 320 sembra un po piu' evoluto .

Grazie comunque in ogni caso per il consiglio e l'aiuto.

RossanoG

Citazione di: C@rciofone il 17 Febbraio 2014, 11:42:58
Citazione di: gever il 09 Febbraio 2014, 08:35:48
Citazione di: gever il 07 Dicembre 2013, 11:42:05la velocità di trasmissione e scrittura e lettura tra nase pc mi sembra lenta non supera il 1MB sec è corretto?
devo correggere qualche parametro?
la rete è a 100 MB via cavo

nessuno mi sa rispondere?

Rileggendo i vari interventi riformulo meglio la domanda:
avevo acquistato i segenti due hd Western Digital
WD Caviar Green WD20EARS SATA 3G 2 TB
trovandoli nell'elenco compatibilità.
da una rilettura degli interventi sembrerebbe che i dischi NON siano compatibili, o meglio non danno la "risposta giusta". E' esatto?
Quindi per modificare le prestazioni dovrei sostituire gli HD con modelli corretti? e a questo punto quale comprare?
Anche con questi dischi è praticamente impossibile che si possano ottenere risultati così scarsi, 1 Mbyte\s significa un collegamento a 10 Mbit, non a 100 e neanche gigabit. Quindi, o stai usando una powerline, o c'è qualche problema hardware dei cavetti che usi, oppure qualcuna delle interfacce ethernet (del pc, del nas o dello switch) è forzata sui 10 Mbit.
Controlla le impostazioni del driver della scheda del pc e anche del NAS che non sia configurato per i 10 Mbit (in Network Management\LAN Setup\Link Speed).

Hai poi risolto il problema della lentezza?
Il mio NAS 325 è collegato al router di Fastweb a Giga
Se scarico i miei file via mydlinkcloud la velocità è lentissima, scarico a 250 Kb/s
E' lento solo via web dall'esterno, perchè in locale scarico come una lippa (20 Mb/s)
E' forse il servizio mydlinkcloud che strozza il download?
Grazie
Rossano

Alby

Penso dipenda dall'uso di mydlinkclaud: richiede l'upload e l'accesso dei dati al nas e il download tramite la stessa linea peraltro.
Che linea internet hai con Fastweb?

m4ss1

Revisionato primo messaggio: ripristinate immagini e video.

valterdati

salve volevo sapere se e compatibile il mio dns-325 con questo hddST2000DM006 dato che nella lista non ho trovato riferimento su questo modello la lista ho visto che e aggiornata al 2015
S.operativo : Win7 64

Nas : dns-325

Nas: firmware corrente 1.04b02

Carciofone

Ti converrebbe aggiornare al firmware 1.05B09 che garantisce un migliorato supporto al file system ext4 e varie correzioni di bugs.
Dopo l'upgrade dovrai riconfigurare utenti, gruppi e password di accesso al nas. Il reset del nas con i dischi dentro già pieni di dati non comporta mai la cancellazione degli stessi, ma solo la modifica dei diritti di accesso ai file i quali vengono resettati.
Per esperienza ti posso dire che non ho finora trovato hd di produttori di prima fascia (WD, Hitachi, Seagate, Thoshiba, Maxtor etc ) incompatibili con questo nas. L'unico che ha dato problemi è stato un hd di marca cinese Kingspec.
Eventualmente acquistalo in uno store online come amazon, cosi nell'eventualità lo puoi restituire nei 14 giorni.

Andy69

Buongiorno a tutti
sono nuovo del forum e vi scrivo per chiedere un aiuto in merito al DNS 325. Durante la procedura di configurazione iniziale non riesco a superare la pagina della richiesta password. Il campo user è admin il campo pwd, sia che lo lasci vuoto sia che inserisca la mia vecchia password non vuole funzionnare. Ho provato a resettare diverse volte con una graffetta sul lato posteriore, aspettando dai 5 ai 30 secondi ma sembra che non funzioni. Il led di power on resta fisso bianco (ho letto dovrebbe diventare verde o lampeggiare) e nulla cambia nella richiesta pwd. Anche accedendo via web browser la frase è sempre la stessa
Login fail, please try again or leave the password blank.
Potete suggerirmi come procedere? 
Grazie in anticipo
Andrea

Claxba

Buongiorno a tutti, ho un problema da risolvere e spero nel vostro prezioso aiuto. Vorrei poter accedere al nas da remoto ma sul sito "mydlink" non è contemplato questo modello per la configurazione guidata. Qualcuno può dirmi come si può fare in alternativa. Magari con qualche altro servizio/software. Grazie a tutti per l'attenzione.
Claudio

Carciofone

A questo modello non si accede tramite il sito, ma tramite una connessione diretta utilizzando l'ip pubblico o il dlinkddns ed un'interfaccia web stile mydlink.

gunda

Ciao Ragazzi,
sapete darmi qualche dritta riguardo la configurazione con win10? Da un paio di mesi win non mi fa più accedere al nas, da qualsiasi pc ove è intallato win10. Ho notato però che su un altro, dove ho win7 la connessione prosegue senza problemi, così come da qualsiasi altro dispositivo collegato in rete.

Grazie

m4ss1


geek.roma

buonasera ho pc e nas connessi in LAN, entrambi negoziano la velocità a 1.0Gb/s, ma la velocità di trasferimento(quindi di scrittura) di un file dal pc vs il nas non supera il 15-18mb/s sapete come mai ?
Grazie

Carciofone

Su quello che ho attualmente installato e collegato ad uno switch professionale a 36 porte rilevo allo stato velocità di trasferimento superiori ai 76 Mbytes\s con una media attorno ai 70.
La configurazione prevede un Raid1 e dischi WD Caviar Red per NAS, robusti, ma non velocissimi.
Ho in genere verificato che se i PC dialogano in rete tramite jumbo packet e questi non sono ben calibrati tra tutti i dispositivi e lo switch, la velocità cala notevolmente probabilmente a causa della necessità di buffering e riassemblaggio del pacchetto.
In definitiva io suggerirei: verifica della versione firmware e aggiornamento all'ultima disponibile, dopodichè verifica del file system di formattazione dei dischi del NAS che con questo modello è stato aggiornato dall'originale ext3 a axt4 ed eventuale riformattazione di dischi.
Poi disabiliterei i jumbo pachet su tutti i dispositivi connessi alla rete. Verificherei infine che i colli di bottiglia non siano altri, ossia dischi del NAS lenti, oppure anche dischi del pc in uso lenti. Ad es. gli HD dei portatili con qualche anno leggono e scrivono alle velocità di cui parli e quindi se questo fosse il caso non si tratterebbe di un problema di rete o del NAS, quanto della lentezza del disco di partenza o di arrivo dei dati rispetto al NAS.
Eventualmente indica i modelli dei vari dispositivi che facciamo una ricerca più approfondita.

geek.roma

Citazione di: Carciofone il 19 Aprile 2020, 12:37:01Su quello che ho attualmente installato e collegato ad uno switch professionale a 36 porte rilevo allo stato velocità di trasferimento superiori ai 76 Mbytes\s con una media attorno ai 70.
La configurazione prevede un Raid1 e dischi WD Caviar Red per NAS, robusti, ma non velocissimi.
Ho in genere verificato che se i PC dialogano in rete tramite jumbo packet e questi non sono ben calibrati tra tutti i dispositivi e lo switch, la velocità cala notevolmente probabilmente a causa della necessità di buffering e riassemblaggio del pacchetto.
In definitiva io suggerirei: verifica della versione firmware e aggiornamento all'ultima disponibile, dopodichè verifica del file system di formattazione dei dischi del NAS che con questo modello è stato aggiornato dall'originale ext3 a axt4 ed eventuale riformattazione di dischi.
Poi disabiliterei i jumbo pachet su tutti i dispositivi connessi alla rete. Verificherei infine che i colli di bottiglia non siano altri, ossia dischi del NAS lenti, oppure anche dischi del pc in uso lenti. Ad es. gli HD dei portatili con qualche anno leggono e scrivono alle velocità di cui parli e quindi se questo fosse il caso non si tratterebbe di un problema di rete o del NAS, quanto della lentezza del disco di partenza o di arrivo dei dati rispetto al NAS.
Eventualmente indica i modelli dei vari dispositivi che facciamo una ricerca più approfondita.
Nel pc come valore di jumbo frame per la scheda di rete lan ho 9KB MTU, disponibile come valore massimo.
Il PC ha un ssd samsung 860 Evo da 500Gb, ma la copia o lo spostamento di elementi è lento anche da nas/nas.
La versione del fw del nas è l'ultima disponibile ufficiale D-Link la 1.05, i dischi sono questi ne ho due da 2TB l'uno configurati in raid 1.
Non avendo mai utilizzato i dischi con versioni di fw inferiori credo che siano formattati in ext4.
I cavi lan utilizzati sono tutti almeno cat 5E.
Ti ringrazio

Carciofone

I dischi sono ottimi ed effettivamente un dta transfer così basso non sembra giustificato.
Hai già provato a disabilitare i jumbo frame?
Il NAS risulta connesso allo switch a 1000 Mbps?

Licenza Creative Commons
Il contenuto dei messaggi del forum è distribuito con
Licenza Creative Commons Attribuzione Non commerciale 4.0
Tutti i marchi registrati citati appartengono ai legittimi proprietari