14 Novembre 2019, 05:19:30

DSL-2640R + DIR-300: creare un hotspot WiFi con HotSpotSystem

Aperto da Plutus, 17 Marzo 2012, 18:00:17

Plutus

Ciao a tutti, mi sono appena iscritto anche se vi seguo da un po' di tempo... Prima di tutto vorrei farvi i complimenti per la precisione nelle risposte, spesso mi hanno dato un grosso aiuto!
Vengo al dunque: ho un modem/router 2640r a cui collego un bel po' di roba ed un DIR-300 nuovo nuovo con firmware dd-wrt rel. 14311.
Ecco cosa vorrei fare: con il 2640r (ip 192.168.1.1) rete domestica, internet... insomma così come è adesso, mentre col DIR-300, collegato con cavo eth al 2640r, vorrei creare un hotspot wifi usando hotspotsystem.
Come devo impostare i 2 apparecchi?
Grazie ;)

Pondera

La prima cosa da leggere in questo forum | Siti globali D-Link

Siate CHIARI SINTETICI E DETTAGLIATI altrimenti non possiamo aiutarvi!!!

N.B. Purtroppo non ho il tempo di rispondere in PVT: 1) usa un motore di ricerca; 2) usa la funzione "Cerca" del forum; 3) chiedi nel forum. GRZ!!!
Questo forum non è un centro assistenza, ma una comunità.
Prima di chiedere a NOI di risolvere il problema che hai TU, chiediti come TU puoi dare una mano a TUTTI.

Plutus

Citazione di: Pondera il 17 Marzo 2012, 20:04:49Inizia a guardare qui di seguito:

http://aranzulla.tecnologia.virgilio.it/come-creare-un-hotspot-wifi-18972.html

Grazie mille per la risposta... avevo già letto quell'articolo, infatti ho preso spunto proprio da lì per arrivare al punto in cui sono.
Ho già messo il dd wrt (14311) nel DIR-300 ma il mio problema adesso è un altro.
Come lo collego al 2640r in modo tale da avere questa situazione: 2640r che gestisce la rete domestica+internet wifi con indirizzi statici 192.168.1.1-19 e DHCP da 192.168.1.20 in poi; DIR-300 collegato in lan al 2640r che gestisce l'hotspot wifi con indirizzi 192.168.2.xxx.
Ovviamente la rete 192.168.1.xxx è protetta con wpa2 e deve rimanere inaccessibile, mentre la 192.168.2.xxx è libera per gli accessi alll'hotspot.
Spero di non essere stato troppo confusionario :s e se esiste qualcosa di più semplice meglio ancora :D
Grazie

m4ss1

L'hai configurato bene ma quando hai detto "DIR-300 collegato in lan al 2640r" forse volevi dire porta Internet (WAN) del DIR-300 collegata in LAN del 2640r ;)

Plutus

Citazione di: m4ss1 il 18 Marzo 2012, 12:59:20L'hai configurato bene ma quando hai detto "DIR-300 collegato in lan al 2640r" forse volevi dire porta Internet (WAN) del DIR-300 collegata in LAN del 2640r ;)
In pratica al 2640r ho attaccato un cavo eth alla porta 4 e lo stesso cavo alla porta 1 del DIR-300. E' corretto?
devo abilitare/disabilitare qualcosa nei due router in modo da avere la configurazione di cui parlavo nel mio post precedente? Così non funge :(

P.S. ho capito adesso di aver sbagliato il collegamento... proverò per come mi hai detto LAN to WAN, ma poi devo settare qualcos altro?


m4ss1

Citazione di: Plutus il 18 Marzo 2012, 20:26:04P.S. ho capito adesso di aver sbagliato il collegamento... proverò per come mi hai detto LAN to WAN, ma poi devo settare qualcos altro?

Si, devi impostare la sezione WAN del DD-WRT.
Puoi  lasciarla su "DHCP" o impostare un indirizzo IP statico, deve essere della classe del dsl quindi 192.168.1.xxx

PS. Dimenticavo ... il dir impostalo su 192.168.2.1, l'importante è che non abbia la stessa classe del dsl

Plutus

Citazione di: m4ss1 il 19 Marzo 2012, 09:14:08
Citazione di: Plutus il 18 Marzo 2012, 20:26:04P.S. ho capito adesso di aver sbagliato il collegamento... proverò per come mi hai detto LAN to WAN, ma poi devo settare qualcos altro?

Si, devi impostare la sezione WAN del DD-WRT.
Puoi  lasciarla su "DHCP" o impostare un indirizzo IP statico, deve essere della classe del dsl quindi 192.168.1.xxx

PS. Dimenticavo ... il dir impostalo su 192.168.2.1, l'importante è che non abbia la stessa classe del dsl

Grazie mille! Provo subito questa configurazione e aggiorno la discussione... Magari può essere utile anche a qualcun altro ;)

Plutus

Niente da fare... non riesco a fare funzionare l'hotspot!
Questa è la situazione:

dsl-2640r ---> ip: 192.168.1.1 / dhcp on da xxx.20 a xxx.100
dir-300 ---> ip: 192.168.20.1 / dchp on da xxx.10 a xxx.49 / wan con ip statico 192.168.1.30

Con questa configurazione riesco a connettermi alla rete wifi del dir-300 ma non riesco a navigare su internet. La cosa strana è che il power led del dir-300 è arancione! Se invece imposto dhcp su off nel dsl-2640r e dhcp on nella sezione wan del dir-300, il power led torna verde ma internet continua a non funzionare!
Ho fatto anche la prova a disattivare il dhcp nel dsl-2640r e ad assegnare un indirizzo ip statico (192.168.1.30) al wan del dir-300 ma il power led è sempre arancione e internet non va.
Non so cos'altro fare... idee?


Plutus

sono riuscito finalmente a far funzionare hotspotsystem!
Ho assegnato l'inidirizzo 192.168.20.1 al dir-300 con dhcp abilitato da x.100 a x.149
Il dhcp della wan è abilitato ed assegna automaticamente indirizzi da 192.168.1.20 in poi, così come impostato sul 2640r a cui il dir-300 è collegato.
Adesso vi chiedo, esiste una soluzione gratuita che consenta di limitare la navigazione web solo ad alcuni siti? Opendns offre questo servizio ma la personalizzazione della blacklist è a pagamento... alternative? Grazie

P.S. il power led del dir-300 rimane comunque arancione!

Licenza Creative Commons
Il contenuto dei messaggi del forum è distribuito con
Licenza Creative Commons Attribuzione Non commerciale 4.0
Tutti i marchi registrati citati appartengono ai legittimi proprietari