26 Settembre 2020, 04:42:30

DSL-2740B E1 - Modem Router ADSL2+ Wireless N 300

Aperto da Carciofone, 03 Maggio 2010, 15:09:57

Marko

Un saluto a tutti ed in particolare a Carciofone che merita un saluto particolare.
Citazione di: C@rciofone dateline=1275468876Nuovo firmware Beta EU_DSL-2740B_5.17b20100526(0527104137) per versione hardware E1
La prima impressione di uso del nuovo firmware beta è decisamente buona e  le cose che avevamo segnalato sono state corrette.
Ho installato il nuovo firmware beta e queste sono i miei risultati, impressioni rispetto alla verisone ufficiale firmware EU_DSL-2740B_5.17b49 dell'08 marzo 10.
Premetto che ho Alice 7 mega.
Citazione1) Time & Date e varie scheduling: si aggiornano normalmente dai server internet e l'ora legale funziona regolarmente (se avviene la connessione)
nessuna differenza rilevata rispetto al precedente firmware. L'aggiornamento dell'ora funzionava e funziona.
Citazione2) PPPoE LLC MTU 1492, si connette regolarmente su Alice 7 mega Telecom, come pure PPPoA VC MTU 1500 non dà problemi. Abilitando la funzione SRA nelle opzioni avanzate Internet la connessione non è più stata possibile, ma di default è disabilitata, quindi potrebbe essere che lo dslam in centrale non la supporti, oppure che non funzioni anche se abilitata sul modello C2. Questo non lo so dire.
nessuna differnza rilevata rispetto al precedente firmware.
Io non ho problemi solo con PPPoE LLC MTU 1492 (8-32), mentre con PPPoA VC MTU 1500 mi dice che è connesso, ma non navigo in internet.
La funzione SRA ce l'ho abilitata e non dà alcun problema. Non so se apporta miglioramenti o meno, ma funziona.
Citazione3) Il DHCP sembra assegnare regolarmente i DNS ai client collegati, sia se la connessione è PPPoA, sia se è PPPoE e non ho avuto bisogno di assegnare i DNS manualmente a nessun PC con Windows Vista\7.
nessuna differenza con il precedente firmware. Problema non rilevato nè prima nè ora.
Citazione4) Il MAC filter wireless funziona regolarmente con la classica politica Deny all esclusi i MAC adress nella lista.
Prima di sicuro non funzionava il MAC filter, ora non l'ho ancora testato, lo farò presto.
Citazione5) WPA2 AES in modalità mista BGN con canali radio 20\40 Mhz funziona senza problemi.
..anche prima funzionava senza problemi.
CitazioneSi avvisano gli utilizzatori che esistono due distinte pagine di configurazione della rete wireless principale e Guest, la quale ultima è a sua volta criptabile e usabile come secondo SSID a tutti gli effetti.
Questa è una cosa che dovrebbere specificare meglio tra le opzioni perchè non è molto intuitiva. Lo avevo appreso da te.
In tutti i casi il secondo SSID funzionava bene prima e funziona bene ora, anche riavviando il router. Questo lo preciso perchè qualcuno sosteneva che riavviando il router il secondo SSID si doveva reimpostare. A me questo non è mai successo.
Citazione6) Al riavvio si riconnette regolarmente, ma mi pare di notare che anche impostando un tempo di idle diverso da 0 come ad es 10 min non avviene in realtà alcuna disconnessione, perchè l'ip rimane lo stesso anche dopo ore a pc spento (ma è una cosa da verificare nel tempo).
Nessun problema da segnalare
Citazione7) L'unico evento di categoria "Emerg" segnalato dal log in modalità debug è questo:
Jan 1 00:00:06   syslog   emerg   BCM96345 started: BusyBox v1.00 (2010.05.26-14:59+0000)
anche con il firmware ufficiale, a parte la data diversa (2010.03.05) vi era solo questo messaggio nella categoria "Emerg".
Citazione8) L'interfaccia web di configurazione risulta nel complesso più reattiva e funzionale rispetto alle precedenti versioni, con l'unico appunto già segnalato da vari lettori che la scritta in basso delle pagine riporta "Copyright © 2005-2007 D-Link Systems, Inc." pur trattandosi di un prodotto nuovissimo.
Non noto differenze rispetto a prima

Invece, ho segnalare che:

- l' "Isolation AP" per la seconda rete wifi (GUEST) non funziona, nel senso che non isola tale rete da quella principale e quindi anche se spuntata tale opzione "gli ospiti" accedono lo stesso ai computer della rete principale.
Questo problema c'era prima e continua ad esserci.

- le traduzioni nelle varie lingue lasciano ancora molto a desiderare, meglio toglierle se non si è in grado di trascrivere quattro righe nelle varie lingue. Ci si fa più bella figura.

- non c'è verso di far funzionare la Wake on LAN da WAN (cioè da internet), mentre funziona all'interno della LAN
Giustamente per motivi di sicurezza i pacchetti in broadcast non passano, anzi non è proprio possibile inserire l'indirizzo broadcast. E questo, anche secondo me, è un bene che ci sia tale limitazione per motivi di sicurezza.
Ma, a mio avviso,  è auspicabile che venga data la possibilità come opzione di poter abilitare tale utile servizio su un indirizzo IP interno da scegliere e che venga registrato sulla memoria non volatile e non solo nella tabella ARP, in quanto se il computer è ovviamente spento non è registrato in tale memoria volatile.
Si tratta solo di inserire una opzione in più, come per altro su altri router. Sarebbe un peccato rinunciare a tale bel router solo perchè "i tecnici" non ci hanno messo una opzione che per alcuni necessaria.
 
- un'altra cosa che non funziona è la VPN di Windows 7 su WAN. Non c'è verso di fala funzionare con questo router. Anche qui contemplare tale servizio e metterci una opzione specifica nel menu per tale utile funzione sarebbe gradita.

Per il momento è tutto, tests in progress.

Infine avrei da fare due domande:
1) come si leggono i numeri del firmware? Ad intuito interpreto così:
EU_DSL-2740B_5.17b20100526(0527104137)
- EU-> dovrebbe significare per l'Europa
- DSL-2740-> è il modello del router
- B-> dovrebbe indicare il chipset Broadcom
- 5.17-> versione del firmware principale
- b-> built sotto versione del firmware
- 20100526-> la data capovolta 26 05 2010
- 052710-> la data all'americana (mese,giorno,anno) 27 05 10
- 4137-> l'ora ?? o esattamente cosa?

2) a quale indirizzo e-mail e chi bisonga contattare dei tecnici della D-Link per mandare loro direttamente osservazioni e proposte in merito a tale router?

Grazie per l'attenzione, mi scuso per il lungo post ed un cordiale saluto a tutti. Ciao.

frfabi

per scrivere direttamente all D-Link, bisogna registrarsi al Portale Self-Service D-Link qui =>  http://www.dlink.it/cs/Satellite?c=Page&childpagename=DLinkEurope-IT%2FDLTechGeneric&cid=1197382037841&pagename=DLinkEurope-IT%2FDLWrapper#

In bocca al lupo :)

Carciofone

Ciao  Marko, ben venuto (immagino MarkoRussinuovo).
Ti ringrazio per il tuo report preciso e circostanziato.
Comincio subito col dire che la denominazione del firmware è del tutto anomala rispetto ai soliti standard, ma la fonte sono gli sviluppatori, quindi si tratta di una release beta di passaggio che però ha parecchie novità e risolve, se non altro i problemi più grossolani del firmware. Diciamo che, probabilmente, se il router fosse stato inscatolato con questo firmware dentro, il 90% del malcontento creatosi negli utenti non ci sarebbe stato. Sbaglio?

Riguardo al punto 2) e 3) e la connettività PPPoE LLC, a me non ha mai funzionato l'assegnazione dei DNS col DHCP se non saltuariamente una volta sola. Poi, complici, forse, anche problemi di interfaccia, senza un reset globale non sono mai stato in grado di switchare tra PPPoE e PPPoA con il router che riuscisse a connettersi. Il problema, a mio parere stava nel fatto che il DHCP non assegnava i DNS automaticamente e il router era connesso, ma la navigazione bloccata se non venivano impostati i DNS manualmente o sul router o sul PC. La mia centrale si appoggia su Dslam Alcatel-Thomson, per questo ho ventilato la possibilità di un'incompatibilità anche riguardo alla funzione SRA, che però con il C2 non sembra avere problemi (a meno che, come ho detto nel post non sia proprio ignorata).

Riguardo alla rete Guest il funzionamento che descrivi dopo un riavvio è corretto e nell'ottica di un vero e proprio SSID. Invece mi devo scusare sulla cosa del Isolation AP, perchè non avevo colto dai tuoi post questo problema che non è, quindi, stato segnalato.
Merita di essere approfondito e testato per vedere cosa occorre aspettarsi da tale funzione.
In particolare:
1) funziona se attivato nella rete principale?
2) se attivato i pc si rilevano, ma non accedono gli uni agli altri, oppure accedono con esplora risorse di rete?
3) idem per la rete guest e tra rete guest e principale, perchè altrimenti il tutto si ridurrebbe ad un'unica rete wlan con 2 password di accesso.
Quanto al WOW, hai già provato a portare il lease time del dhcp ad es a 240 h (10 gg) in modo che la taella ARP (se il router non viene spento, mantenga l'associazione ip\MAC?

Spidermac

Uhm.... l'unica cosa che mi viene in mente è una possibile incompatibilità del browser Safari con gli script dell'interfaccia web. Verifica di avere la versione più aggiornata, di non avere qualche add-on o antivirus che blocchi l'esecuzione degli script (su Firefox ad es. c'è NoScript e altri) e di avere l'ultima versione della Java RE (16.20 mi pare).
Comunque i DNS li devi mettere NON nel router, ma nelle proprietà avanzate della scheda di rete del MAC che si connette al router.

ciao C@rciofone, ho installato la nuova beta del firmware e ho risolto i problemi, ora viaggio tranquillamente, si vede che sulla release precedente sul Mac non funzionava bene, avrei un ultima domanda: il bottone sul fianco che emana luce blu all'accensione serve per il wireless veloce, mi potresti spiegare meglio non ho capito l'utilità.... un grazie in anticipo per la disponibilità.
Chi non sa impara......basta umilmente chiedere

Alby

Ti rispondo io sul WPS.  ;D
In pratica serve per agevolare la connessione di nuove periferiche wireless senza dover inserire manualmente la password della tua rete protetta.
1) Vai in Setup\Wireless Setup e clicchi su ADD WIRELESS DEVICE WITH WPS, scegli Auto e se la scheda di rete ha il tastino WPS lo premi e poi scegli PBC e Connect. Il router rimane in attesa di segnali dalla scheda di rete per 120 sec.
2) Se la scheda di rete non ha il tastino può essere che il driver di Windows abbia la stessa funzione e quando scegli la rete e clicchi su Connetti nel PC funziona allo stesso modo che premerlo sulla scheda stessa.

Il tasto blu sul router fa lo stesso identico lavoro del punto 1) sul router, ma senza entrare nei menu. Ovviamente ill WPS deve essere attivato in Advanced\Wi-Fi Protected Setup e la protezione wireless già impostata.


frfabi

Risposta della D-Link sul port fowarding sull'indirizzo di broadcast .255 per la versione hardware E1:

Gentile Cliente,
siamo spiacenti ma ribadiamo quanto giá detto. L´inoltro delle porte non puó essere girato sull´indirizzo di broadcast. Il prodotto in questione non é in grado di effettuare la Wow.
Cordiali saluti,
D-Link

Tralaltro sostengono che non era neanche possibile farlo con la revisione hardware C2:

Gentile Cliente,
quanto da lei descritto nelle vecchie versione di hardware non ci risulta poiché l´inoltro delle porte non puó essere girato sull´indirizzo di broadcast, in quanto essendo tale non puó essere utilizzato.
Cordiali saluti,
D-Link

Non credono che nelle prossime revisioni del firmware metteranno qualcosa....

Ciaoooo

Alby

Peccato, ma prevedibile. Troppo grosso un bug di sicurezza che consentisse un inoltro di pacchetti in broadcast all'interno dell lan. Qualcuno ha già provato la cosa di portare a 240 le ore del lease del dhcp?

Marko

@carciofone, @Alby, @frfabi et at utti
Ragazzi, vi ringrazio delle risposte e dell'interessamento, siete veramente molto gentili.
Ho riletto il post scritto ieri e mi scuso per tutti gli errori di battittura e grammaticali che ci sono, ma non ho molta dimestichezza nello scrivere sul forum, mi auguro cmq che si capisca il senso, altrimenti ripeto in termini più "italiani".

Intanto ho notato una differenza tra il firmware 5.17 e quello beta. Con quest'ultimo hanno inserito una opzione in più nel scheda Port Forwarding: la colonna, con relative opzioni, di Imbound Filter che prima non c'era.
Ecco gli screen shot di confronto:

firmware 5.17


firmware 5.17 beta



CitazioneRiguardo alla rete Guest il funzionamento che descrivi dopo un riavvio è corretto e nell'ottica di un vero e proprio SSID.
Invece mi devo scusare sulla cosa del Isolation AP, perchè non avevo colto dai tuoi post questo problema che non è, quindi, stato segnalato.
Merita di essere approfondito e testato per vedere cosa occorre aspettarsi da tale funzione.
In particolare:
1) funziona se attivato nella rete principale?
2) se attivato i pc si rilevano, ma non accedono gli uni agli altri, oppure accedono con esplora risorse di rete?
3) idem per la rete guest e tra rete guest e principale, perchè altrimenti il tutto si ridurrebbe ad un'unica rete wlan con 2 password di accesso.
Si, l'"AP Isolation" se viene attivato nella rete wifi principale funziona, nel senso che isola ciascun computer collegato alla rete da tutti gli altri collegati. I computer si vedono nella mappatura della rete e vengono graficamente rappresentati da Windows 7 in una posizione fuori dalla rete e tali computer, ovviamente risultano inaccessibili. Quindi, mi pare, che il comportamento sia corretto.
La stessa cosa, invece, non succede se si attiva l'"AP Isolation" nella seconda rete wifi disponibile (quella chiamata GUEST).
Per il mio utilizzo non ho attivo l'AP Isolation sulla rete wifi principale perchè i computer connessi si devono scambiare i dati, ma ho provato ad attivarla e funziona.
Mentre se attivo la seconda rete wifi GUEST per dare accesso temporaneo, condizionato e limitato agli ospiti, spuntando la sua opzione "AP Isolation" questa non isola proprio niente e come se si stesse nella rete principale. In pratica un unica rete con due accessi diversi e non due reti distinte.

Questa è la mappatura della rete fatta da Windows 7:




Citazioneper scrivere direttamente all D-Link, bisogna registrarsi al Portale Self-Service D-Link [COLOR="Navy"]qui[/COLOR]
Grazie, mi ero già registrato a quel portale per effettuare la registrazione del prodotto in topic che avevo appena comprato in una catena di informatica.
Quando sono andato ad inserire il seriale per la registrazione, mi veniva detto il seriale era sconosciuto e che non era registrabile. Ho provato diverse volte, ma non sono riuscito nemmeno a registrare il prodotto. E vi assicuro che i numeri erano digitati correttamente.
Non so se anche a qualcun altro è successa la stessa cosa. Inoltre su tale prodotto non viene data l'estensione di garanzia dei 5 anni, anche se nelle istruzioni c'è scritto che se si registra il prodotto si godrebbe di tale garanzia. Quindi dovrebbe valere solo quella obbligatoria per legge, cioè quella standard dei 2 anni da parte del venditore.
Ovviamente le mie considerazioni non sono state positive ed ho desistito dall'approfondire perchè non è chiaro a chi bisogna rivolgersi e non ho tempo da perdere dietro a queste cose.
Ma se qualcuno vuole approfondire sarebbe una cosa da chiarire affinchè la D-Link abbia una immagine di correttezza e trasparenza e non di una azienda che arronza.
 
CitazioneRisposta della D-Link sul port fowarding sull'indirizzo di broadcast .255 per la versione hardware E1:
Gentile Cliente,
siamo spiacenti ma ribadiamo quanto giá detto. L´inoltro delle porte non puó essere girato sull´indirizzo di broadcast. Il prodotto in questione non é in grado di effettuare la Wow.
Cordiali saluti,
D-Link
Anch'io sono assolutamente d'accordo con la D-Link sul fatto che, essenzialmente per motivi di sicurezza, non sia possibile girare dei pacchetti in brodcast all'interno della LAN, tant'è che l'indirizzo broadcast (.255) non viene neanche accettato.
Mi meravigliava il fatto che da più fonti si sostesse che il modello C2 invece lo consentisse e che avesse un così grosso bug di sicurezza. In rete si travano recensioni in merito.
L'unica spiegazione plausibile è che evidentemente su tali apparati era montato qualche firmware taroccato (e quindi anche con grossi bug di sicurezza) e non ufficiale. oppure alla D-Link dicono bugie.

Quello che chiedevo io però era una cosa diversa. Anch'io non vorrei mai che passassero pacchetti di qualsiasi genere in indirizzo broadcast a tutta la rete.
Io chiedevo l'inserimento di una opzione nel firmware per abilitazione la funzione Wake On Lan da WAN (internet) limitata ad una regola specifica in cui l'utente inserisce un accoppiamento indirizzo IP/MAC Adderess della sua rete su una determinata porta.
E che tale accoppiamento (IP/MAC address) e relativa porta di eccezione inserita dall'utente, venga memorizzata in memoria non volatile ed utilizzata dal router (appunto come eccezione specifica per il WOW) anche quando tale computer è spento.  

CitazioneQualcuno ha già provato la cosa di portare a 240 le ore del lease del dhcp?
Il problema non credo che sia il tempo di lease e, in base alle prove cerco di spiegarmi il perchè:
Se sul router si inseriscono delle eccezioni per delle porte (sia dalla scheda del menù Port Forwarding e sia dalla scheda Inbound Filter) con destinazione un indirizzo IP, quindi non eccezioni generali, ho constatato che tali eccezioni sono attive se nella LAN è presente tale indirizzo IP. Nel senso che il computer al quale è assegnato quell'indirizzo IP (abbinato anche con il MAC) deve essere acceso e presente in rete.
Infatti se si fa uno scan esterno del router si vede che le porte che avevamo impostato come eccezioni sono giustamente aperte.
Nel momento in cui spegniamo quel computer che abbiamo in rete (e per il quale abbiamo definito le eccezioni) e proviamo a fare uno scan esterno del router, vediamo che le porte risultano nascoste e non più accessibili.
Il router, nel momento in cui non avverte più la presenza nella rete interna del destinatario delle eccezioni alle regole che avevamo impostate, GIUSTAMENTE chiude (nasconde) tali porte e non fa passare proprio nulla.
E questo mi pare che sia un comportamento corretto da parte del router perchè, ripeto giustamente, se il computer destinatario non c'è e non risponde disattiva automaticamente le eccezioni particolari per quel computer.

Questo l'ho dedotto dal fatto che se spengo il computer della LAN che vorrei risvegliare via Internet ed invio il pacchetto magico di risveglio via internet immediatamente, nel tempo massimo di circa 30 secondi, il pacchetto passa ed il computer si accende con il comando inviato appunto via Internet. Questo succede perchè (deduco che) il router non ha ancora cancellato il computer appena spento dalla sua memoria (credo quella ARP) e quindi lascia passare i pacchetti ed il tutto funziona a meraviglia.
Dopo 30 secondi il pacchetto non possa più e se provo a fare una scansione delle porte con i vari servizi offerti via internet, le porte che precedentemente a computer acceso erano aperte, ora risultano nascoste e il router non fa passare neanche la capocchia di uno spillo.

Quindi sarebbe sufficiente che nel firmware i tecnici d-link inserissero una opzione (una regola opzionale) attivabile dall'utente per consentigli di poter usufruire di tale servizio Wake on Lan da Wan, in cui l'utente deve inserire l'indirizzo IP, il MAC address, la porta e relativo protocollo che vengono memorizzati dal router (non so dove e cmq non in memoria volatile) e che per quella regola e solo per quella non effettua il controllo della presenza del computer in rete e quindi fa passare cmq il pacchetto indirizzato a quell'IP a quel MAC e proveniente da quella determinata porta con quel determinato protocollo.

Mi sembra che come sicurezza ci siamo ed è quello che vorrei e che mi servirebbe.
Lo scopo è quello di mettere un computer nella casa al mare e poterlo accendere, spegnere e gestirlo da remoto.
Non mi pare una esigenza tanto fuori dal comune e che credo possa servire a molti anche a chi non ha la casa al mare, ma magari dall'ufficio vuol gestire in remoto il proprio computer di casa dove magari ci sono collegate anche telecamere o quant'altro.
Oppure in vancanza all'estero o su un'isola semi deserta, avendo un collegamento internet, accendere il computer di casa, controllare e spengnerlo...
Perchè tutto questo non deve essere possibile con tale router D-Link !?

In fin dei conti è una opzione presente in altri router anche meno costosi di questo e che altre marche di Router concorrenti offrono. Quindi non credo che sia una cosa così impossibile da implementare e di aver scoperto chissà che, anzi credo che sia abbastanza semplice inserire tale opzione nel firmware per i tecnici che fanno questo lavoro e che non ci sia nessun problema di sicurezza o quanto meno è ridotto ad un rischio minimo ed accettabile per chi attiva l'opzione.

Scusate il lungo post (sicuramente prolisso) che ho scritto al volo e che non ho neanche riletto e qualche errore mi sarà scappato. Tenente presente che non sono un tecnico e quindi chiedo venia per la terminologia inappropriata*.

*ma ho le idee molto chiare di quello che mi serve e voglio fare con il computer ed il suo bel routerino.. in sostanza "la libertà!"
Ciao ;)

kalash

Non so cosa sia successo stasera ma improvvisamente mi ha disconnesso da internet e non si connetteva più. La portante DSL c'era. Ma la lucedi connessione ad internet era rossa anzichè verde e il messaggio in status diceva Authentication Failure. Ho perso due ore dietro a questo problema senza capire cosa stesse succedendo. Ho persino provato ad aggiungere il dominio @tin.it dopo il mio userid (cosa che col vecchio router funzionava).
Alla fine il problema si è risolto da solo ma nel frattempo io ho dovuto togliere il dominio e lasciare la sola userid (ho visto che anche nei vostri screenshot c'è solo la userid senza dominio).

Non ho idea di cosa sia successo...

P.S: Ho il nuovo firmware beta che nel frattempo ho resettato e riconfigurato, ma il problema non si è risolto per quello.

Spidermac

Ringrazio Alby per la risposta sul WPS, ma ciò significa che un amico a cui non voglio dare o er fare prima la password della rete WI-FI, io premo sul router una volta abilitato il tasto WPS, ma lui dal PC o MAC non ho capito cosa dovrebbe avere la sua scheda idi rete o parliamo di una penna USB di connessione che ha il tasto WPS (penna opzionale della D-Link), ho capito bene?

Grazie per la disponibilità....
Chi non sa impara......basta umilmente chiedere

Alby

Citazione di: Spidermac dateline=1275600326Ringrazio Alby per la risposta sul WPS, ma ciò significa che un amico a cui non voglio dare o er fare prima la password della rete WI-FI, io premo sul router una volta abilitato il tasto WPS, ma lui dal PC o MAC non ho capito cosa dovrebbe avere la sua scheda idi rete o parliamo di una penna USB di connessione che ha il tasto WPS (penna opzionale della D-Link), ho capito bene?

Grazie per la disponibilità....
Sì, hai capito bene: il WPS funziona con le schede che ce l'hanno anche loro.
A me però è capitato con una scheda tp-link usb che era senza tastino, che facendo la connessione manualmente da windows scegliendo la rete e cliccando su connetti, invece di chiedermi la password di rete mi diceva di premere il tasto wps sul router e si connettevano senza fare altro, come se avesse il tasto hardware. Però erano i driver a prevedere la cosa, probabilmente.

P.S.: se viene un tuo amico, mettiamo mezz'ora a casa tua e non vuoi giustamente dargli la pass di rete hai anche un'altra possibilità: attivi la rete wireless Guest e si connette senza problemi a quella, addirittura gli devi mettere un SSID diverso, ad es. Network_temporaneo o simili.

Alby

Citazione di: kalash dateline=1275599426Non so cosa sia successo stasera ma improvvisamente mi ha disconnesso da internet e non si connetteva più. La portante DSL c'era. Ma la lucedi connessione ad internet era rossa anzichè verde e il messaggio in status diceva Authentication Failure. Ho perso due ore dietro a questo problema senza capire cosa stesse succedendo. Ho persino provato ad aggiungere il dominio @tin.it dopo il mio userid (cosa che col vecchio router funzionava).
Alla fine il problema si è risolto da solo ma nel frattempo io ho dovuto togliere il dominio e lasciare la sola userid (ho visto che anche nei vostri screenshot c'è solo la userid senza dominio).

Non ho idea di cosa sia successo...

P.S: Ho il nuovo firmware beta che nel frattempo ho resettato e riconfigurato, ma il problema non si è risolto per quello.

Speriamo che si sia trattato di un down temporaneo del provider. Comunque se dovesse ricapitare fai sapere.
Quando hai regolato a puntino il router e va tutto, ti conviene salvarti il file di config per quel firmware e se succede qualcosa, dopo un reset lo carichi e dovresti fare molto prima come tempi.
L'importante è che il backup lo fai in un momento in cui funziona tutto come si deve.

Carciofone

@Marko: hai notato bene il dettaglio. Ti dirò di più: nello screenshot che segue si vede cosa succede se si aggiorna dal vecchio firmware al nuovo beta senza resettare, quando le regole di port forwarding sono già state inserite:



Il campo è vuoto null e probabilmente non funzionano. Se si riscrive la regola, invece, compare la scritta Allow all che dovrebbe essere quella corretta. Tuttavia, pur non apparendo la colonna sul vecchio firmware le regole funzionavano bene. Quindi penso si tratti solo di una questione grafica.

Sulla questione dell'Isolation AP effettivamente le cose stanno come le descrivi. Anche a me sembra strano che i PC che accedono alla rete Guest accedano a quelli della LAN e la cosa merita di essere verificata su altri router per vedere come si comportano. O ci sfugge qualcosa su questa opzione, oppure il comportamento non è logico.


La tua idea sulla wow va meditata con calma, perchè non l'ho colta al primo colpo.  ;D
Come ottieni il WOL nella lan, inviando il pacchetto in broadcast? Oppure al MAC adress, oppure all'ip?

Marko

Il WOL nella LAN lo ottengo inviando il pacchetto magico al MAC Address del computer interessato.
Da quello che ho capito in sostanza il pacchetto magico non è altro che l'invio del MAC Address  ripetuto un certo numero di volte (mi pare sette volte, non ho approfondito).
In sostanza il pacchetto WOL è una cosa semplicissima: è costituito dal MAC Address ripetuto n volte, con protocollo UDP.

Come credo altrettanto semplice per i tecnici che si occupano di queste cose, scrivere due righe di codice da inserire nel firmware per abilitare tale funzione ed offrire anche tale opzione tra le tante che già ci sono.


Intanto, queste sono le differenze visibili che ho notato tra il firmware 5.17b49 ufficiale ed il firmware 5.17 beta successivo.. insomma hanno dato una piccola sistematina.

Sulla sinistra gli screenshot del firmware ufficiale, a fianco, sulla destra quelli del firmware beta con evidenziate le differenze:








..speriamo bene!   :P

Carciofone

E provare con qualche forma di routing statico per l'ip del pc da risvegliare?

Marko

Non so a cosa serve e se è idoneo allo scopo.
Tieni presente che io non è che ci capisca molto di tutte 'ste sigle, protocolli e settaggi vari.  :-[

Ho trovato queste spiegazioni sullo "Static Route" che si trova nel menù "Routing Setup":
- Instradamento statico [size=10]click[/size]
- RIP* (Routing Information Protocol) [size=10]click[/size]

* tra i vari significati di tale acronimo ho trovato che significa anche "Requiescat In Pace" (latino) "Rest In Peace" (inglese) "Riposa In Pace" (italiano).. insomma un acronimo abbreviato delle condoglianze luttuose molto in uso. LOL.

Non so nemmeno se l'abilitazione del "Multicast Streams" nel menù "Advanced LAN" serva o meno allo scopo.  :-[
Mi riferisco all'abilitazione dell'IGMP (Internet Group Management Protocol) [size=10]click[/size]
:)

Spidermac

"Il tasto blu sul router fa lo stesso identico lavoro del punto 1) sul router, ma senza entrare nei menu. Ovviamente ill WPS deve essere attivato in Advanced\Wi-Fi Protected Setup e la protezione wireless già impostata."post di Alby (non so come fate a fare le citazioni con colore diverso) ammetto l'ignoranza.

Salve a seguito della risposta di Alby che ringrazio ho visto che provando a collegare la WII a internet WI-FI, facendo la scansione mi trova anziché il mio router dlink casa ne ho trovato un altro denominato "wIO_Guest1" che credo sia sempre il mio dlink aperto a tutti?..... Come faccio a collegarlo a quello con la password e cosa rischio attivando quello libero (ciò vuol dire che chiunque può entrare nel mio computer?) e dove posso disabilitarlo? Vi ringrazio in anticipo per le delucidazioni...... Un saluto a tutti.
Chi non sa impara......basta umilmente chiedere

Carciofone

Citazione di: Marko dateline=1275741416Non so a cosa serve e se è idoneo allo scopo.
Tieni presente che io non è che ci capisca molto di tutte 'ste sigle, protocolli e settaggi vari.  :-[

Ho trovato queste spiegazioni sullo "Static Route" che si trova nel menù "Routing Setup":
- Instradamento statico [size=10]click[/size]
- RIP* (Routing Information Protocol) [size=10]click[/size]

* tra i vari significati di tale acronimo ho trovato che significa anche "Requiescat In Pace" (latino) "Rest In Peace" (inglese) "Riposa In Pace" (italiano).. insomma un acronimo abbreviato delle condoglianze luttuose molto in uso. LOL.

Non so nemmeno se l'abilitazione del "Multicast Streams" nel menù "Advanced LAN" serva o meno allo scopo.  :-[
Mi riferisco all'abilitazione dell'IGMP (Internet Group Management Protocol) [size=10]click[/size]
:)
Ho provato a fare un route statico su un IP, ma non mi sembra la strada giusta.

Citazione di: Spidermac dateline=1275745959"Il tasto blu sul router fa lo stesso identico lavoro del punto 1) sul router, ma senza entrare nei menu. Ovviamente ill WPS deve essere attivato in Advanced\Wi-Fi Protected Setup e la protezione wireless già impostata."post di Alby (non so come fate a fare le citazioni con colore diverso) ammetto l'ignoranza.

Salve a seguito della risposta di Alby che ringrazio ho visto che provando a collegare la WII a internet WI-FI, facendo la scansione mi trova anziché il mio router dlink casa ne ho trovato un altro denominato "wIO_Guest1" che credo sia sempre il mio dlink aperto a tutti?..... Come faccio a collegarlo a quello con la password e cosa rischio attivando quello libero (ciò vuol dire che chiunque può entrare nel mio computer?) e dove posso disabilitarlo? Vi ringrazio in anticipo per le delucidazioni...... Un saluto a tutti.
E' sufficiente premere in alto a dx del riquardo da citare il tasto Citazione  ;)

Di default la tua rete Guest non dovrebbe essere attiva. Comunque per attivarla\disattivarla basta che vai in Advanced\Advanced Wireless\GUEST Wireless Settings
Stando le cose come ha scoperto Marko, attualmente la rete Guest non è per nulla sicura e consente a chi vi si collega oltre che navigare, anche di condividere risorse coi pc della LAN\WLAN privata. Quindi va disattivata se non protetta e se non serve.

m4ss1

Mi intrometto in questa interessante discussione anche se non ho il 2740B E1 :)

Citazione di: Marko dateline=1275681401Il WOL nella LAN lo ottengo inviando il pacchetto magico al MAC Address del computer interessato.
Da quello che ho capito in sostanza il pacchetto magico non è altro che l'invio del MAC Address  ripetuto un certo numero di volte (mi pare sette volte, non ho approfondito).

Citazione di: http://en.wikipedia.org/wiki/Wake-on-LANThe magic packet is a broadcast frame containing anywhere within its payload: 6 bytes of ones (resulting in hexadecimal  FF FF FF FF FF FF or binary 11111111 11111111 11111111 11111111 11111111 11111111 or decimal 255 255 255 255 255 255), followed by sixteen repetitions of the target computer's 48-bit MAC address.

Viene ripetuto per 16 volte, se il pc è collegato in wireless (WoWLAN) deve essere abilitato il WMM altrimenti non funzionerà mai.
Non so se è stato già provato ...
Le porte usate dal wol sono la UDP 65535, AMD usa la UDP 2304 e alcune distro linux la UDP 9 (provale tutte e poi togli quella che non ti serve ;)) quindi apri la/e porta/e sull'indirizzo ip del pc che vuoi risvegliare.

Qui trovi molti programmi utili al wol: http://www.depicus.com/wake-on-lan/

Marko

@m4ss1-> grazie della precisazione e dell'arricchimento della discussione :).
Cmq, il WMM è attivato, infatti in LAN il pacchetto magico funziona, il problema è farlo passare da internet indirizzato ad un computer spento, attraverso il router. E' questo il punto perchè nel momento in cui il router non avverte il computer all'interno della LAN, perchè appunto è spento, NON fa passare proprio niente.

Intanto approfitto del post per dire che ho constatato un'altra particolarità che secondo me non va bene.
Attivando l'AP isolation sulla WLAN Pincipale, vengono isolati tra loro solo i computer connessi al WiFi Principale e non quelli connessi alla LAN ai quali si accede tranquillamente.

Ecco la mappatura della rete, dove si può osservare che i computer della WLAN vengono isolati tra loro, ma NON quelli della LAN. E questo, secondo me, non va bene.

I computer 1, 2 e 3 sono collegati al WiFi principale. Mentre il 4 rappresenta i computer collegati via cavo.




Queste altre immagini invece riprendono la mappatura della rete dalle tre diverse posizioni con AP Isolation attivato sulla rete WiFi GUEST:
- dal computer collegato in LAN via cavo
- dal computer collegato in WLAN Principale
- dal computer collegato in WLAN GUEST con opzione AP Isolation attivata
Sia graficamente e sia all'atto pratico dei test, l'AP isolation sulla rete wifi GUEST non sortisce nessun effetto di nessun genere. Praticamente non isola una cippa lippa!LOL TUTTI i computer comunicano tranquillamente tra loro.





quindi [size=12]RICAPITOLANDO[/size]:

direi che al momento, almeno per quanto mi riguarda e per quelle poche cose che ho provato si possono segnalare alla D-Link i seguenti problemi, salvo sviste:

1) Mancato funzionamento completo dell'AP Isolation della WLAN. Isola solo i computer della WLAN ma non tutto il resto. A livello pratico è ovvio che se uno utilizza tale opzione vorrebbe che ogni computer collegato fosse isolato, altrimenti non avrebbe molto senso pratico utilizzarla.

2) Completo NON funzionamento dell'AP Isolation della seconda rete WLAN (GUEST). Non isola niente e nessuno, cioè praticamente è una opzione fantasma che non sortisce alcun effetto. Tutti si vedono e comunicano felicemente!

3) Impossibilità di poter utilizzare il Wake On Lan da WAN verso un indirizzo interno, identificato attraverso un abbinamento di Indirizzo IP/MAC Address già memorizzato nel router nel DHCP Reservations List.
Non so se è una cosa voluta o è sufficiente scrivere due righe di codice per poter attivare tale opzione e rendere la vita più semplice all'utente e tutto a guadagno della D-Link considerato che altri router offrono tale opzione senza tanti sbattimenti e costano pure meno.

4) Non sono riuscito a far funzionare, nonostante diverse prove, la VPN di Windows 7. Considerato che tale router DSL-2740B E1 si fregia e si vanta di avere il logo Windows7 e la relativa certificazione, la cosa mi pare un po' strana.
Se è vero che ha la certificazione ed il logo Windows 7 come ampiamente pubblicizzato dalla D-Link, deve anche prevedere ed avere delle opzioni preimpostate per far funzionare la VPN di tale sistema operativo. Altrimenti è una balla ed una presa in giro nei confronti di chi si fida ed acquista tale prodotto.

5) Manuale alquanto carente, scarso di informazioni e spiegazioni, abbastanza generico e non proprio specifico ed aderente al modello in questione. E sicuramente non indirizzato ad una utenza quanto meno media. Ad un professionista forse non serve nemmeno il manuale. Ma non tutti quelli che acquistano oggi un router devono per forza essere dei professionisti.
Anzi credo che i maggiori guadagni, le maggiori vendite e le migliori prospettive vengano dal mercato Home e Small Office al quale si indirizza tale prodotto.

6) La traduzione nella lingua italiana è peggiore di quella fatta con google.
E faccio una triste considerazione: tradurre due paginette (ma sono anche meno) di parole in inglese , un traduttore professionista si prende non più di 80 euro, cioè meno di quello che si paga per acquistare 1 (dico uno) router.
Ora una grande multinazionale come la D-link che vende in tutto il mondo e con un fatturato a 7 zeri, pare che nei suoi costi non voglia nemmeno mettere gli 80 euro da dare ad un professionista!!  Insomma non ci fa una bella figura e non invoglia certo ad acquistare i suoi prodotti!

Licenza Creative Commons
Il contenuto dei messaggi del forum è distribuito con
Licenza Creative Commons Attribuzione Non commerciale 4.0
Tutti i marchi registrati citati appartengono ai legittimi proprietari