24 gennaio 2021, 23:57:49

DSL-2740B E1 - Modem Router ADSL2+ Wireless N 300

Aperto da Carciofone, 03 maggio 2010, 15:09:57

Pondera

Citazione di: Grisha il 19 dicembre 2010, 16:39:19
Citazione di: Pondera il 19 dicembre 2010, 11:40:05Per i Broadcom, il 2640B B2 e il 2740B E1, mi sono accorto che non è necessario attivare l'impostazione dell'ora legale, non so per quale motivo però basta che sia impostato un server NTP funzionante.
Bug non ancora risolto, evidentemente: vedere questo post.
No! Non devi attivare per niente l'ora legale sui Broadcom, basta inserire il nome/indirizzo IP del server NTP e poi se la sbrigano router e server a far quadrare ora solare e legale!

@wiz4rd
Ma hai impostato Group Key Update Interval=0?


Grisha

Citazione di: Pondera il 20 dicembre 2010, 00:40:37No! Non devi attivare per niente l'ora legale sui Broadcom, basta inserire il nome/indirizzo IP del server NTP e poi se la sbrigano router e server a far quadrare ora solare e legale!
Ho capito che nel 2740B E1 è così, ma è un baco suo. Normalmente negli altri Broadcom-based il flag DST ha significato.

Carciofone

20 dicembre 2010, 07:57:36 #762 Ultima modifica: 23 maggio 2019, 10:31:31 di D-Link Forum
Anche con il firmware 5.17 17\'9\2010 ha significato e funziona correttamente.

Pondera

Citazione di: Grisha il 20 dicembre 2010, 06:34:21Ho capito che nel 2740B E1 è così, ma è un baco suo. Normalmente negli altri Broadcom-based il flag DST ha significato.
No! Nel DSL-2640B B2 ha lo stesso identico funzionamento!
Ricordo per l'ennesima volta che basta impostare il server NTP e basta! Il cambio da ora solare a legale avviene in automatico! Nella serie R, invece, si deve impostare la data di cambio ogni anno: una vera palla!

Grisha

Citazione di: [email protected] il 20 dicembre 2010, 07:57:36Anche con il firmware 5.17 17\'9\2010 ha significato e funziona correttamente.
Non sembra proprio: nel tuo screenshot il "Current Router Time" è avanti di un'ora rispetto al tuo post...
Normalmente (es. sui Netgear, Linksys, etc.) l'opzione "Enable Daylight Saving" sta ad indicare semplicemente che nella propria time zone esiste il periodo dell'ora legale. E quando i suddetti modem e/o router sincronizzano con i server NTP ne tengono conto. Punto.
Il comportamento del D-Link è contrario a quasi tutti gli altri (che fanno la cosa giusta) ed è sbagliato. Così si deve intervenire manualmente e impostare le regole di cambio orario nei dropbox sottostanti, sperando che non siano buggati....
E invece lo sono, come dimostra il tuo screenshot: con le regole impostate nei dropbox "Daylight Saving Dates" per lui continua ad essere ora legale......
Senza contare la rottura di dover intervenire manualmente sulle regole praticamente un anno sì e uno no: ad es. la domenica di ritorno all'ora solare non è sempre la quarta...

wiz4rd


Carciofone

Citazione di: Grisha il 20 dicembre 2010, 14:02:39
Citazione di: [email protected] il 20 dicembre 2010, 07:57:36Anche con il firmware 5.17 17\'9\2010 ha significato e funziona correttamente.
Non sembra proprio: nel tuo screenshot il "Current Router Time" è avanti di un'ora rispetto al tuo post...
Normalmente (es. sui Netgear, Linksys, etc.) l'opzione "Enable Daylight Saving" sta ad indicare semplicemente che nella propria time zone esiste il periodo dell'ora legale. E quando i suddetti modem e/o router sincronizzano con i server NTP ne tengono conto. Punto.
Il comportamento del D-Link è contrario a quasi tutti gli altri (che fanno la cosa giusta) ed è sbagliato. Così si deve intervenire manualmente e impostare le regole di cambio orario nei dropbox sottostanti, sperando che non siano buggati....
E invece lo sono, come dimostra il tuo screenshot: con le regole impostate nei dropbox "Daylight Saving Dates" per lui continua ad essere ora legale......
Senza contare la rottura di dover intervenire manualmente sulle regole praticamente un anno sì e uno no: ad es. la domenica di ritorno all'ora solare non è sempre la quarta...

L'ora dello screenshot è corretta (7.54) ed è perfettamente allineata a quella dei post che vedo (7.57). Quella che vedi nei tuoi è quella che hai impostato come opzione nel tuo pannello utente del forum.

wiz4rd

Rieccoci, voglio condividere l'esperienza delle disconnessioni wireless che sembra essere risolta.

Ho verificato che le disconnessioni erano in linea con l'accensione di un AP wireless della mia vicina ( no, non è bona). Ho usato per capire questa sovrapposizione il tool "inSSIDER 2.0" che ho lasciato acceso per diverso tempo. Ho visto i grafici e ho notato che il segnale era in sovrapposizione ( non uso N al momento) con il suo proprio la sera, spostato di canale è aumentato il mio segnale  sono in test ora:).

Se non ci sentiamo prima buone Feste

Toad

Citazione di: Toad il 16 dicembre 2010, 10:43:18
Citazione di: Alby il 15 dicembre 2010, 21:52:49Aggiorna il firmware del router alla beta del 17 settembre 2010 postato in prima pagina. Svariati bugs sono stati corretti.

Trovi informazioni sulla configurazione che ti interessa utilizzando una porta ethernet per il collegamento qui: https://www.dlink-forum.info/index.php?topic=208.0
Nel tuo caso, infatti, il Pirelli opera già a monte come router e non ti conviene utilizzare nel D-Link la funzione di routing, impostarlo come semplice AP.
Per usarlo in modalità doppio routing, ma con conseguente rallentamento della navigazione, doppio NAT e port forwarding lo dovresti configurare come spiegato alla lettera B) di questa guida: https://www.dlink-forum.info/index.php?topic=206.0 (sconsigliatissimo nel tuo caso).

Scegli poi un canale radio wireless diverso per i due o disattiva quello del pc che non ti serve.

Il ping sul DNS è normale che fallisca, dato che i DNS non rispondono al ping (e nemmeno il router, per evitare attacchi DOS ping of death).

Grazie Alby per il tuo link,
questa sera provvedo ad aggiornare il firmware alla versione di settembre 2010.
Ho visto come configurare il D-Link come AP e controllando il mio settaggio mi sono reso conto di non aver disabilitato l'UpnP.
Farò le modifiche da te indicate e incrocio le dita.
Vi Aggiorno appena fatto.
buona giornata


Grazie alle informazioni ricevute da un mio amico e da Alby, elenco (per chi avesse la stessa necessità) le operazioni
che mi hanno permesso di navigare in Internet ,collegando in cascata il modem router voip Pirelli (in comodato d'uso EUTELIA)
con il modem router wireless D-link DSL-2740B E1 (degradato a semplice AP):

   1)  Reset del router
   2)   Aggiorno firmware alla rel. di settembre 2010
   3)   Reset del router
   4)   Collego via ethernet pc e D-link (entrambi spenti)
   5)   Accendo del d-link , accensione del PC
   6)   Mi collego al router (http://192.168.1.1) e, del D-link configuro ***SOLO*** i seguenti parametri:
     -   setup / internet setup / Ethernet WAN port = LAN1
     -   setup / lan setup / router ip address = 192.168.1.2 / 255.255.255.0
     -   setup / lan setup / dhcp = disable
   7) Salvo la configurazione del D-link
   8) Spengo il PC, poi il D-link
   9) Collego via ethernet il Pirelli alla LAN2 del D-link
 10) Collego via ethernet il PC alla LAN3 del D-link
 11) Accendo in sequenza Pirelli, D-link , PC.
 12) Se aprendo una qualsiasi pagina web si riesce a navigare procedo al settaggio della parte wireless del D-link:
 13) Spengo PC, D-link, Pirelli (scollego il cavo di rete tra PC e D-link)
 14) Collego il Pirelli alla LAN1 del D-link
 15) Accendo il Pirelli, il D-link e il PC  
 16) Mi connetto ad internet via wireless dopo aver settato nelle proprietà del protocollo TCP/IP della scheda di rete senza fili
    -   Utilizza i seguenti indirizzi server DNS : 8.8.8.8
    
 Ringrazio tutti coloro che mi hanno aiutato.

tolaini

Confermo che con questo ultimo firmware continua a non funzionare l'uPnP. Sia uTorrent su Windows che Transmission su Mac comunicano correttamente al router di fare il forward delle porte (verificabile ad esempio con un programma tipo Port Map su Mac), ma il forward non funziona.

Carciofone

Citazione di: tolaini il 24 dicembre 2010, 09:54:26Confermo che con questo ultimo firmware continua a non funzionare l'uPnP. Sia uTorrent su Windows che Transmission su Mac comunicano correttamente al router di fare il forward delle porte (verificabile ad esempio con un programma tipo Port Map su Mac), ma il forward non funziona.
Che provider hai?
Di che colore è il cerchietto in basso a dx di utorrent?
Com'è configurata la scheda Connessione di utorrent?
Hai firewall software installati sul pc?

tolaini

Citazione di: [email protected] il 24 dicembre 2010, 10:02:46
Citazione di: tolaini il 24 dicembre 2010, 09:54:26Confermo che con questo ultimo firmware continua a non funzionare l'uPnP. Sia uTorrent su Windows che Transmission su Mac comunicano correttamente al router di fare il forward delle porte (verificabile ad esempio con un programma tipo Port Map su Mac), ma il forward non funziona.
Che provider hai?
Di che colore è il cerchietto in basso a dx di utorrent?
Com'è configurata la scheda Connessione di utorrent?
Hai firewall software installati sul pc?


Provider: tiscali (se ridirigo a mano le porte funziona tutto correttamente, quindi non è il provider che blocca)
utorrent: è flaggato sia l'uso di uPnP che di NAT-PNP, la prova di connessione dall'esterno alla porta del utorrent l'ho fatta tramite uno dei vari servizi online (con uPnP non funziona, con redirezione manuale delle porte si). Nessun firewall da nessuna parte.

Alby

Mai avuto nessun problema con upnp del router e utorrent: anzi, è l'unico che funziona sempre bene. Ip da DHCP e porta casuale ad ogni avvio (ne basta una). Il test sul sito potrebbe fallire per altre ragioni, una di queste è che i pacchetti "finti" usati nel test vengono filtrati dal firewall spi del router, per la loro struttura. Disabilita in advanced Firewall le regole dell'alg che non ti servono.
Hai provato a resettare il router e riprovare?

linux

Salve,

ho il 2740B E1 aggiornato al fw del 17/09/2010, avrei la necessità di far vedere a questo un altra rete gestita da altro router con IP diverso (192.168.178.1).
Ho tentato invano di fare una route statica, ma senza successo: non mi accetta l'accoppiata (192.168.178.1/255.255.255.0).
Cosa devo inserire? Come gateway devo immettere 192.168.178.1 o 198.168.1.1 (dlink)?
Nell'altro router ho immesso la route statica del dlink 2740B (192.168.1.1/255.255.255.0) e il relativo percorso funziona a dovere: vedo tutti gli apparecchi collegati al dlink (che mi funge da modem); non riesco a vedere il lato opposto di questa doppia rete?
Innanzi tutto la route statica funziona nel 2740B E1?
In pratica dovrei far vedere rciprocamente due spezoni di rete diverse (collegate da due router).

Spero che esca al più presto un altro aggiornamento per il 2740B E1: trovo inquietante che si possa accedere da remoto a questo router con login tecnica, è un baco gravissimo, anche se riguarda solo le connessioni remote!

Grazie per la risposta e scusate "l'ignoranza" in materia.

Auguro buon anno a tutti, soprattutto a [email protected] che, con la professionalità mostrata nel moderare questo forum, ha compensato egregiamente il nervosismo derivato da un firmware iniziale enormemente bacato.

bobbox

Cosa dice il router del mio avatar?  "Hey, don't look at me. Not me that ain't working..."

linux

Citazione di: bobbox il 28 dicembre 2010, 15:13:45Stai fecendo un cascading se non ho capito male.
Qui trovi qualche consiglio:
http://www.corenetworkz.com/2008/02/router-to-router-cascading-simple-guide.html


Penso di si (non sono un esperto e dunque il mio lessico è carente): voglio collegare due router tra di loro e vedere le reciproche sotto-reti (con ip diversi) da tutti gli apparecchi collegati.
Penso che questo link sia ciò che mi serve, lo leggerò con attenzione e "posterò" l'eventuale risultato.
Grazie mille e auguroni bobbox

Carciofone

Citazione di: linux il 28 dicembre 2010, 15:37:34
Citazione di: bobbox il 28 dicembre 2010, 15:13:45Stai fecendo un cascading se non ho capito male.
Qui trovi qualche consiglio:
http://www.corenetworkz.com/2008/02/router-to-router-cascading-simple-guide.html


Penso di si (non sono un esperto e dunque il mio lessico è carente): voglio collegare due router tra di loro e vedere le reciproche sotto-reti (con ip diversi) da tutti gli apparecchi collegati.
Penso che questo link sia ciò che mi serve, lo leggerò con attenzione e "posterò" l'eventuale risultato.
Grazie mille e auguroni bobbox

Ciao e ben venuto!
Purtroppo la guida indicata può essere fuorviante, perchè se ho ben capito cosa intendi fare, nessuno dei due casi indicati rispecchia le tue intenzioni.
Nel primo caso, infatti, ci troviamo in una situazione eth to eth analoga a quella specificata qui, per cui conviene trasformare il secondo router in AP puro senza lasciargli gestire il dhcp e il routing, cosa che non vuoi fare perchè mi pare di aver capito che vuoi tenere due segmenti di LAN separati.
Nemmeno il secondo caso è il tuo, perchè la porta WAN del DIR tu la colleghi all'HAG FW secondo questa modalità: https://www.dlink-forum.info/index.php?topic=206.0

La via giusta sarebbe quindi quella da te suggerita del routing statico se non fosse che con tutta probabilità il 2740B lo effettua sulla sua porta WAN\ADSL, a meno di non scoprire funzioni Virtual LAN del DIR ancora inesplorate, nel qual caso il 2740B basterebbe lasciarlo operare come AP su una specifica delle porte ethernet del DIR.

Con il 2740B E1 sono poi percorribili anche altri excamotages: ad es. configurare la sua porta ethernet 1 come WAN, trasformandolo di fatto in un secondo DIR;
oppure si potrebbe far connettere i client wireless alla rete wlan attivando l'opzione Isolation AP che li rende invisibili tra loro e alla LAN cablata, oppure farli connettere solo alla seconda rete wireless Guest, criptabile alla bisogna etc, nel qual caso anche senza attivare l'opzione isolation AP, essi non vedrebbero la LAN proveniente dalle porte ethernet, non vedrebbero la wlan principale (che fungerebbe a questo punto da sorta di repeater delle principale, ma non deve necessariamente essere utilizzata), ma continuerebbero a vedersi tra loro.

Posta uno screenshot della configurazione che hai già tentato che proviamo a vedere.

linux

Citazione di: [email protected] il 29 dicembre 2010, 08:43:01La via giusta sarebbe quindi quella da te suggerita del routing statico se non fosse che con tutta probabilità il 2740B lo effettua sulla sua porta WAN\ADSL, a meno di non scoprire funzioni Virtual LAN del DIR ancora inesplorate, nel qual caso il 2740B basterebbe lasciarlo operare come AP su una specifica delle porte ethernet del DIR.

Con il 2740B E1 sono poi percorribili anche altri excamotages: ad es. configurare la sua porta ethernet 1 come WAN, trasformandolo di fatto in un secondo DIR;
oppure si potrebbe far connettere i client wireless alla rete wlan attivando l'opzione Isolation AP che li rende invisibili tra loro e alla LAN cablata, oppure farli connettere solo alla seconda rete wireless Guest, criptabile alla bisogna etc, nel qual caso anche senza attivare l'opzione isolation AP, essi non vedrebbero la LAN proveniente dalle porte ethernet, non vedrebbero la wlan principale (che fungerebbe a questo punto da sorta di repeater delle principale, ma non deve necessariamente essere utilizzata), ma continuerebbero a vedersi tra loro.

Posta uno screenshot della configurazione che hai già tentato che proviamo a vedere.

In effetti con il link


linux

Citazione di: [email protected] il 29 dicembre 2010, 08:43:01La via giusta sarebbe quindi quella da te suggerita del routing statico se non fosse che con tutta probabilità il 2740B lo effettua sulla sua porta WAN\ADSL, a meno di non scoprire funzioni Virtual LAN del DIR ancora inesplorate, nel qual caso il 2740B basterebbe lasciarlo operare come AP su una specifica delle porte ethernet del DIR.

Con il 2740B E1 sono poi percorribili anche altri excamotages: ad es. configurare la sua porta ethernet 1 come WAN, trasformandolo di fatto in un secondo DIR;
oppure si potrebbe far connettere i client wireless alla rete wlan attivando l'opzione Isolation AP che li rende invisibili tra loro e alla LAN cablata, oppure farli connettere solo alla seconda rete wireless Guest, criptabile alla bisogna etc, nel qual caso anche senza attivare l'opzione isolation AP, essi non vedrebbero la LAN proveniente dalle porte ethernet, non vedrebbero la wlan principale (che fungerebbe a questo punto da sorta di repeater delle principale, ma non deve necessariamente essere utilizzata), ma continuerebbero a vedersi tra loro.

Posta uno screenshot della configurazione che hai già tentato che proviamo a vedere.

Eccomi, con un pò di fatica sono riuscito a fare i necessari screenshot.
Devo dire onestamente che con il link del cascading, pur avendolo letto, mi sembrava di complicare enormemente le cose.
Io avevo tentato di fare un più semplice "route statico su entrambi i router", pensando banalmente di istruirli "reciprocamente" sulla presenza dell'altro.
Sul router n. 2 (che è un FrtzBox e fa solo da router e da gestore telefonico) ho impostato questa route che va dal FritzBox al Dlink:

http://img232.imageshack.us/i/route1z.png/

Con questa va tutto bene, riesco a fare il ping di ogni dispositivo collegato al Dlink.

Sul router n. 1 (DLink 2740BE1 ultimo fw che funziona anche da modem) sono riuscito a fare solo la seguente route:

http://img402.imageshack.us/i/route2740b3.png/

La parte configurazione del RIP (che NON so cosa sia) non presenta alcun pulsante, penso dipenda dal fatto che ho abilitato il NAT (PPO/E), per me sono solo sigle lette al momento sul manuale e/o viste velocemente si wikipedia...

Non riesco nemmeno ad impostare la netmask (255.255.255.0 o 255.255.0.0) perché mi dà il seguente errore:

http://img84.imageshack.us/i/route27402.png/

Anche variando la modalità da gateway a "rete/br, etc".. è la stessa cosa, questo lato della rete (da dlink a fritzbox) non funziona, ping non raggiungibile.
Ho anche istruito i firewall presenti sui due pc a vedere tutte e due le reti, non è dunque colpa del firewall software.
A me, causa ignoranza, non viene in mente altro di "semplice".
Penso però che, anche se riescirò a far vedere reciprocamente i due spezzoni di rete, non funzionerà il gruppo di lavoro di due macchine xp che stanno ciascuna su uno spezzone differente, ma questa, al momento, è un'altra storia...

Grazie mille.


Carciofone

Chissà perchè ero convinto che i due router fossero collegati ad un hag fastweb a monte (troppe answer in contemporanea...). Se i router sono solo due il D-Link non dovrebbe avere grossi problemi, nel senso che una volta configurato per la connessione adsl come se ci fosse solo lui, dovrai operare solo sul fritz. Di solito i fritz con porta wan rj11 (modem adsl) hanno l'opzione per trasformare una delle porte ethernet in WAN. Fatto questo, collegati i due con un cavo ethernet e assegnato al fritz e al suo dhcp un range di IP diverso dal dlink (es. 192.168.100.1), andrai ad impostare la modalità WAN di connessione con DHCP attivo (la modalità è la stessa di quella adottata dal DIR-655 al punto B) di questa guida https://www.dlink-forum.info/index.php?topic=206.0 ) in modo che: il fritz prenderà un IP del range del D-Link, mentre gestirà a valle una lan con range suo diverso (quindi il suo NAT attivo). Vedi te se disabilitare il firewall del secondo router dato che opera già quello del primo (direi di sì). Non conosco i Fritz e quindi non ti so dire nei dettagli i menù da modificare. Ovvio che se il Fritz non ha la possibilità di trasformare una porta ethernet in wan o non ha una wan ethernet di suo, si ricade in quanto detto nell'answer precedente sul D-Link: può essere usato solo come AP puro e non può gestire una sublan tutta sua. Altrimenti bisognerebbe vedere se invertendo la posizione dei due nella rete si può ottenere qualcosa, ma ripeto, il Fritz non lo conosco.

Licenza Creative Commons
Il contenuto dei messaggi del forum è distribuito con
Licenza Creative Commons Attribuzione Non commerciale 4.0
Tutti i marchi registrati citati appartengono ai legittimi proprietari