19 Settembre 2020, 17:32:59

DSL-2740B E1 - Modem Router ADSL2+ Wireless N 300

Aperto da Carciofone, 03 Maggio 2010, 15:09:57

wiz4rd

@Linux

Ciao, ho visto gli screenshot che hai postato ma sinceramente non mi torna il routing

per inserire le rotte dovresti metterle secondo la seguente logica

per raggiungere la x.x.x.x 255.255.255.0 passa attraverso la y.y.y.y
mentre tu hai messo 192.168.1.1 255.255.255.255 passa attraverso 192.168.1.1 quindi secondo me è direttamente raggiungibile ( ha già una zampa su questa rete) perchè scrivi sempre la stessa net.

esempio pratico:

212.1.1.0 255.255.255.0 passa attraverso 192.168.1.1 questo vuol dire che per raggiungere la 212.1.1.0 devo passare attraverso il 192.168.1.1, come vedi sono su net diverse (ovviamente la zampa su 192.168.1.0 la devo avere)

altra cosa ti da errore di rete (http://img84.imageshack.us/i/route27402.png/) ed è normale perchè hai messo un indirizzo puntuale 192.168.178.1 e quindi non necessita di una subnetmask 255.255.255.0 ma di una /32 puntuale 255.255.255.255, prova a mettere 192.168.178.1 /30 (255.255.255.252) e vedrai che te lo prende il range di ip vanno da 192.168.178.1 a 2 (0 la rete 3 il broadcast)

se metti invece un ip secco hai bisogno di 255.255.255.255

Ciao

P.s. il RIP è un protocollo di routing dinamico che ti permette di istruire gli apparati vicino a seguito di una modifica su di un router ( aggiungendo o togliendo rotte) senza intervento manuale su ognuno di essi. Non è il tuo caso :)

djlattos

ciao a tutti io hioo comprato questa schifezza di router che non mi permette di collegarmi
ho alice 20 mega e di fabrica il firmware 5.17
 che devo fare? grazie!!!

wiz4rd

@Djlattos

hai aggiornato il firmware ? lo trovi qui con altre spiegazioni dettagliate:

https://www.dlink-forum.info/index.php?topic=213.0


linux

@wiz4rd e C@rciofone

Ti ringrazio per il puntuale consiglio wiz4rd.
Ho provato (lato dlink, quello che non funge) a mettere la route da te suggerita: 192.168.178.1 /30 (255.255.255.252), ma mi dà lo stesso errore, ossia mi fa mettere solo quello puntuale 192.168.178.1/32 (255.255.255.255), e con questo non funziona il ping a nessuna macchina del ramo (192.168.178.x).
Per ora ho messo i pc sul Fritz e i dispositivi ethernet vari statici sul dlink e così funzìiona tutto (faccio tranquillamente il ping su 192.168.1.x).
Il Fritz è ottimo per gestire la telefonia e i NAS anche usb (li vede come come dispositivi ethernet e si può fare su essi ftp), ma secondo me è inferiore al DLINK come configurabiltà del solo router e in particolar modo del firewall (per quanto ne posso capire), è chiaramente un altro tipo di oggetto, multifunzione e di costo maggiore, dunque NON sono confrontabili per destinazione d'uso; questa è una piccola aggiunta per soddisfare qualche curiosità su questo apparecchio.
Spero vivamente che la befana ci porti un nuovo fw per il 2740B, è un buon prodotto, considerate le potenzialità in rapporto al prezzo, basta scatenarle con un fw decente!
Dobbiamo aver fiducia, sperando che la Dlink non ci ripaghi non
Io, ad es., ho avuto modo di vedere anche un Netgear, e le potenzialità espresse dal fw mi sembrano di gran lunga inferiori.
Grazie ragazzi.
Buon anno a tutti.
Chiedo scusa, nel precedente commento mi è sfuggito l'invio prima che potessi completare una frase, riporto il pezzo errato in forma corretta:

Spero vivamente che la befana ci porti un nuovo fw per il 2740B, è un buon prodotto, considerate le potenzialità in rapporto al prezzo, basta scatenarle con un fw migliore!
Dobbiamo aver fiducia, sperando che la Dlink ci ripaghi non abbandonando lo sviluppo del 2740b E1.

wiz4rd

Ciao linux,


allora fermo restando quello che ti ho detto precedentemente, ho fatto una prova con la rotta statica e non accetta sottoreti diverse dalla /32, ma puoi mettere una rete tipo 192.168.178.0/24 (255.255.255.0)


Auguri a te :)



linux

Citazione di: wiz4rd il 01 Gennaio 2011, 18:10:48allora fermo restando quello che ti ho detto precedentemente, ho fatto una prova con la rotta statica e non accetta sottoreti diverse dalla /32, ma puoi mettere una rete tipo 192.168.178.0/24 (255.255.255.0)


Auguri a te :)


@ wiz4d

Ciao wiz4d,
purtroppo neanche con la rete 192.168.178.0/24 (255.255.255.0), che è stata accettata senza errori, i dati passano sull'altro router, vedrò di "impazzire un pò magari con le impostazioni lato "Fritz"; non so proprio da cosa possa dipendere.
Speriamo che le rotte statiche sul DLINK 2740B E1 ultimo fw non soffrano di qualche baco...
Comunque volevo principalmente ringraziare per  l'aiuto e i suggerimenti; provando e riprovando ho visto quanto tempo si perde per capire le cose,  e dunque ho maggiormente apprezzato i consigli ricevuti: la professionalità è sempre derivata  dall'impiego del proprio tempo, e questo è prezioso, anche quando utilizzato solamente per rispondere ad una richiesta d'aiuto!   :-)

Carciofone

Il modello di Fritz che usi non ha la possibilità di trasformare una delle porte LAN in WAN? Ha un modem integrato?

linux

Citazione di: C@rciofone il 05 Gennaio 2011, 08:49:02Il modello di Fritz che usi non ha la possibilità di trasformare una delle porte LAN in WAN? Ha un modem integrato?


Sicuramente si, dato che è l'ultimo 7390, io l'ho impostato in modo che dalla porta lan1 prenda l'accesso a internet (mantenendo la caratteristica di router NAT):

http://img211.imageshack.us/i/router6.png/

Se imposto il router per utilizzare la rete internet disponibile come solo client ip forse risolvo, ma perdo altre caratteristiche e sicuramente devo cambiare ip al router, cosa che vorrei evitare di fare.
Il Fritz non riporta una sezione dedicata dei suoi menu all'impostazione fine del solo firewall.
Aggiungo che non impostato il Fritz come modem perché con la mia ADSL infostrada 2+ non mi regge la connessione: è una ADSL "ballerina" che devo tenere impostata ad ADSL 2 (senza +) affinché sia stabile.

Sul DLINK se abilito, tra le impostazioni avanzate, ADSL2 va bene, altrimenti se tento di mettere il solo protocollo ADSL2+ vengono automaticamente abilitati ("spuntati") tutti gli altri protocolli, es. G-Dmt, etc.  E' un altro baco o è normale?

Il DLINK comunque mi mantiene la connessione ADSL2 adeguatamente, e questo è un punto a suo favore; su FRITZ non posso differenziare manualmente i protocolli ADSL, e questo secondo me è, al momento (se non sarà inserito in un prossimo firmware) un difetto.

Ecco ciò che ottengo con il DLINK come statistiche:

http://img818.imageshack.us/i/router7.png/

Se imposto ADSL2+ aumenta la velocità e l'"attainable rate" di un 30% c.a. ma si la connessione ADSL va e viene (il margine SNR è all'incirca uguale con tutti e due i protocolli, + o -); probabilmente il DSLAM al quale sono collegato è, occhio e croce, a poco più di tre chilometri (distanza desunta da alcuni test trovati in rete). Sto in una città completamente "coperta" dalla rete Infostrada ADSL2+, no problem dunque da questo punto di vista.
Inutile dire che se chiamo il call center Infostrada sono un muro di gomma e a volte mi sembra di passare per cretino, ho provato a scrivere (classica raccomandata) perché non hanno fax, e-mail, etc...., ed è una compagnia di telecomunicazioni!!!!!  :-(
Scusa la digressione/sfogo , ma sono esausto per disservizi dovuti essenzialmente ad offerte telefoniche che non prevedono adeguata assistenza (anche Telecom so che non è messa molto meglio), io preferirei pagare un po' di più ma avere una vera rete di assistenza multicanale.

Mi accontento, per ora, di far vedere reciprocamente Fritz e DLINK, e comunque, anche grazie a voi sto imparando tanto. "Impara l'arte e mettila da parte" dicevano i nostri nonni!  :-)
Grazie mille.

linux

@¢@rciofone e wiz4rd

Aggiunta alla risposta precedente:

la porta 1 del router FRITZ è collegata alla 4 del router 2740B E1. Il router Fritz prende un indirizzo dal lato 192.168.1.x per stabilire una propria connessione ADSL:

http://img227.imageshack.us/i/router8.png/

Ho eliminato la route statica del router Fritz e funziona lo stesso (OK dal lato FRITZ vs DLINK), ed è ovvio in quanto avevo già un piede nella rete 192.168.1.x; la route statica DLINK (per il lato opposto, 2740B vs FRITZ), invece continua a non funzionare: ho immesso la route come specificato precedentemente da wiz4rd.
Spero in tal modo di risultare esaustivo.  :-)
Grazie mille.

Carciofone

14 Gennaio 2011, 12:44:50 #789 Ultima modifica: 23 Maggio 2019, 11:08:28 di D-Link Forum
Nuovo firmware DSL-2740B E1 5.17b20101007 del 7 ottobre 2010.

dodi


Pondera

L'interfaccia in italiano corretto è proprio un'utopia! :D

Carciofone

Citazione di: dodi il 14 Gennaio 2011, 13:40:26qualcuno ha provato questo firmware?

Sì, è in uso da stamane. Attendiamo feedback.

wiz4rd

avete news sui vari problemi che avevamo evidenziato ?

Pondera


dmann9999

Citazione di: linux il 06 Gennaio 2011, 11:42:45Se imposto il router per utilizzare la rete internet disponibile come solo client ip forse risolvo, ma perdo altre caratteristiche e sicuramente devo cambiare ip al router, cosa che vorrei evitare di fare.
Il Fritz non riporta una sezione dedicata dei suoi menu all'impostazione fine del solo firewall.
Aggiungo che non impostato il Fritz come modem perché con la mia ADSL infostrada 2+ non mi regge la connessione: è una ADSL "ballerina" che devo tenere impostata ad ADSL 2 (senza +) affinché sia stabile.

Sul DLINK se abilito, tra le impostazioni avanzate, ADSL2 va bene, altrimenti se tento di mettere il solo protocollo ADSL2+ vengono automaticamente abilitati ("spuntati") tutti gli altri protocolli, es. G-Dmt, etc.  E' un altro baco o è normale?



Ciao, dopo aver letto i tuoi post sul pppoE passthru, così per sfizio ho provato anche io a farlo anche io sul fritz che ho a casa e ci sono riuscito ( ma mi intendo abbastanza di reti e di informatica avendoci studiato e lavorato)
devo premetterti che a casa ho però un router netgear (a differenza del lavoro...)ma questo dovrebbe essere ininfluente.
La prima cosa che devi fare è settare il router in pppoe llc, abiliti il pppoe passtrhu, e poi setti il fritz come hai già fatto, ma forse l'errore che tu fai è che con questo settaggio al fritz devono andare due cavi di rete, la prima porta diventa la wan (per condividere la connessione col router), e quindi sulla seconda devi metteci un altro cavo di rete che va dal router al fritz.
Ti sei iscrritto su fritz forum italia? massinge (l'admin) è molto preparato, competente e gentile e magari può darti una mano molto meglio di me.

Per quanto riguarda il dlink 2740b e1 ho notato anche io il baco che quando cambi modulazione ogni tanto ti spunta anche le altre, ma se lo batti in velocità dandogli l'applica velocemente non lo fa....
Ieri sul 2740b e1 ho messo il nuovo firmware di ottobre ed attualmente lo sto testando, questo router è veramente buono come hardware ed "intenzione di software" ma è comunque a mio parere una politica errata quella della dlink che fa fare da beta tester ai clienti, se una persona non è in grado (e ce ne sono tante) vede che il router col firmware di fabbrica funziona male (e i primi firm funzionavano veramente male) e butta il router in un cassetto, ci vuole poco a perdere i clienti... I router netgear invece sono molto più user friendly, e di solito funzionano da soli una volta connessi (beh col wireless aperto che è un suicidio...)
Io non ho la pretesa di insegnare il lavoro ad altri, ma alla dlink dovrebbero pensarci seriamente e vendere router più "facili da usare" ed alla portata di "utonto" (utente tonto) e quindi più pronti anche dal punto di vista software
ciao a tutti :)



Carciofone

Citazione di: Alby il 13 Novembre 2010, 06:58:00Lista bugs accertati nel firmware 5.17 beta di agosto 2010:
A distanza di oltre 2 mesi dall'ultima release del firmware per questo modello, è opportuno mettere in evidenza la lista di bugs ancora pesante che lo affliggono, sperando vengano presi in considerazione nelle prossime release del firmware.

Citazione1) I client ethernet non compaiono nella lista dei client connessi in Setup\LAN Setup\Number of Dynamic DHCP Clients nè in Status\Connected Clients.

2) I server DNS forniti tramite DHCP dopo un tot di tempo apparentemente casuale cominciano a non funzionare più richiedendo il riavvio del router

3) Lo scheduling del wireless e di altre funzioni non funziona per niente

4) Corollario del precedente problema è che l'interfaccia web in inglese e altre lingue sembra non rispondere più correttamente, ossia anche disattivando le funzioni impostate precedentemente elencate e non funzionanti, il router non si comporta più correttamente, richiedendo un reset completo per ricominciare a funzionare.

5) Le funzioni di accesso remoto da WAN come SSH e Telnet non funzionano.

6) In modalità PPPoA molti utenti lamentano mancata riconnessione automatica in caso di uso della funzione ondemand oppure in caso di disconnessione casuale.

Ne ho dimenticato qualcuno?

Riguardo a questa serie di bugs dopo 18 ore di up ho rilevato che:
1) sembra possibile finalmente la riconnessione in pppoa SENZA riavvio del router per la felicità di coloro che usano lo script per jdownloader e simili;

2) i DNS automatici del router presi dal provider con DHCP non mi hanno dato problemi, ma serve più tempo di test per vedere;

3) Lo scheduling wireless continua a non funzionare e a questo punto tanto varrebbe toglierlo.
- Se le relative impostazioni NON vengono MAI toccate dopo un reset del router, il wireless si accende regolarmente all'accensione del router e funziona 24h su 24.
- Se viene impostata un'ora di accensione, mettiamo dalle 9 di mattina alle 22 e il router RIMANE SEMPRE ACCESO, lo scheduling accende e spegne regolarmente il wireless.
- Se viene impostata un'ora di accensione, mettiamo dalle 9 di mattina alle 22 e il router VIENE SPENTO, ALLORA succede che:

a) se il router viene acceso PRIMA dell'ora di inizio dell'accensione del wireless, ALLORA lo scheduling accende e spegne regolarmente il wireless;

b) se il router viene acceso DOPO l'ora di inizio dell'accensione del wireless, ALLORA lo scheduling MANTIENE DISATTIVATO il wireless e per accenderlo occorre agire sul tasto ON OFF posteriore del wireless, oppure dall'interfaccia web del router spuntando la voce Attiva Wireless.

Questo potrebbe anche sembrare un funzionamento normale, ma il problema si manifesterebbe in ogni caso ad OGNI RIAVVIO del router ALL'INTERNO DELL'ORARIO DI ACCENSIONE e questo è talmente illogico e scomodo, da far auspicare la rimozione della funzione.

ALTRO GRAVE DIFETTO è che una volta che si siano modificati i parametri dello scheduling, ANCHE RIMETTENDO 24h su 24 7 giorni su 7 o Always On il wireless ad ogni riavvio del router è sempre spento e occorre agire come alla lettera b) precedente, oppure attuare il workaround di resettare il router e riconfigurarlo SENZA MAI TOCCARE LE IMPOSTAZIONI DELLO SCHEDULING WIRELESS.

Pondera

Citazione di: C@rciofone il 15 Gennaio 2011, 10:34:10
Citazione di: Alby il 13 Novembre 2010, 06:58:002) I server DNS forniti tramite DHCP dopo un tot di tempo apparentemente casuale cominciano a non funzionare più richiedendo il riavvio del router

2) i DNS automatici del router presi dal provider con DHCP non mi hanno dato problemi, ma serve più tempo di test per vedere;

Direi di coordinarsi nei test per giungere ad una soluzione comune...

https://www.dlink-forum.info/index.php?topic=380.msg6991#msg6991


dmann9999

Non si potrebbe avere nei prossimi firm la possibilità di scegliere il margine di aggancio dell'snr, per non farlo per vie traverse ogni volta? se la dlink lo aggiungesse (per i chipset broadcom naturalmente) sarebbe una scelta vincente, molti utenti avanzati apprezzerebbero la cosa.
Ciao ;)

Pondera

Citazione di: Alby il 13 Novembre 2010, 06:58:006) In modalità PPPoA molti utenti lamentano mancata riconnessione automatica in caso di uso della funzione ondemand oppure in caso di disconnessione casuale.

Alice 7M (PPPoA=1500, SRA, Idle Time Out=0)

Rate (Kbps): 7616 480
Line Coding(Trellis): Off Off
SNR Margin (0.1 dB): 173 220
Attenuation (0.1 dB): 200 70
Output Power (0.1 dBm): 178 121
Attainable Rate (Kbps): 9632 852


Semplice test: scollego il doppino fino a quando si spegne il led Internet, poi lo ricollego. Nella sezione Status trovo sempre DISCONNECTED.
Per forzare la connessione devo andare su Apply nella sezione ADSL Setup.

Ricordo che, per quanto riguarda il DSLAM a cui sono collegato:
Citazione di: Pondera il 09 Dicembre 2010, 14:10:15Pare che io stia con Infineon.

Licenza Creative Commons
Il contenuto dei messaggi del forum è distribuito con
Licenza Creative Commons Attribuzione Non commerciale 4.0
Tutti i marchi registrati citati appartengono ai legittimi proprietari