26 Maggio 2019, 09:10:53

D-930L/D-932L e ffmpeg

Aperto da mrmisi, 11 Dicembre 2015, 10:43:34

Discussione precedente - Discussione successiva

mrmisi

Ciao a tutti,

sono il felice possessore di 3 camere IP D-Link (2 932 e 1 930).
Premetto che non ho alcun problema di nessun genere e le uso da ormai 3 anni con un software di videosorveglianza.

Ora sarei interessato a registrare 60 secondi di audio di ognuna telecamere in seguito ad un mio comando (che faccio pervenire dal mio android grazie al server SSH installato sul PC di casa).
Per fare questo uso ffmpeg; per registrare il video non ho nessun problema, per l'audio invece si (video+audio non riesco a farlo).

invio il seguente comando a entrambi i modelli:


for /f "delims=" %%a in ('wmic OS Get localdatetime  ^| find "."') do set dt=%%a
set YYYY=%dt:~0,4%
set MM=%dt:~4,2%
set DD=%dt:~6,2%
set HH=%dt:~8,2%
set Min=%dt:~10,2%
set Sec=%dt:~12,2%

ffmpeg -t 60 -i http://[b]admin:password[/b]@[b]indirizzoip[/b]/audio.cgi -y C:\...\%DD%-%MM%-%YYYY%_%HH%-%Min%-%Sec%.mp3


Ma, mentre per la 930L l'audio registrato è perfetto, per la 932 è metallico e rumoroso, come se fosse in problema di codifica o chissà cosa.
Sapete in cosa differiscono i due modelli secondo questo aspetto? Avete un'idea su come modificare il comando di ffmpeg per registrare un audio decente?

Grazie a tutti.

Licenza Creative Commons
Il contenuto dei messaggi del forum è distribuito con
Licenza Creative Commons Attribuzione Non commerciale 4.0
Tutti i marchi registrati citati appartengono ai legittimi proprietari