19 Ottobre 2019, 04:30:32

DVA-5582 / DVA-5592 / DVA-5593 & VPN

Aperto da Pondera, 30 Agosto 2017, 15:37:01

Pondera

30 Agosto 2017, 15:37:01 Ultima modifica: 26 Giugno 2019, 09:38:11 di m4ss1
D-Link DVA-5582 / DVA-5592 / DVA-5593
&
VPN



VPN è l'acronimo per Virtual Private Networks, una rete privata che sfrutta una rete pubblica - ovvero Internet - per permettere ai computer connessi di comunicare tra loro come se fossero tutti fisicamente collegati allo stesso router. Il termine virtuale si riferisce al fatto che i computer non sono effettivamente collegati tra loro come accade in una LAN (Local Area Network) o in una rete aziendale dedicata, ma sfrutta un'altra infrastruttura fisica, sulla quale viene creato il cosiddetto tunnel VPN. L'obiettivo è proteggere i dati scambiati e garantire i livelli di sicurezza informatica attraverso una connessione remota.

Approfondimenti
Guida IPsec RoadWarrior DVA-5592 a cura di skyscreaper
Guida VPN PPTP a cura di tea4two: Non puoi visualizzare gli allegati in questa sezione.
Effettuare l'accesso al forum per visualizzare gli allegati.

Fonti immagini e testo:
D-Link & Wind3
Fastweb
The BizTech Post
La prima cosa da leggere in questo forum | Siti globali D-Link

Siate CHIARI SINTETICI E DETTAGLIATI altrimenti non possiamo aiutarvi!!!

N.B. Purtroppo non ho il tempo di rispondere in PVT: 1) usa un motore di ricerca; 2) usa la funzione "Cerca" del forum; 3) chiedi nel forum. GRZ!!!
Questo forum non è un centro assistenza, ma una comunità.
Prima di chiedere a NOI di risolvere il problema che hai TU, chiediti come TU puoi dare una mano a TUTTI.

manuel983

Buona sera parto subito con una domanda,  mi hanno appena attivato la fibra i infostrada ed ho il modem dva 5582.  Ho la necessità di connettermi alla mia rete da fuori casa tramite una vpn col Cel android.  Sono riuscito a crearla,  a connettermi alla vpn ed accedere in internet tramite vpn,  qui di con IP di casa,  ma non riesco a vedere gli altri dispositivi connessi alla LAN,  qualcuno può aiutarmi?  Grazie in anticipo

Carciofone

Devi verificare che servizi di condivisione files hai attivi sul cellulare android, in particolare Samba e CIFS, e poi a seconda delle macchine che hai nella LAN attivare le varie condivisioni su di loro e verificare che tutti i dispositivi si trovino in una LAN privata, ossia che i firewall non blocchino le comunicazioni.

Non specifichi però se la VPN è passante oppure hardware tramite il modem.

mickyct

Citazione di: manuel983 il 30 Agosto 2017, 23:56:38Buona sera parto subito con una domanda,  mi hanno appena attivato la fibra i infostrada ed ho il modem dva 5582.  Ho la necessità di connettermi alla mia rete da fuori casa tramite una vpn col Cel android.  Sono riuscito a crearla,  a connettermi alla vpn ed accedere in internet tramite vpn,  qui di con IP di casa,  ma non riesco a vedere gli altri dispositivi connessi alla LAN,  qualcuno può aiutarmi?  Grazie in anticipo

Ciao, perdona il disturbo. Ho il tuo stesso problema. Non credo sia un problema di cartelle condivise in rete, ma un problema di regole di routing o di firewall. Hai per caso risolto o fatto qualche passo avanti. In pratica io, come credo anche tu, stabilisco la connessione vpn ma a parte pingare il router non riesco a fare altro.

mickyct

Salve, ho un problema di configurazione del router in oggetto (fornito dalla Wind). In sostanza ho configurato l'accesso come pptp server per la vpn e riesco a stabilire correttamente la connessione dall'esterno. Solo che riesco a pingare solo il router e nient'altro. Nessun servizio, nessun apparato. Sospetto sia un problema di routing non autorizzato o di regole di firewall, ma non riesco a trovare dove e come intervenire. Qualcuno di voi ha avuto lo stesso problema e/o riesce ad aiutarmi? Grazie in anticipo a tutti.

idbricco

Scusate se rieusumo il post, ma sono nella stessa situazione. La Vpn PPTP si collega e riesco pure a navigare tramite vpn aggiungendo a mano i dns nella connessione client PPTP.
Non riesco però a raggiungere i device della rete locale. Ho già provato a disattivare il firewall del dlink.
Qualcuno ha poi risolto?

Pondera

Su questo argomento stiamo cercando di ottenere quante più informazioni possibili anche per il modello successivo DVA-5592 che ha la stessa interfaccia Epicentro dato che è difficile non avendo a portata di mano il dispositivo ed anche perché sui manuali non sono descritti i menu di livelli più profondi.

Intanto se puoi pubblica le schermate della tua configurazione (coprendo gli eventuali dati personali) così le analizziamo insieme e possiamo formulare qualche ipotesi di soluzione.
La prima cosa da leggere in questo forum | Siti globali D-Link

Siate CHIARI SINTETICI E DETTAGLIATI altrimenti non possiamo aiutarvi!!!

N.B. Purtroppo non ho il tempo di rispondere in PVT: 1) usa un motore di ricerca; 2) usa la funzione "Cerca" del forum; 3) chiedi nel forum. GRZ!!!
Questo forum non è un centro assistenza, ma una comunità.
Prima di chiedere a NOI di risolvere il problema che hai TU, chiediti come TU puoi dare una mano a TUTTI.

mickyct

Citazione di: idbricco il 15 Febbraio 2018, 11:05:05Scusate se rieusumo il post, ma sono nella stessa situazione. La Vpn PPTP si collega e riesco pure a navigare tramite vpn aggiungendo a mano i dns nella connessione client PPTP.
Non riesco però a raggiungere i device della rete locale. Ho già provato a disattivare il firewall del dlink.
Qualcuno ha poi risolto?

Niente da fare, io alla fine ho rinunziato. Ho sentito anche l'assistenza Wind (visto che me lo hanno fornito loro sta fetacchia) ma non avevano idea di cosa parlassi. D-link non da supporto in quanto il prodotto è distribuito da Wind. Alla fine ho messo su un Raspberry con servizio vpn pptp e con quello sono andato avanti configurando solo il port-forwarding.

idbricco

Citazione di: mickyct il 15 Febbraio 2018, 11:15:37
Citazione di: idbricco il 15 Febbraio 2018, 11:05:05Scusate se rieusumo il post, ma sono nella stessa situazione. La Vpn PPTP si collega e riesco pure a navigare tramite vpn aggiungendo a mano i dns nella connessione client PPTP.
Non riesco però a raggiungere i device della rete locale. Ho già provato a disattivare il firewall del dlink.
Qualcuno ha poi risolto?

Niente da fare, io alla fine ho rinunziato. Ho sentito anche l'assistenza Wind (visto che me lo hanno fornito loro sta fetacchia) ma non avevano idea di cosa parlassi. D-link non da supporto in quanto il prodotto è distribuito da Wind. Alla fine ho messo su un Raspberry con servizio vpn pptp e con quello sono andato avanti configurando solo il port-forwarding.

Grazie , mi sa che alla fine metterò un altro apparato anche io per gestire la vpn, anche se da appassionato informatico un po' mi scoccia.
Ma le ho già provate tutte con questo dlink per la vpn, mi sa che ha qualche baco davvero...

mickyct

Citazione di: idbricco il 15 Febbraio 2018, 11:21:25"anche se da appassionato informatico un po' mi scoccia."


Figurati a me che l'informatico lo faccio per professione... ;-)

idbricco

@Pondera
Scusa ho visto ora che avevi risposto anche te.
La configurazione del Dlink è quella di default appena installato. Ho solo creato la vpn.
Provato sia con firewall abilitato di base o disabilitato.
La vpn si collega regolarmente ( non passa i parametri dns che però ho messo a mano )
Il traffico verso la lan non passa. Si naviga regolarmente tramite vpn.
Penso ci sia effettivamente un baco, con il firewall disattivo dovrebbe passare tutto senza controlli.

Lila

Premesso che ho il 5592 e che non so nulla di vpn, ma smanetto un pochino, se volete verifico se con la versione successiva funziona meglio, ho android 6/win/mac/ios e qualche macchina virtuale per fare prove

antifascista

Anch'io sono diventato uno sfortunato possessore del 5592 che peraltro siamo costretti oscenamente a pagare.
Le mie prove con la configurazione delle VPN, sia in ipsec che nelle altre modalità, sono state del tutto negative: sembrano regolarmente configurate ma quando provo ad instaurare la connessione ottengo sempre lo stesso messaggio ovvero il server vpn non risponde; tra l'altro se guardo il file di configurazione non trovo traccia delle connessioni VPN create...
Premesso che per lavoro faccio l'informatico e che con Cisco e compagnia non ho problemi sono arrivato alla conclusione che il firmware brandizzato Wind abbia qualche bug e/o qualche castrazione...
Sicuramente avrò mille modi alternativi e migliori per realizzare la mia VPN ma mi gira l'anima e anche qualcos'altro se penso che devo pure pagare per un cesso di questo genere...

Se posso essere utile in qualche modo fatemi sapere...

Grazie

Carciofone

Postate le configurazioni adottato lato server e client che si vede di darvi una mano.
Ci sono errori molto comuni che spesso non consentono un funzionamento come si vorrebbe delle VPN per le quali vanno ovviamente configurati per bene servizi passanti, firewall (di solito almeno 4 tra due clients diversi) e range di IP se non si vogliono creare regole di routing statiche tra subnets diverse.

Pondera

Discussione in rilievo ed ampliata ad entrambi i modelli D-Link e personalizzati Wind Tre con interfaccia Epicentro.
La prima cosa da leggere in questo forum | Siti globali D-Link

Siate CHIARI SINTETICI E DETTAGLIATI altrimenti non possiamo aiutarvi!!!

N.B. Purtroppo non ho il tempo di rispondere in PVT: 1) usa un motore di ricerca; 2) usa la funzione "Cerca" del forum; 3) chiedi nel forum. GRZ!!!
Questo forum non è un centro assistenza, ma una comunità.
Prima di chiedere a NOI di risolvere il problema che hai TU, chiediti come TU puoi dare una mano a TUTTI.

antifascista

Provata anche la disabilitazione del fw del router. Per quanto riguarda la configurazione lato router come ho scritto prima nemmeno la trovo sul file di configurazione...

Lila

Scusate, esiste una guida "VPN su epicentro per dummies?" Seconda cosa, devo avere un servizio vpn esterno? (si capisce che sono confusa?)

m4ss1

@Lila Io non sono riuscito a trovarlo, no non serve un servizio esterno il router ha un server VPN (PPTP, L2TP, IPSEC) integrato.
L'unico servizio esterno da utilizzare è il DDNS che serve per collegarti al router.

Lila

Grazie @m4ss1 , sto giocando un po', il ddns lo avevo intuito ed è attivato ;) per ora il server mi chiude la porta in faccia XD

antifascista

Ho creato per l'ennesima volta una VPN che continua a non andar su ma stavolta ne ho trovata traccia sulla config:

vpn
    users
        add user User1
        user User1
            username ***
            password ***
            enable
        exit
    exit
    ipsec
        dnsCheck
            disable
            repetitionRate 180
        exit
        disable
    exit
    l2tp
        add server L2TP1
        server L2TP1
            addressRange 192.168.100.10 192.168.100.15
            users clear
            authProtocol set PAP,CHAP,MS-CHAP,MS-CHAPv2
            interface "WAN Data"
            enable

Naturalmente il router è accessibilissimo dall'esterno e gli asterischi su user e password li ho messi io.

Licenza Creative Commons
Il contenuto dei messaggi del forum è distribuito con
Licenza Creative Commons Attribuzione Non commerciale 4.0
Tutti i marchi registrati citati appartengono ai legittimi proprietari