17 Luglio 2019, 04:57:05

DVA-5582 / DVA-5592 / DVA-5593 & VPN

Aperto da Pondera, 30 Agosto 2017, 15:37:01

vincenzo12

Confermo di riuscire: col telefono vedo il NAS di casa e riesco a collegarmi VNC con un PC.

Sul telefono (Android) ho impostato: 
Tipo: PPTP
Crittografia PPP(MPPE)
Server DNS: 208.67.222.123 (penso vada benissimo anche 8.8.8.8)

Sul modem (5582):
Min Address: 192.168.4.197
Max Address: 192.168.4.200

Authentication Enabled: Yes
Authentication Protocol: MS-CHAPv2
MPPE encryption: 128 bit  + stateless
Users: admin
Auto Disconnect when Idle: Yes 
Idle Disconnect Time: 600

Come DHCP server ho 3 pool su 
192.168.1.
192.168.2.
192.168.3.

.fega.

Ah ok quindi con il DVA-5582 funziona

johnni

Ho scritto all'assistenza clienti della 3, chiedendo se è possibile cambiare il modem D-Link DVA-5592 con il "FRITZ!Box 7490 (fibra)", mi è stato risposto che non è possibile procedere alla sostituzione del modello di dispositivo perché i modelli consegnati e cioè i DVA-5592, sono configurati direttamente in rete. Secondo voi è normale, pagare il canone mensile di € 4,00 e non poter cambiare il modem con un modello che, per come ho letto, e dai video visti su youtube è più performante, e già configurato per poterlo usare come NAS con la funzione FritzNAS, oltretutto ho letto che il modem ha di suo una memoria interna di 500 MB.
Giovanni

Lila

Allora, da oggi riesco a giocare circa con la mia rete locale con il 5592 sia in PPTP che in LPTP.
NON la vedo, nel senso che in windows 10 non ho un bell'elenco delle macchine collegate ma
-posso accedere ad un disco condiviso sul router
-posso collegarmi in ssh sul media server con ip statico (non ho samba e quindi non è condiviso)
-non riesco ad entrare nelle cartelle condivise dei pc perchè mi dice che forse ho problemi col firewall, ma anche senza il firewall non vado oltre. Ad ogni modo la risorsa viene rilevata ma non accetta di comunicare...
Appena ho più tempo vi posto le mie configurazione, tenete presente che in un caso ho usato un range di ip nella stessa serie del router 192.168.1.x, nell'altro 192.168.2.x ma il risultato è lo stesso...

m4ss1

02 Marzo 2018, 11:55:22 #44 Ultima modifica: 20 Maggio 2019, 18:43:57 di m4ss1
Confermo che configurando una rete diversa da 192.168.1.xxx con la PPTP riesco a raggiungere tutti i dispositivi in LAN tranne l'interfaccia web del router.
Ho usato 10.0.0.2-10.0.0.20

Non puoi visualizzare gli allegati in questa sezione.

Dopo riprovo anche la IPSec...

Lila

Confermo pure io, con l'indirizzo diverso accedo al media server (sia interfaccia web, sia statistiche, si direttamente con upnplay per guardare i video, ma solo da android), altrimenti no. In entrambi i casi accedo ai dischi condivisi in rete sul router e NON accedo all'interfaccia web del router. NON accedo ai pc windows, li vede ma non si parlano!

DIVINI

Chiedo gentilmente aiuto.
 Ho un problema con la WIFI: se cerco di vedere una IPCam della stessa rete tramite un sito che fornisce il mio indirizzo pubblico non mi fa vedere nulla mentre se vado tramite la connessione dati dello smatphone si, se vado tramite rete lan tutto ok.
Premesso, sembra che il problema sia al rientro del router il quale non sa più a chi inviare la comunicazione, mi spiego tramite WIFI arrivo a chi mi fornisce IP pubblico e ritorna al router dove si blocca.

Lila

Citazione di: DIVINI il 03 Marzo 2018, 19:33:14Chiedo gentilmente aiuto.
 Ho un problema con la WIFI: se cerco di vedere una IPCam della stessa rete tramite un sito che fornisce il mio indirizzo pubblico non mi fa vedere nulla mentre se vado tramite la connessione dati dello smatphone si, se vado tramite rete lan tutto ok.
Premesso, sembra che il problema sia al rientro del router il quale non sa più a chi inviare la comunicazione, mi spiego tramite WIFI arrivo a chi mi fornisce IP pubblico e ritorna al router dove si blocca.
perdona la mia ignoranza, ma stai parlando di vpn o ddns?

Lila

@m4ss1 , posso chiederti se nella tua lan hai pc windows? perchè non riesco a configurare il firewall dei pc in modo che vengano visti, ho verificato e senza firewall entro...
Detto questo il problema principale credo sia che NON fa il NAT dell'ip (VPN NAT). Per evitare conflitti non è possibile usare un ip della stessa metrica del server dhcp locale. Però se io sono nella rete come 10.0.0.2 o 192.168.2.10 comunque non risulto parte della rete interna e quindi al massimo posso vedere gli ip che non rifiutano con firewall connessioni da esterno, tipo, nel mio caso, il media server. Per vedere la rete locale dovrei essere nello stesso range di ip, ma se non capisco come attivare questa "trasmissione" non si va oltre.

Ho cercato di attivare ipsec.. e come risultato mi sono chiusa fuori dall'interfaccia web e dall'accesso telnet e sparita la rete locale. Salvata in corner entrando con ethernet e scheda configurata con l'ip che avevo messo in ipsec e il gateway solito... Chi ha configurato ipsec può mostrare come è configurato?

DIVINI

Citazione di: Lila il 03 Marzo 2018, 22:54:52
Citazione di: DIVINI il 03 Marzo 2018, 19:33:14Chiedo gentilmente aiuto.
 Ho un problema con la WIFI: se cerco di vedere una IPCam della stessa rete tramite un sito che fornisce il mio indirizzo pubblico non mi fa vedere nulla mentre se vado tramite la connessione dati dello smatphone si, se vado tramite rete lan tutto ok.
Premesso, sembra che il problema sia al rientro del router il quale non sa più a chi inviare la comunicazione, mi spiego tramite WIFI arrivo a chi mi fornisce IP pubblico e ritorna al router dove si blocca.
perdona la mia ignoranza, ma stai parlando di vpn o ddns?
ddns

Lila

Citazione di: DIVINI il 04 Marzo 2018, 09:50:38ddns
questo è un thread su VPN, tu raggiungi la ipcam via vpn?

m4ss1

@DIVINI non fare le stesse domande in due discussioni, si crea confusione e questa è la discussione per le VPN.
Continua qui.

Lila

grazie per aver chiarito @m4ss1 , non capivo se mi stavo perdendo un passaggio.

m4ss1

Citazione di: Lila il 04 Marzo 2018, 06:51:30@m4ss1 , posso chiederti se nella tua lan hai pc windows? perchè non riesco a configurare il firewall dei pc in modo che vengano visti, ho verificato e senza firewall entro...

Si ho un pc win 10 che condivide una cartella, ho configurato la connessione come privata

attivato la condivisione della cartella aggiungendo l'utente e la password.

Citazione di: Lila il 04 Marzo 2018, 06:51:30Per evitare conflitti non è possibile usare un ip della stessa metrica del server dhcp locale. e io sono nella rete come 10.0.0.2 o 192.168.2.10 comunque non risulto parte della rete interna e quindi al massimo posso vedere gli ip che non rifiutano con firewall connessioni da esterno, tipo, nel mio caso, il media server. Per vedere la rete locale dovrei essere nello stesso range di ip, ma se non capisco come attivare questa "trasmissione" non si va oltre.

Risulti parte della rete, il router penserà a instradare il traffico verso l'IP usato dalla VPN e viceversa ma non vedi i client nelle risorse di rete perchè il firewall di windows blocca la connessione da IP che non sono in LAN.
Vai nelle impostazioni avanzate del firewall, clicca su "Regole connessioni in entrata" e "Condivisione File e stamapanti (SMB-in)"

Vai nel menu Ambito > Indirizzo IP remoto e aggiungi il range che configurato per i client della VPN

DIVINI

Citazione di: m4ss1 il 04 Marzo 2018, 12:33:41@DIVINI non fare le stesse domande in due discussioni, si crea confusione e questa è la discussione per le VPN.
Continua qui.

Scusatemi mi urge risolvere il problema

Lila

@m4ssi , grazie, quando ho tempo ci gioco!

antifascista

@Lila Io sto provando ipsec e da quando ho aggiornato il firmware ottengo meno errori dai log. mi potresti gentilmente dire che autenticazione e crittografia usi sulla phase 1 e 2? Io quando provo ad instaurare la vpn ottengo errore di negoziazione. Se supero questo scoglio potrei essere di aiuto a vedere se il traffico viene correttamente instradato sulla lan; dai log che ho visto, usando indirizzi in classe 10.10.10.x, il router pare creare correttamente le regole di nat-trasversal...

grazie

Lila

@antifascista io non sono riuscita a configurare ipsec, non so nemmeno come iniziare. Per le connessioni uso crittografia MSCHAPv2 128 bit stateless.

antifascista

@Lila Cosa non riesci a fare su ipsec? Possiamo collaborare se vuoi...

Lila

@antifascista , ho provato a configurarlo ma sono solo riuscita a chiudermi fuori dal router! se tu potessi darmi tutte le indicazioni, io provo a ripetere la stessa configurazione e vedere cosa succede!

Licenza Creative Commons
Il contenuto dei messaggi del forum è distribuito con
Licenza Creative Commons Attribuzione Non commerciale 4.0
Tutti i marchi registrati citati appartengono ai legittimi proprietari