28 Settembre 2020, 14:29:45

DSL-500T/502T/504T/524T/G604T/G624T - Modem router ADSL2+

Aperto da bovirus, 10 Marzo 2009, 10:18:55

l0v3r

Scusate una domanda: ma se io volessi sostituire l'adam2 del mio 502T con un pspboot, quale mi consigliate di usare? Ho scaricato i vari che ho trovato e pensavo alla 1.4 dell'acorp LAN120.

l0v3r

bovirus

Perchè vorresti cambiare il bootloader?
E una volta che hai aggiornato il PSPBOOT che firmware ci carichi?
Non è solo un probelma di bootloader. Devi trovare anche un firmware compatibile.

devis cegliere un bootloader compatibile con la dimensione e marca e mdoello della flash.
Il bootloader originale del DSL5XXT/G6XXT funziona pereftatmente.
IL'equivalente potrebbee ssere quella dell'Acorp LAN420 (no Wifi) o quellod el W400G (Wifi).-
Ma non è detto che funzionino (serve la JTAG)

l0v3r

Citazione di: bovirus il 13 Maggio 2011, 12:42:20Perchè vorresti cambiare il bootloader?
E una volta che hai aggiornato il PSPBOOT che firmware ci carichi?
Non è solo un probelma di bootloader. Devi trovare anche un firmware compatibile.


Sì, lo so, volevo mettere il pspboot perché leggevo in giro che dovrebbe essere più stabile: ho un 502T e un 300T e entrambi dopo qualche settimana di connessione devo riavviarli perché non mi agganciano più la portante (LED ADSL spento). Uso il routertech 2.95.
Ho anche abilitato la deframmentazione e la pulizia della memoria col cron nelle impostazioni avanzate RT.
Allora volevo provare a trasformarli in PSPBOOT, naturalmente cambiando poi MTD e caricando il RT per PSPBOOT.

l0v3r

Edit: sono entrambi con flash ATMEL, naturalmente con dimensione e RAM differenti.
Edit2: aggiungo anche che il problema della portante che non si riaggancia fino al riavvio è comparso dopo che hanno cambiato la DSLAM in centrale: la vecchia era solo ADSL, la nuova aggancia a 8124 Kbps in ADSL2+ con 32dB SNR in downstream

bovirus

Credo che qualsiasi firmware anche PSPBOOT per quella piattaforma TI AR7 potrebbe portare a blocchi del modem.
Nel primo post trovi una serie di bootloader (non si garantisce nulla). Serve la JTAG.
Potrebebe anche essere

- Problema alimentatore (corrente insuffciiente)
- Condensatori esauriti
- Problemi di dissipazione (servono dissipatori sui chip)

l0v3r

Citazione di: bovirus il 13 Maggio 2011, 12:53:01Credo che qualsiasi firmware anche PSPBOOT per quella piattaforma TI AR7 potrebbe portare a blocchi del modem.
Nel primo post trovi una serie di bootloader (non si garantisce nulla). Serve la JTAG.
Potrebebe anche essere

- Problema alimentatore (corrente insuffciiente)
- Condensatori esauriti
- Problemi di dissipazione (servono dissipatori sui chip)


Nel 502T avevo già messo un dissipatore sull'ar7... la JTAG non l'ho ancora costruita, ho solo il cavetto seriale (il cavetto dati del vecchio Siemens S35... ha già tutto all'interno del connettore seriale e si alimenta tramite la seriale con dei diodi)... i condensatori non lì ho sostituiti, appena ho un attimo di tempo li cambio.

Grazie per le info bovirus.

l0v3r

Pondera

Secondo me è inutile fare tutta 'sta faticaccia (condensatori, JTAG, PSPBoot) se non sei sicuro! Prova con gli originali McMCC (solo per ATMEL/AMD) il DSP 6 era molto più stabile e quel firmware molto più adatto del RT, specie per i DSL con 2M!

Se poi non vanno nemmeno questi allora vai con le modifiche e le sostituzioni! ;)

http://www.mcmcc.bat.ru/dlinkt/300T/DLink-300T_V.1.0.02.RU.18012007_MC_AnnexA_DSP62.zip

http://www.mcmcc.bat.ru/dlinkt/500T/DLink-500T_V.1.0.02.RU.18012007_MC_AnnexA_DSP62.zip

l0v3r

Citazione di: Pondera il 13 Maggio 2011, 13:37:41Secondo me è inutile fare tutta 'sta faticaccia (condensatori, JTAG, PSPBoot) se non sei sicuro! Prova con gli originali McMCC (solo per ATMEL/AMD) il DSP 6 era molto più stabile e quel firmware molto più adatto del RT, specie per i DSL con 2M!

Se poi non vanno nemmeno questi allora vai con le modifiche e le sostituzioni! ;)

http://www.mcmcc.bat.ru/dlinkt/300T/DLink-300T_V.1.0.02.RU.18012007_MC_AnnexA_DSP62.zip

http://www.mcmcc.bat.ru/dlinkt/500T/DLink-500T_V.1.0.02.RU.18012007_MC_AnnexA_DSP62.zip

Sì, questi ce li ho in giro in qualche HDD, ho anche quelli con il DSP 7.x di McMCC. Però mi piacciono di più i RT come configurabilità. Se ho un pò di tempo faccio qualche prova, magari mi faccio 'sta JTAG e mi diverto un pò ;) (così provo anche a flashare un 300T comprato in fiera al quale ho sostituito la flash ma ho sempre rimandato per mancanza della JTAG)

Grazie per ora.

Saluti

l0v3r

Pondera

Si ma prova quelli originali McMCC con DSP 6 (quelli con DSP 7 sono Zagor mod)! Se riscontri che è un problema di DSP (come penso!) puoi pure cercare una versione RT con quella serie di DSP!

P.S. È stato pubblicato il RT 2.96!

bovirus

Le ultime versioni di Routertech (da un paio di versioni) non usano più i DSP 6.xx

Dannoso

Citazione di: bovirus il 08 Maggio 2011, 17:02:07Se server not repsonding vuol dire che non c'è colloquio.
Hai impostato al scehad di rete su IP fisso 192.168.1.2?
Server not repsonding di solito sucecde con il bootloader
Oltre a server not responding dice altro?
Stai usando il kit recovery del firmware vero?
Dlink non fai quei lavori (sarebbe non conveniente)
Se vuoi ci sono dei volontari (uno sono io..) che possono fare quei lavori. mandami un messaggio privato.


Ciao, scusa il ritardo con cui rispondo, ma questa settimana ho avuto parecchi problemi. Dunque, si, ho impostato l'IP fisso, prima sulla rete 192.168, poi 10 e infine anche 5.8.8.9, ma niente da fare. Oltre a server non responding non dice nulla, mentre se provo col firmware mi da EAccessViolation. Mi sa che ti mando al volo un MP!:D8-):D

l0v3r

Citazione di: bovirus il 13 Maggio 2011, 16:19:12Le ultime versioni di Routertech (da un paio di versioni) non usano più i DSP 6.xx


Ho installato la 2.96 due giorni fa, ma ancora non ho avuto modo di provarla... cmq se fosse solo un problema di DSP, nei RT per flash da 4MB è possibile selezionare anche il DSP 6 nella configurazione avanzata RT (la versione per 2MB era già solo in DSP 6... le ultime versioni non so)

Farò qualche prova

l0v3r

Edit: a no, è un pezzo che non leggo i change log :)... dalla versione 2.94 "Further rationalisation of the DSP drivers means that the "low end" driver has changed from dsp/tiatm v6.2 (dsp62) to v7.0 (dsp70). In all versions of the firmware, dsp62 has been replaced with dsp70. DSP/tiatm v6.x are now "retired". "

Pondera

Citazione di: Pondera il 19 Maggio 2011, 09:38:54Gli sviluppatori del progetto RouterTech invitano a dare una mano nella compilazione di un elenco completo dei router che sono supportati "out of the box", che funzionano appena tirati, letteralmente, "fuori dalla scatola", cioé senza effettuare operazioni fuori dall'ordinario, come la sostituzione del bootloader.
A partire dalla versione 2.96 è inserito uno script attivabile nella sezione "Run Command" dando il proprio produttore e modello con la seguente sintassi:

router-info --router="Produttore/Modello"


Esempio

router-info --router="D-Link/DSL-300T"


Pubblicare il risultato visualizzato, senza modifiche ulteriori, nella loro discussione:

http://www.routertech.org/viewtopic.php?f=3&t=4191

e specificare, su rigo separato, se non si è riusciti ad aggiornare semplicemente via web ma con l'ausilio di apposite utilità software.

Nel caso i campi riguardanti la flash presentino valori sconosciuti (Unknown!), come nel caso delle Intel, è bene pubblicare anche il risultato visualizzato col seguente comando:

cat /proc/flashinfo


Pondera

@bovirus
I link DSL-524T non funzionano...

bovirus

@Pondera
Grazie della segnalazione. Sistemato.

Dannoso


Con questo post desidero ringraziare infitamente bovirus per aver risolto il problema del mio G624T. Raramente, se non mai, mi è capitato di conoscere in rete una persona così disponibile. Grazie mille! :):):):):):):):):)

martyballa

Ciao a tutti! Sono ufficialmente disperata :(
ho provato tutte le vostre indicazioni ma il mio router non da proprio segni di vita...
Ho un router DLink DSL-624T le uniche luci accese sono Power e quella della Lan, non riesco a resettarlo dal foro posteriore (ho provato più volte ma non succede nulla!)..
ho provato a cambiare firmware disattivando tutti i firewall ma ogni volta che prova a caricarlo mi da il seguente messaggio di errore "EAccessViolation".. ho provato varie versioni di firmware ma il risultato è sempre lo stesso.. ho provato a scaricare ciclamab ma con il mio sistema operativo (seven) non me lo fa installare.. ho provato a installarlo in modalità di compatibilità ma non riesco ad utilizzarlo comunque...
ho provato infine anche ti remote application ma senza risultati... cosa devo fare???? ora sono connessa tramite cellulare.. internet mi serve per motivi di studio.. devo cambiare modem o c'è ancora qualche speranza?

bovirus

C'è ancora qualche speranza ma serve hardware aggiuntivo (console seriale e JTAG).
Le utility di recovery funzionanO ESCLUSIVAMENTE in XP (non va bene il modo virtuale XP).
Lascia stare Ciclamab. E' troppo pericoloso usarlo se non lo si conosce.

Ti preparo entro sera (spero) un kit modificato e vediamo se funge...

Se non fune nonr imane che un modem nuovo.

bovirus


martyballa

Citazione di: bovirus il 15 Giugno 2011, 17:54:02Prova questo kit recovery (meglio se con XP 32bit)

DlinK DSL-G624T - Firmware Routertech 2.95 modificato

grazie mille, sei gentilissimo!!!provo subito e ti dico!!!

martyballa

mi ci vorrà un pò di tempo perchè al momento non dispongo di un pc con xp.. quindi pensavo di fare un boot da pendrive con xp... o installarlo direttamente su un altro pc..
ho tentato, anche se inutilmente, con seven e mi da lo stesso errore di sempre eacessviolation...
appena ho degli sviluppi ti aggiorno!

Licenza Creative Commons
Il contenuto dei messaggi del forum è distribuito con
Licenza Creative Commons Attribuzione Non commerciale 4.0
Tutti i marchi registrati citati appartengono ai legittimi proprietari