15 Novembre 2019, 21:15:33

Parere riguardo a problema ADSL

Aperto da logan, 31 Gennaio 2011, 23:53:15

logan

Ciao a tutti, qualcuno si ricorderà forse che ho un sacco di problemi di connessione con libero adsl (anche se tra qualche giorno dovrei passare a telecom).
il problema consiste nel rallentamento progressivo della connessione e, nell'arco di pochi minuti, nella disconnessione totale e riconnessione (anche se non sempre succede che si sconnetta).

questa sera, facendo una prova, ho riscontrato lo stesso problema e sono riuscito a loggare sul dir 825 il problema (riscontrato anche con il 2740b). vi incolla il log con  il momento del problema (Terminating on signal 15, al momento 23:41:05).
Jan 31 23:41:48 info  UDHCPD Inform: add_lease 192.168.1.11
Jan 31 23:41:47 info  read /etc/hosts - 1 addresses
Jan 31 23:41:47 info  using nameserver 193.70.152.15#53
Jan 31 23:41:47 info  using nameserver 193.70.152.25#53
Jan 31 23:41:47 info  reading /etc/resolv.conf
Jan 31 23:41:47 info  compile time options: IPv6 GNU-getopt no-ISC-leasefile no-DBus no-I18N no-TFTP
Jan 31 23:41:47 info  started, version 2.41 cachesize 150
Jan 31 23:41:44 debug  UDHCPD sending ACK to 192.168.1.11
Jan 31 23:41:44 info  UDHCPD sending OFFER of 192.168.1.11
Jan 31 23:41:42 debug  UDHCPD sendOffer : find a free IP
Jan 31 23:41:39 info  exiting on receipt of SIGTERM
Jan 31 23:41:39 info  using nameserver 193.70.152.15#53
Jan 31 23:41:39 info  using nameserver 193.70.152.25#53
Jan 31 23:41:39 info  reading /etc/resolv.conf
Jan 31 23:41:39 notice  pppd sent restart signal to rc
Jan 31 23:41:39 notice  pppd check for rc to be idle ?
Jan 31 23:41:37 notice  pppd is waiting 2 Secs for rc to be idle
Jan 31 23:41:37 notice  pppd is waiting for rc to be idle
Jan 31 23:41:37 notice  pppd check for rc to be idle ?
Jan 31 23:41:35 notice  pppd is waiting 2 Secs for rc to be idle
Jan 31 23:41:35 notice  pppd is waiting for rc to be idle
Jan 31 23:41:35 notice  pppd check for rc to be idle ?
Jan 31 23:41:32 info  read /etc/hosts - 1 addresses
Jan 31 23:41:32 info  using nameserver 193.70.152.15#53
Jan 31 23:41:32 info  using nameserver 193.70.152.25#53
Jan 31 23:41:32 info  reading /etc/resolv.conf
Jan 31 23:41:32 info  compile time options: IPv6 GNU-getopt no-ISC-leasefile no-DBus no-I18N no-TFTP
Jan 31 23:41:32 info  started, version 2.41 cachesize 150
Jan 31 23:41:32 notice  pppd is waiting 2 Secs for rc to be idle
Jan 31 23:41:32 notice  pppd is waiting for rc to be idle
Jan 31 23:41:32 notice  pppd check for rc to be idle ?
Jan 31 23:41:32 notice  klogd started: BusyBoxJan 31 23:41:05 router daemon.err pppd[19374]: Send SIGPIPE (ppp terminated) to wantimer
Jan 31 23:41:05 info  Die Exit.
Jan 31 23:41:05 info  Sent PADT
Jan 31 23:41:05 notice  ppp auth: Connection terminated.
Jan 31 23:41:05 debug  rcvd [LCP TermAck id=0x2]
Jan 31 23:41:05 debug  sent [LCP TermReq id=0x2  User request ]
Jan 31 23:41:05 info  Sent 2593215 bytes, received 10379654 bytes.
Jan 31 23:41:05 info  Connect time 9.1 minutes.
Jan 31 23:41:05 info  Terminating on signal 15
Jan 31 23:32:11 info  read /etc/hosts - 1 addresses
Jan 31 23:32:11 info  using nameserver 193.70.152.15#53
Jan 31 23:32:11 info  using nameserver 193.70.152.25#53
Jan 31 23:32:11 info  reading /etc/resolv.conf
Jan 31 23:32:11 info  compile time options: IPv6 GNU-getopt no-ISC-leasefile no-DBus no-I18N no-TFTP
Jan 31 23:32:11 info  started, version 2.41 cachesize 150
Jan 31 23:32:03 info  exiting on receipt of SIGTERM
Jan 31 23:32:02 info  using nameserver 193.70.152.15#53
Jan 31 23:32:02 info  using nameserver 193.70.152.25#53
Jan 31 23:32:02 info  reading /etc/resolv.conf
Jan 31 23:32:02 notice  pppd sent restart signal to rc
Jan 31 23:32:02 notice  pppd check for rc to be idle ?
Jan 31 23:32:02 notice  secondary DNS address 193.70.152.25
Jan 31 23:32:02 notice  primary   DNS address 193.70.152.15
Jan 31 23:32:02 notice  ipcp_up: remote PPP IP address 151.6.160.72
Jan 31 23:32:02 notice  ipcp_up: local PPP IP address 151.47.220.125
Jan 31 23:32:02 notice  ipcp_up: Open /var/tmp/pptp_server_ip.txt (l2tp_server_ip.txt) fail or Using PPPoE
Jan 31 23:32:02 debug  peerdns2 : 193.70.152.25
Jan 31 23:32:02 debug  peerdns1 : 193.70.152.15
Jan 31 23:32:02 debug  ppp create_resolv in ipcp
Jan 31 23:32:02 debug  rcvd [IPCP ConfAck id=0x2 'addr 151.47.220.125' 'ms-dns1 193.70.152.15' 'ms-dns3 193.70.152.25']
Jan 31 23:32:02 debug  sent [IPCP ConfReq id=0x2 'addr 151.47.220.125' 'ms-dns1 193.70.152.15' 'ms-dns3 193.70.152.25']
Jan 31 23:32:02 debug  rcvd [IPCP ConfNak id=0x1 'addr 151.47.220.125' 'ms-dns1 193.70.152.15' 'ms-dns3 193.70.152.25']
Jan 31 23:32:01 debug  sent [IPCP ConfAck id=0xde 'addr 151.6.160.72']
Jan 31 23:32:01 debug  rcvd [IPCP ConfReq id=0xde 'addr 151.6.160.72']
Jan 31 23:32:01 debug  sent [IPCP ConfReq id=0x1 'addr 0.0.0.0' 'ms-dns1 0.0.0.0' 'ms-dns3 0.0.0.0']
Jan 31 23:32:01 notice  peer from calling number 00:90:1A:42:84:8F authorized
Jan 31 23:32:01 notice  PAP authentication succeeded
Jan 31 23:32:01 debug  rcvd [PAP AuthAck id=0x1   ]
Jan 31 23:32:00 debug  rcvd [LCP EchoRep id=0x0 magic=0x1ed0242a]
Jan 31 23:32:00 debug  sent [PAP AuthReq id=0x1 user= ilmiousername@flat  password='hidden']
Jan 31 23:32:00 debug  sent [LCP EchoReq id=0x0 magic=0x472bbcf3]
Jan 31 23:32:00 debug  rcvd [LCP ConfAck id=0x1 'mru 1492' 'magic 0x472bbcf3']
Jan 31 23:32:00 debug  sent [LCP ConfAck id=0xe2 'mru 1492' 'auth pap' 'magic 0x1ed0242a']
Jan 31 23:32:00 debug  rcvd [LCP ConfReq id=0xe2 'mru 1492' 'auth pap' 'magic 0x1ed0242a']
Jan 31 23:31:59 debug  sent [LCP ConfReq id=0x1 'mru 1492' 'magic 0x472bbcf3']
Jan 31 23:31:59 notice  Connect: ppp0 '--' eth1
Jan 31 23:31:59 info  Using interface ppp0
Jan 31 23:31:59 debug  using channel 5
Jan 31 23:31:59 info  PPP session is 5442
Jan 31 23:31:59 debug  PADS: Service-Name: 'ADSL'
Jan 31 23:31:59 info  Sent PADT
Jan 31 23:31:59 info  rp_pppoe send PADT to terminate the session ID that sent last time
Jan 31 23:31:59 notice  pppd 2.4.3 started by root, uid 0
Jan 31 23:31:59 info  RP-PPPoE plugin inform wantimer to reset auth, discovery variable
Jan 31 23:31:59 info  RP-PPPoE plugin version 3.3 compiled against pppd 2.4.3
Jan 31 23:31:59 info  Plugin /lib/pppd/2.4.3/rp-pppoe.so loaded.

come si vede la connessione è durata solo 9 minuti e poi è saltata. qualcuno sa leggere questo log e capire che problema può essere e se, passando in telecom, potrei riscontrarlo ancora?

grazie!

Alby

Forse occorrerebbe verificare le impostazioni di connessione del modem e la sua configurazione, perchè a meno di aver impostato un tempo di disconnessione troppo breve, la connessione dipende dal modem.

logan

Citazione di: Alby il 01 Febbraio 2011, 09:22:44Forse occorrerebbe verificare le impostazioni di connessione del modem e la sua configurazione, perchè a meno di aver impostato un tempo di disconnessione troppo breve, la connessione dipende dal modem.

la configurazione del 320b (gestito in bridge dal dir 825) è pppoe 8/35 connessione always on (quindi senza tempo di disconnessione dopo inattività). mtu 1492 (quello standard).
la disconnessione succedeva anche con il 2740b.

può essere utile qualche altro parametro di connessione?
grazie mille alby!

Licenza Creative Commons
Il contenuto dei messaggi del forum è distribuito con
Licenza Creative Commons Attribuzione Non commerciale 4.0
Tutti i marchi registrati citati appartengono ai legittimi proprietari