19 Settembre 2020, 10:31:10

DSL-2640B B2: DNS non funzionano con DHCP

Aperto da raffaele18, 12 Febbraio 2011, 12:42:28

raffaele18

Salve a tutti. Ho un router/modem DSL-2640B (ma non credo che questo importi) con firmware stock. Il router funge anche da access point wifi

Finora avevo sempre usato client con IP statici e non mi ero mai accorto del problema: i DNS non funzionano se il client riceve l'IP dinamicamente. Ho provato con telefoni e laptop, la risposta è sempre l'eloquente unknown host. (Ovviamente via LAN funziona tutto, ie se inserisco l'indirizzo IP del router o di altri server delle casa)

Allego alcune schermate, spero possiate aiutarmi
ADSL settings


DNS settings


LAN settings



PS Per il voip devo usare il modem di Tele2, quindi la mia rete funziona così
Modem (.154) -------> Router wifi(.128) ------> client (ip statici e dinamici)

Pondera

Che revisione hardware e che versione firmware?
Si, è un problema noto sia per i firmware della serie Broadcom che Trendchip/Ralink.

raffaele18

Il firmware è quello stock, quindi mi fido di quello che esce scritto in alto a destra nell'interfaccia web e te lo riporto paro paro :D

Product : DSL-2640B
Firmware Version: EU_4.00 Hardware Version: B2


Però -caspita!- non immaginavo che potessero esistere bug per una funzione così basilare, anche perchè pensavo che lo stack di programmi usati dal router fosse quello standard gnu/linux

Pondera


raffaele18

Ho aggiornato e il problema sembra andato
Ora tengo il tutto sotto osservazione per un po'; nel caso qualcosa vada storta tornerò qui :D Grazie mille per l'aiuto, Pondera

raffaele18

Citazione di: raffaele18 il 12 Febbraio 2011, 19:56:33Ho aggiornato e il problema sembra andato
Ora tengo il tutto sotto osservazione per un po'; nel caso qualcosa vada storta tornerò qui :D Grazie mille per l'aiuto, Pondera
Come non detto! Probabilmente non avevo testato per bene... Il problema persiste

Pondera

Citazione di: raffaele18 il 12 Febbraio 2011, 12:42:28Ho un router/modem DSL-2640B [...]. Il router funge anche da access point wifi

[...] avevo sempre usato client con IP statici [...]

Allego alcune schermate, spero possiate aiutarmi
ADSL settings


[...]

Per il voip devo usare il modem di Tele2, quindi la mia rete funziona così
Modem (.154) -------> Router wifi(.128) ------> client (ip statici e dinamici)
Potresti spiegare, anche per gli altri, come utilizzi la connessione con indirizzo IP statico?


raffaele18

Niente di che... nel client imposto gateway, netmask e dns. E ovviamente l'ip

Pondera

Cioè invece di usare quelli che fornirebbe il provider usi quelli della tua rete!?!

raffaele18

Citazione di: Pondera il 13 Febbraio 2011, 10:47:00Cioè invece di usare quelli che fornirebbe il provider usi quelli della tua rete!?!
Ovviamente no!!! Altrimenti come potrebbe funzionare??? Avevo capito male la domanda. Come vedi dalla schermata allegata, come gateway imposto il mio modem, e come DNS ci sono quelli pubblici di Google (anzichè quelli di Tele2, ma questo non cambia niente)

Pondera

Citazione di: raffaele18 il 13 Febbraio 2011, 10:52:34Ovviamente no!!! Altrimenti come potrebbe funzionare???

Citazione di: Pondera il 13 Febbraio 2011, 10:47:00invece di usare quelli che fornirebbe il provider
nel caso in cui avessi un contratto ad IP fisso, era sottinteso! ;)


raffaele18

Bene :D allora, tornando al mio problema, com'è possibile che i client non ricevano la risoluzione dei nomi?

Pondera

Ma il modem come lo configuri: con connessione PPPoE/A o in BRIDGE?

Licenza Creative Commons
Il contenuto dei messaggi del forum è distribuito con
Licenza Creative Commons Attribuzione Non commerciale 4.0
Tutti i marchi registrati citati appartengono ai legittimi proprietari