30 Settembre 2020, 10:35:23

DSL-2640B B2 - Modem Router ADSL2+ Wireless G 54

Aperto da D-Link Forum, 15 Ottobre 2008, 20:01:00

seppia01

Ciao a tutti e grazie anticipatamente per l'eventuale aiuto.
Posseggo un dsl 2640b fornitomi da infostrada con firmware 2640B_WT_1.1.0b5_20100409
H/W ver:B2  ;  F/W ver: 1.1.0;  
Ho bisogno di aprire una porta a client che si collegano dalla wan ma settando la porta nel portforwording a volte risulta aperta e altre volte chiusa, così ho settato il mio server nel DMZ ma succede che quando l'ISP mi cambia l'IP,  il server nella sezione DMZ  non viene settato e mi tocca pigiare apply  per  reimpostarlo.
Mi chiedevo se eliminando il firmware di infostrada  e mettendo uno sbloccato riuscirei a risolvere l'inconveniente. Quindi proseguirei in questo modo:
caricamento  DSL-2640B B2 - Firmware 4.00.310022800 EU (10.06.2008) - sbloccato x downgrade
caricamento DSL-2640B B2 - Firmware 4.04b.310024100 EU (19.12.2011) ◄ Consigliato
inoltre mi chiedevo  se devo salvare i setting per poi ricaricarli nel firmware consigliato ho devo reimpostare tutto a mano, parametri linea , indirizzi mac che ho nella sezione wireless e quant'altro.
Spero di essere stato chiaro. ciao  ???

bovirus

Non c'è una ragione per cui il porta forwarding va e non va.
Se l'IP è fisso e hai impostato corretatmente il port forwarding deve funzionare.

Cambiando il firmware le impostazioni vanno rifatte ex novo.

sanga92

Salve a tutti e buon pomeriggio.
Ho una versione b2 di infostrada.
Ho un problema col port forwarding, premesso che ho letto tutte le guide possibile e gli altri post, so che devo inserire un ip statito, o comunque una eccezione nel dhcp server,ho inoltre inserito la porta che mi serviva nel port forwarding ,8080 in questo caso .
Ora, se verifico che la pora è aperta da un sito quale canyouseeme o yougetsignal me la da come aperta, se da rete interna provo ad accedervi funziona il server(torrent), ma se provo ad accedere inserendo il mi indirizzo ip pubblco:porta mi va in timeout, e cosa ancora piu strana se faccio un ping di quella porta mi da host non disponibile.
Help grazie

sanga92

help;)

seppia01

Citazione di: sanga92 il 12 Maggio 2013, 13:27:26help;)

Ciao come puoi leggere sopra,  avevo anche io problemi con il portforwording, ho risolto aggiornando il firmware del router con quelli che puoi scaricare nel post 1, per i quali ringrazio gli admin del forum per il loro lavoro. :)

th3r3d

Salve a tutti , sono nuovo nel forum. Mi sono registrato avendo visto la competenza degli "addetti" :) .
Vengo al punto, ergo non ho moltissimo tempo per leggermi tuta la discussione causa impegni, famiglia e super lavoro.
Ho fatto uan portabilità da Vodafone 8 mb a Infostrada 20 mb da circa un mese; le prime 2 settimane andava tutto bene ma poi all'improvviso ho visto che à a 4 MB! -.-
Ho un DSL-2640B di un precedente abbonamento con Infostrada.
Domande:
1- E' compatibile con la 20 mb? Mi va a 4 mb invece di 20! Prima di spendere soldi a vanvera comprando un DSL 2+, leggendo ho percepito che questo modem può essere portato a DSL +2 o sbaglio? ....ho provato a installare "DSL-2640B B2 - Firmware 4.04b.310024100 EU (19.12.2011)" ma mi dà un "fatal error etc. etc.".
2- Se è compatibile per la 20 MB, ci sono firmwares appositi?
3- Ho anche un Alice Gate 2 plus con sopra installati l'ultimo firmware US ROBOTICS ma anche questo sembra che più di 4/5 MB non li superi; esiste un firmware universale per porre fine al problema usando l'Alice Gate 2 plus?

Grazie in anticipo per la pazienza.

Carciofone

Questo modem nasce con la compatibilità adsl2 e adsl2+, quindi anche con il firmware di fabbrica supporta i 20 Mega. Verifica sull'etichetta che versione hardware è e solo dopo si potrà vedere qual è il firmware adatto.
L'aggiornamento va fatto preferibilmente con Internet Explorer 8 o superiore o Firefox e JRE aggiornata (7.21 per windows 32 bit).
Occorrerebbe poi verificare che parametri hai impostato per la connessione ed in ogni caso se fino ad un certo punto ti si connetteva a 20 e poi a 4 mbit qualcosa sulla linea è successo ...
Cosa ti dice il modem nella scheda status?

th3r3d

Citazione di: C@rciofone il 16 Maggio 2013, 21:29:09Questo modem nasce con la compatibilità adsl2 e adsl2+, quindi anche con il firmware di fabbrica supporta i 20 Mega. Verifica sull'etichetta che versione hardware è e solo dopo si potrà vedere qual è il firmware adatto.
L'aggiornamento va fatto preferibilmente con Internet Explorer 8 o superiore o Firefox e JRE aggiornata (7.21 per windows 32 bit).
Occorrerebbe poi verificare che parametri hai impostato per la connessione ed in ogni caso se fino ad un certo punto ti si connetteva a 20 e poi a 4 mbit qualcosa sulla linea è successo ...
Cosa ti dice il modem nella scheda status?

grz per la risposta.

H/W: B2    F/W: WT_1.1.0
 Firmware Version: 2640B_WT_1.1.0b5_20100409

STATUS
System Info
Model Name:    DSL-2640B
Time and Date:    Thu May 16 20:35:39 2013
Firmware Version:    2640B_WT_1.1.0b5_20100409
Internet Info               ppp_0_8_35_1
Internet Connection:
Internet Connection Status:    Up
Default Gateway:    ppp_0_8_35_1
Preferred DNS Server:    193.70.152.15
Alternate DNS Server:    212.52.97.15
Connection Up Time:    3 hour, 21 min, 14 sec
Downstream Line Rate (Kbps):   5367
Upstream Line Rate (Kbps):   681

Enabled WAN Connections:
VPI/VCI                Service Name    Protocol    IGMP    QoS    IP Address
8/35    pppoe_0_8_35    PPPoE    Enabled    Disabled    151.45.44.140
8/37    mer_0_8_37    MER            Enabled    Disabled    


Wireless Info
MAC Address:    02:24:01:4F:07:48
Status:    Enabled
Network Name (SSID):    InfostradaWiFi
Visibility:    Visible
Security Mode:    WPA2
Local Network Info
MAC Address:    00:24:01:4F:07:48
IP Address:    192.168.1.1
Subnet Mask:    255.255.255.0
DHCP Server:    Enabled

Questo è il report dello STATUS.

th3r3d

Citazione di: th3r3d il 16 Maggio 2013, 19:52:31
Salve a tutti , sono nuovo nel forum. Mi sono registrato avendo visto la competenza degli "addetti" :) .
Vengo al punto, ergo non ho moltissimo tempo per leggermi tuta la discussione causa impegni, famiglia e super lavoro.
Ho fatto uan portabilità da Vodafone 8 mb a Infostrada 20 mb da circa un mese; le prime 2 settimane andava tutto bene ma poi all'improvviso ho visto che à a 4 MB! -.-
Ho un DSL-2640B di un precedente abbonamento con Infostrada.
Domande:
1- E' compatibile con la 20 mb? Mi va a 4 mb invece di 20! Prima di spendere soldi a vanvera comprando un DSL 2+, leggendo ho percepito che questo modem può essere portato a DSL +2 o sbaglio? ....ho provato a installare "DSL-2640B B2 - Firmware 4.04b.310024100 EU (19.12.2011)" ma mi dà un "fatal error etc. etc.".
2- Se è compatibile per la 20 MB, ci sono firmwares appositi?
3- Ho anche un Alice Gate 2 plus con sopra installati l'ultimo firmware US ROBOTICS ma anche questo sembra che più di 4/5 MB non li superi; esiste un firmware universale per porre fine al problema usando l'Alice Gate 2 plus?

Grazie in anticipo per la pazienza.


Ho risolto, son venuti i tecnici SIRTI e hanno riscontrato un problema/danno alla cassetta esterna, ad un cavo.
Ho recuperato l'efficenza piena della linea (PING 25/30 - 13/15 mb dwnl - 1 mb upload).
Per fortuna un intervento tempestivo a a 36 ore dalla segnalazione.
Ringrazio chi mi ha risposto qui sul forum; vi ho aggiunti nei preferiti e vi farò buona pubblicità. GL  e grz a tutti ancora.
;)

Agisfulzio

Salve avrei un piccolo problema ed esseno un nabbo tremeno docn questo genere di cose... Sono passato da wind a fastweb e volevo usare DSL-2640B B2 che mi avevano dato quelli di wind per fasteb in tanto che il router di fastweb arriva.
Le impostazioni sono quelle di base e il firmware è il primo che si trovava non è mai stato aggiornato.
Sapete dirmi quali configurazioni si debbano mettere per farlo andare? Mi fareste un grosso favore la mia ragazza lo deve usare per lo studio e mi stà stressando l'anima...
Considerate che sono un nabbone quindi se possibile e se avete pazienza spiegatemi bene il tutto :D

Grazie in anticipo!

Ah dimenticavo sono anche disposto a chiamare chi mi saprà risolvere il problema, per farlo dal vivo :D

bovirus

Le indicazioni necessarie sono presenti nel primo post.
Il consiglio è prima di tutto aggiornare il modem alla versione firmware più recente.
La seconda cosa controlla sul sito di Fastweb quali sono le impostazioni necessarie.

Agisfulzio

Citazione di: bovirus il 24 Maggio 2013, 11:35:00Le indicazioni necessarie sono presenti nel primo post.
Il consiglio è prima di tutto aggiornare il modem alla versione firmware più recente.
La seconda cosa controlla sul sito di Fastweb quali sono le impostazioni necessarie.

Ok per l'aggiornamento, ma per quanto riguarda i settaggi le schermate sono diverse tra il sito di fastweb e quella che compare nel router, cambiano dopo l'aggiornamento?

Pondera

Citazione di: Agisfulzio il 24 Maggio 2013, 11:30:52Sono passato da wind a fastweb e volevo usare DSL-2640B B2 che mi avevano dato quelli di wind per fasteb in tanto che il router di fastweb arriva

Aggiorna ad uno dei firmware sbloccati e poi aggiorna all'ultimo consigliato in evidenza nel 1° messaggio di questa discussione.

Agisfulzio

Citazione di: Pondera il 24 Maggio 2013, 12:45:44
Citazione di: Agisfulzio il 24 Maggio 2013, 11:30:52Sono passato da wind a fastweb e volevo usare DSL-2640B B2 che mi avevano dato quelli di wind per fasteb in tanto che il router di fastweb arriva

Aggiorna ad uno dei firmware sbloccati e poi aggiorna all'ultimo consigliato in evidenza nel 1° messaggio di questa discussione.

Ok lo farò appena arrivo a casa. Poi? Seguo le loro istruzioni e si riuscirà ad usare?

v9_1

Ciao a tutti spero di non aver sbagliato sessione ho un 2640b 2 infostrada con led power rosso fisso
che non risponde dopo reset vorrei chiedere gentilmente dove trovo il firmware per questo modello da mettere con jtag?
grazie Saluti

Pondera

Trovi tutti i firmware nel 1° messaggio di questa discussione!
Prova prima via seriale il bootloader è davvero difficile che si corrompa. Ulteriori dettagli qui.

v9_1

Citazione di: Pondera il 26 Maggio 2013, 11:32:05Trovi tutti i firmware nel 1° messaggio di questa discussione!
Prova prima via seriale il bootloader è davvero difficile che si corrompa. Ulteriori dettagli qui.

Pondera innanzitutto grazie della risposta ho provato da seiale ma credo di aver un problema :( ho installato e settato teraterm collegato la seiale per vedere se funzionava ed andava tutto a video mi dava tutte le informazioni incuriosito non ho fermato il boot ho spento riacceso il router per ripetere la procedura e la seriale ora non mi visualizza piu' informazioni solo una marea di caratteri strani e non riesco a fermare il boot help me please
Saluti

Pondera

Reimposta di nuovo la velocità di trasferimento della porta seriale in Tera Term a 115200 baud.

v9_1

Citazione di: Pondera il 26 Maggio 2013, 13:21:46Reimposta di nuovo la velocità di trasferimento della porta seriale in Tera Term a 115200 baud.

:( fatto piu' volte ... non cambia nulla.... ho provato anche a cambiare com e compter sempre caratteri strani :( la seriale funziona ho appena provato su altro router.... mi sa propio che il cfe e' andato..... come potrei procedere ora?

Pondera

Citazione di: v9_1 il 26 Maggio 2013, 13:13:23non mi visualizza piu' informazioni solo una marea di caratteri strani e non riesco a fermare il boot

Questo dovrebbe significare che qualcosa continua a funzionare quindi si può ipotizzare che il bootloader sia integro.
C'è qualcosa che non va con la comunicazione seriale tipo una saldatura fatta male o un filo mal collegato o qualche collegamento invertito...

Licenza Creative Commons
Il contenuto dei messaggi del forum è distribuito con
Licenza Creative Commons Attribuzione Non commerciale 4.0
Tutti i marchi registrati citati appartengono ai legittimi proprietari