27 Maggio 2020, 02:02:47

DSL-2640B B2 - Modem Router ADSL2+ Wireless G 54

Aperto da D-Link Forum, 15 Ottobre 2008, 20:01:00

Carciofone

Ho notato che negli altri 2 modelli non c'è laporta seriale posteriore e il bottoncino per il reset.

BailA

Ciao a tutti!  :P
Da qualche giorno sono possessore di questo router,volevo sapere se ci sono firmware moddati in giro per la rete.
L'hardware del router sembrano eccellenti,un meno il firmware sopratutto dal lato Wireless ?
Ciao
Ps:ops,io possiedo il 2740,me ne sono accorto ora  :D

m4ss1

Citazione di: "BailA"Ciao a tutti!   ;)
Da qualche giorno sono possessore di questo router,volevo sapere se ci sono firmware moddati in giro per la rete.
L'hardware del router sembrano eccellenti,un meno il firmware sopratutto dal lato Wireless ?
Ciao
Ps:ops,io possiedo il 2740,me ne sono accorto ora  ;)

Ciao BailA, benvenuto  ;)

Ho aperto una nuova discussione per il 2740B   :)

bertith

aggiungo un mio problema.

allora partiamo dal principio. io avevo(ho ancora) un router della d-link modello DSL-502T ma siccome mi serviva l'ha wifi, ne ho comprato uno di nuovo, sempre d-link modello DSL-2640B e da allora iniziano i problemi, o meglio non riesco a configurarlo opportunamente. nel modello vecchio per fare funzionare correntamente utorrent mi bastava andare nel port forwarding e inserire la porta da mappare (nel vecchio modello non avevo molte configurazioni del firewall, o attivo o disattivato); nel nuovo ho provato sempre a mappare la porta ma ho dei problemi. utorrent mi dice praticamente sempre che ci sono dei problemi di connessioni e dover scaricare a 20k al posto di 300 mi brucia un pò. sembra quasi che il router dopo un pò inizi a segare la connessione, anche perchè se chiudo il programma e lo riapro per un pò la velocità è decente, ma poi scende fino ad arrivare quasi a 0, mentre l'upload resta sempre fisso al settaggio che gli ho messo.per esempio ora ho rimesso il router vecchio che sto andando a quasi 300 k, 2 minuti fa con l'altro andavo si e no a 40..... avete qualche suggerimento? non dovendoli configurare giornalmente di sicuro tralascio qualche impostanzione.
grazie in anticipo per l'aiuto.

p.s. non è un problema di connessione, perchè ho provato a fare i test da vari siti e mi segna sui 870-900 k in download e 87 in up. ho provato pure a scaricare da siti file grossi e viaggio sempre sui 600-700.

m4ss1

Ciao bertith e benvenuto  anche a te  ;)

Scusa se ti rispondo con delle domande ma ...

1) Che firmware ha il 2640B ? Lo trovi alla voce status.
2) Hai seguito la guida in prima pagina ? Ricorda che per uTorrent serve sia la TCP che UDP quindi dovrai selezionare Both nel protocollo del menu Port Forwarding.
3) Non avrai inserito il tuo ip nel campo remote ip  vero ?   :)
4) Facci sapere  :)

Carciofone

Per caso hai attivato opzioni del Qos?
Mi viene il dubbio perchè all'inizio dici che viaggia e poi cala.

bertith

grazie del benvenuto.

ora come ora sono in giro per lavoro e torno a casa nel pomeriggio di venerdì e su due piedi non mi ricordo di preciso come ho configurato e vado a memoria, sicuro il qos è disattivato per il resto sul portforwarding non ci metterei le mani sul fuoco, sicuro ho aperto sia tcp che udp, ma non ricordo sinceramente se ho messo qualcosa nel remote ip.aspetto di tornare a casa e vi so dire. penso che il firmware sia vecchio visto che ho lasciato quello base di istallazione l'ho comprato una settimana fa).

bertith

eccomi tornato a casa ora. come immaginavo il firmaware è vecchiotto, versione EU_3.07, allora ho scaricato la versione 4.00 da  ftp://ftp.dlink.it/Adsl/DSL-2640B/Firmw ... B_EU_4.zip  ( vedendolo nella prima pagina), ma quando cerco di fare l'upload mi dice di inserire un file valido??

m4ss1

Resettalo con il tasto posteriore, estrai i firmware dalla cartella e usa internet explorer per aggiornare.

bertith

Citazione di: m4ss1Resettalo con il tasto posteriore, estrai i firmware dalla cartella e usa internet explorer per aggiornare.

grazie, usato explorer e aggiornato alla versione 4.0, il problema purtroppo resta, utorrent continua a dirmi che non ci sono connessioni in arrivo e potrebbero esserci dei problemi di rete. ho risettato le porte come scritto nella prima pagina non mettendo nulla sulla voce ip remoto.
consigli?

Carciofone

Testato oggi con utorrent e raggiungeva tranquillamente i 600 KBytes in down. Sei sicuro di aver configurato correttamente il port forwarding?

bertith

Citazione di: C@rciofoneTestato oggi con utorrent e raggiungeva tranquillamente i 600 KBytes in down. Sei sicuro di aver configurato correttamente il port forwarding?

mannaggia alla diocesi...si era impallata la rete e mi aveva cambiato l'indizzo ip di questo pc...si ora col firmware aggiornato funziona tutto correttamente

m4ss1

Citazione di: bertith
Citazione di: C@rciofoneTestato oggi con utorrent e raggiungeva tranquillamente i 600 KBytes in down. Sei sicuro di aver configurato correttamente il port forwarding?

...si era impallata la rete e mi aveva cambiato l'indizzo ip di questo pc...

:D  meno male  

Carciofone

Citazione di: bertith
Citazione di: C@rciofoneTestato oggi con utorrent e raggiungeva tranquillamente i 600 KBytes in down. Sei sicuro di aver configurato correttamente il port forwarding?

mannaggia alla diocesi...si era impallata la rete e mi aveva cambiato l'indizzo ip di questo pc...si ora col firmware aggiornato funziona tutto correttamente
Imposta il MACAD per ottenere un indirizzo statico dal DHCP del router, così puoi sfruttare i vantaggi di usare un dhcp e avere un ip fisso su quel router.

vernaus

Ciao a tutti...
da qualche giorno  ho acquistato questo Modem Router DSL-2640B (in reltà DKT-710, prima avevo un modem DSL-302T) perchè oltre al PC dovevo collegare anche un xBOX.
....arrivo subito al problema: funziona tutto bene sia la navigazione che il gioco online ma per quanto riguarda emule....è un disastro ID basso di continuo se reinstallo il programma va bene per un pò ma poi di nuovo id basso e quando è alto scarica comunque pianissimo le porte le ho aperte(fatto il test tutto risulta ok).

qualcuno è in grado di aiutarmi?
Grazie

PS la versione firm:EU_3.07

m4ss1

Ciao Marco,
ho fatto due prove velocissime ...
Nessun firmware tra quelli linkati viene caricato, compreso quello citato da C@rciofone, il router riconosce sicuramente che non è un firmware EU e infatti ho modificato il post precedente.

Altra cosa ... tramite telnet è possibile visualizzare e modificare le impostazioni wan:


Ma non è possibile aggiungere PVC e quindi l'IPTV ... puoi aggiungerne con lo stesso VPI/VCI.

Controllando velocemente il file di configurazione del router però ho notato una cosa molto interessante:


All'interno del sono contenute anche le informazioni wan, appena ho tempo provo a modificarlo per vedere se si riesce ad aggiungere un pvc.

Un ultima cosa ... riesco a trovare solo i sorgenti del vecchio firmware 3.xx.xx, qualcuno sa dove trovo quelli v4 ?

Carciofone

Citazione di: m4ss1Ciao Marco,
ho fatto due prove velocissime ...
Nessun firmware tra quelli linkati viene caricato, compreso quello citato da C@rciofone, il router riconosce sicuramente che non è un firmware EU e infatti ho modificato il post precedente.

Altra cosa ... tramite telnet è possibile visualizzare e modificare le impostazioni wan:


Ma non è possibile aggiungere PVC e quindi l'IPTV ... puoi aggiungerne con lo stesso VPI/VCI.

Controllando velocemente il file di configurazione del router però ho notato una cosa molto interessante:


All'interno del sono contenute anche le informazioni wan, appena ho tempo provo a modificarlo per vedere se si riesce ad aggiungere un pvc.

Un ultima cosa ... riesco a trovare solo i sorgenti del vecchio firmware 3.xx.xx, qualcuno sa dove trovo quelli v4 ?
Sai qualcosa su come funzionano i firmware WI(nd) per IPTv? Si caricano sul router?
Per i sorgenti è tipico di D-Link. Mettono un sorgente vecchio e fine.

m4ss1

Purtroppo no :(

Ho cercato anche di caricarlo via telnet ma niente ...

Carciofone

Citazione di: m4ss1Altre due cose utili ...

Qui è disponibile lo schema per la JTAG e qui invece trovate una utilissima utility per modificare SNR e tanti altri valori.

La modifica dei valori SNR può essere fatta anche tramite telnet e memorizzata con il comando SAVE
Conoscevo già DMT, ma vedo che nell'ultima versione hanno messo anche la possibilità di modificare manualmente i parametri snr a mano.... Ottimo, per non sporcarsi le mani.  :D

m4ss1

Citazione di: m4ss1All'interno del sono contenute anche le informazioni wan, appena ho tempo provo a modificarlo per vedere se si riesce ad aggiungere un pvc.

Settimana prossima attivano l'IPTV ad un amico e vi faccio sapere  :D
Forse buone notizie ...  :D

Licenza Creative Commons
Il contenuto dei messaggi del forum è distribuito con
Licenza Creative Commons Attribuzione Non commerciale 4.0
Tutti i marchi registrati citati appartengono ai legittimi proprietari