30 Settembre 2020, 19:42:32

DSL-2640B B2 - Modem Router ADSL2+ Wireless G 54

Aperto da D-Link Forum, 15 Ottobre 2008, 20:01:00

bozo89

Citazione di: m4ss1 il 10 Febbraio 2011, 16:01:35Ciao, non avevo pensato ad un comando HTTP ... bella trovata appena ho tempo ci provo :D

Prova con quello che ti allego, devi DISATTIVARE il server DHCP del 2640B !

wow, come hai fatto a impostare i parametri di via telnet? per favore mi dica ...  ??? ::)

Ho bisogno anche di parametri diversi per PPPoE. Si può impostare questo parametro e caricare file?

parametri per PPPoE:
VPI - 0
VCI - 33
Tipo di connessione - LLC PPPoE
MTU - 1492
Firewall - Disabilita
NAT - Abilitazione

parametri per BRIDGE:
VPI - 0
VCI - 40
Tipo di connessione - 1483 Bridged IP LLC

Che ethernet (LAN1, LAN2 ...) è impostato di porta da utilizzare BRIDGE e che è impostato per utilizzare la connessione PPPoE?

La ringrazio molto per il vostro aiuto! ;)

m4ss1

Fatto, controlla l'allegato :D

Non ho usato telnet ma ho modificato il file .conf

Il decoder puoi collegarlo in qualsiasi porta LAN perchè non ho creato VLAN, purtroppo non ho un 2640B per provare a modificare il valore vlanId="-1"

L'importante è che il server DHCP del 2640B sia disattivato.

bozo89

ok, grazie, proverò questo. conf
ok, ma come si può configurare due PVC tramite interfaccia web e salvarli in file. conf?
o ho sbagliato qualcosa?!


m4ss1

Citazione di: bozo89 il 11 Febbraio 2011, 09:51:10ok, ma come si può configurare due PVC tramite interfaccia web e salvarli in file. conf?

Purtroppo credo non sia possibile, probabilmente si può fare da telnet ma non posso provare :-/

bozo89

Internet e IPTV lavorare con il vostro conf, ma è inutile senza VLAN port Maping perché non vi è trasmissione IPTV di interfaccia WLAN e lo rallenta ... WLAN LED è costantemente lampeggiante, questo non è buono ...

calimer77

Ciao a tutti
a questo indirizzo potete trovare il firmware 4.01 per il dsl2640b hw b2
ftp://ftp.dlink.it/Products/DSL/DSL-2640B/Firmware/

Non l'ho provato
Secondo voi funziona  e se si, quali sono le migliorie visto che da nessuna parte c'è scritto cosa migliora.
Grazie per qualunque info

calimer77

Ho letto il primo post ma il file mi pare diverso.
l'ultimo segnato in rosso e raccomandato dlink e' del 2009, questo e' del 2010
ed il file si chiama diversamente
Quello che dico io e' questo
EU_DSL-2640B_EU_4.01B_310023B00_cfe_fs_kernel
quello indicato nel primo post e' questo
DSL-2640B_4.01.310023E00B1_DL_cfe_fs_kernel

Saranno uguali?

Pondera

Quello che indichi tu sul sito ftp D-Link IT è questo:
Citazione di: Pondera il 30 Marzo 2010, 10:14:07BRCM_VERSIONE | BRCM_EDIZIONE | BRCM_EXTRAVERSIONE | ASUS_EDIZIONE

EU_DSL-2640B_EU_4.01B_310023B00_cfe_fs_kernel -> 3 10 02 3B00
Citazione di: D-Link Forum il 15 Ottobre 2008, 20:01:00DSL-2640B rev. B2 - Firmware v.  4.01.310023B00  (05.03.2009) Dlink

Mentre l'ultimo è questo:
Citazione di: Pondera il 30 Marzo 2010, 10:14:07BRCM_VERSIONE | BRCM_EDIZIONE | BRCM_EXTRAVERSIONE | ASUS_EDIZIONE

EU_DSL-2640B_EU_4.01B1_310023E00B1_cfe_fs_kernel -> 3 10 02 3E00B1
Citazione di: D-Link Forum il 15 Ottobre 2008, 20:01:00DSL-2640B rev. B2 - Firmware v. 4.01.310023E00B1  (25.03.2009) Dlink (suggerito)

Il 20/12/2010 non ha rilevanza come data riguardante il fw ma piuttosto di pubblicazione sull'ftp IT!

calimer77

Citazione di: Pondera il 10 Marzo 2011, 02:07:13Quello che indichi tu sul sito ftp D-Link IT è questo:
Citazione di: Pondera il 30 Marzo 2010, 10:14:07BRCM_VERSIONE | BRCM_EDIZIONE | BRCM_EXTRAVERSIONE | ASUS_EDIZIONE

EU_DSL-2640B_EU_4.01B_310023B00_cfe_fs_kernel -> 3 10 02 3B00
Citazione di: D-Link Forum il 15 Ottobre 2008, 20:01:00DSL-2640B rev. B2 - Firmware v.  4.01.310023B00  (05.03.2009) Dlink

Mentre l'ultimo è questo:
Citazione di: Pondera il 30 Marzo 2010, 10:14:07BRCM_VERSIONE | BRCM_EDIZIONE | BRCM_EXTRAVERSIONE | ASUS_EDIZIONE

EU_DSL-2640B_EU_4.01B1_310023E00B1_cfe_fs_kernel -> 3 10 02 3E00B1
Citazione di: D-Link Forum il 15 Ottobre 2008, 20:01:00DSL-2640B rev. B2 - Firmware v. 4.01.310023E00B1  (25.03.2009) Dlink (suggerito)

Il 20/12/2010 non ha rilevanza come data riguardante il fw ma piuttosto di pubblicazione sull'ftp IT!

Grazie mille.
Allora aggiorno il router col fw da te indicato.

yvany

2640B_WT_1.1.0b6_20100414
Non riesco a reperire questo firmware cki mi aiuta? grazie

Pondera

T'ho spostato nella discussione appropriata!
Cerca nel primo messaggio di questa discussione!

dobe3

Ciao a tutti,

ho letto tutti i thread su questo modem hw B2, e ancora ricevo errore nel caricare il fw.

io ho il 2640B_WT_1.1.0b5_20100409

devo rinominare il file in .bin o devo lasciarlo senza estensione?


calimer77

Citazione di: dobe3 il 13 Marzo 2011, 14:37:44Ciao a tutti,

ho letto tutti i thread su questo modem hw B2, e ancora ricevo errore nel caricare il fw.

io ho il 2640B_WT_1.1.0b5_20100409

devo rinominare il file in .bin o devo lasciarlo senza estensione?



Io per riuscire ad aggiornarlo ho dovuto usare internet explorer altrimenti con firefox mi dava sempre " indicare un file valido".

dobe3

Citazione di: calimer77 il 14 Marzo 2011, 19:14:52Io per riuscire ad aggiornarlo ho dovuto usare internet explorer altrimenti con firefox mi dava sempre " indicare un file valido".


mea culpa, dimenticavo di specificare che ho provato su
1) Win 7 con IE8 (compatibilità ON) + firefox
2) MAC OSX 10.6 con safari + firefox

sempre lo stesso errore.

ho anche provato a rinominare il file in .bin ma niente.


calimer77

Citazione di: dobe3 il 14 Marzo 2011, 19:36:45
Citazione di: calimer77 il 14 Marzo 2011, 19:14:52Io per riuscire ad aggiornarlo ho dovuto usare internet explorer altrimenti con firefox mi dava sempre " indicare un file valido".


mea culpa, dimenticavo di specificare che ho provato su
1) Win 7 con IE8 (compatibilità ON) + firefox
2) MAC OSX 10.6 con safari + firefox

sempre lo stesso errore.

ho anche provato a rinominare il file in .bin ma niente.



Da quello che posso capire il fw che hai tu (magari sbaglio) e' dell'hw B3 e come specificato nella discussione indicata da bovirus i fw del b2 non vanno sul b3.
Il file che hai indicato di avere, mi pare strano.
Tu hai scaricato l'ultimo segnato in rosso come consigliato dlink?
Io ho scaricato questo:
http://www.adsl4all.net/public/Modem/Dlink/Dlink_DSL-2640B/Firmware/DSL-2640B_4.01.310023E00B1_20090325_DL.zip
 e con ie e' andato su al volo senza nemmeno perdere le impostazioni.
Se invece hai infostrada devi scaricare quelle subito dopo, ma in tal caso non so dirti nulla perche' non li ho mai usati.

Mark0505

Buonasera a tutti,

Chiedo cortesemente a voi un aiuto nel risolvere un problema che ormai mi sta facendo impazzire:
Per ormai le 3ª volta in 6 mesi mi si è ripresentato un problema che mi costringe a navigare con continui cali di linea e frequenti cadute della stessa (sia su LAN che wireless).
Ho sempre pensato che fosse sempre colpa della linea telefonica che ogni tanto dava problemi (seppur i miei valori di connessione sia ottimi).
Invece questa volta penso di aver capito che il problema sie del router stesso che alcune volte si "incasina".
Due giorni fa ho staccato la linea del router dalla tripolare nel muro per vedere una cosa sul filtro adsl mentre (mio errore) era acceso il router. Dopo circa 2 mesi di funzionamento veramente perfetto senza mai una caduta di linea mi ritrovo ad avere continue cadute di linea e cali quasi ciclici (per esempio nelle chiamate di skype sento ogni qualche minuto la persona con cui sto parlando a tratti ma loro mi sento sempre perfettamente bene).
Circa 4 mesi fa mi aveva dato lo stesso problema ed ero riuscito a risolverlo dopo dopo una semplice reinstallazione del firmware 4.
Questa volta invece sembra che ogni cosa non faccia alcun effetto.
Ecco le statistiche della mia connessione:

------------

Mode:   G.DMT
Type:   Interleave
Line Coding:   Trellis Off
Status:   No defect
 
    Downstream   Upstream
Rate (Kbps):   5376    480
 
SNR Margin (dB):   11.7    28.0
Attenuation (dB):   18.0    5.0
Output Power (dBm):   9.9    17.8
 
Super Frames:   3341109    3341118
Super Frame Errors:   332161    6
RS Words:   227195478    28398500
RS Correctable Errors:   42903084    7
RS Uncorrectable Errors:   6063409    N/A
 
HEC Errors:   321847    3
OCD Errors:   675    2
LCD Errors:   0    0
Total Cells:   713295161    0
Data Cells:   7661682    0
Bit Errors:   0    0
 
Total ES:   17336    0
Total SES:   6357    0
Total UAS:   12    0

-------------------
L'unica cosa che noto essere troppo alta rispetto al normale sono le varie voci degli errori. Ma non so sinceramente quale sia la vera causa del problema.

Vi ringrazio infinitamente in anticipo,

Marco

Pondera

Che versione di firmware hai al momento?

Mark0505

Fino a ieri sera avevo la 4.00.
Da ieri sera l'ho aggiornato anche alla 4.01 (l'ultima suggerita sul topic del router sul vostro forum)
Ma senza risultati...

Pondera

Imposta la modulazione in G.DMT e disabilita SRA e Bitswap.

Mark0505

Citazione di: Mark0505 il 17 Marzo 2011, 12:34:55Fino a ieri sera avevo la 4.00.
Da ieri sera l'ho aggiornato anche alla 4.01 (l'ultima suggerita sul topic del router sul vostro forum)
Ma senza risultati...

Fatto ma nessun risultato. Cos'altro potrebbe essere secondo te?

Grazie comunque per l'ìinteressamento

Licenza Creative Commons
Il contenuto dei messaggi del forum è distribuito con
Licenza Creative Commons Attribuzione Non commerciale 4.0
Tutti i marchi registrati citati appartengono ai legittimi proprietari