29 Maggio 2020, 19:28:47

DSL-2640B B2 - Modem Router ADSL2+ Wireless G 54

Aperto da D-Link Forum, 15 Ottobre 2008, 20:01:00

bovirus

@bbrun
Io ho iInfostrada e non mi risulta (per esperienza mia personale) che chi è abbonatoad Infostrada abbia particolari limiti

E 'inutile segnalare probelmatiche o chiedere di effettuare verifiche su firmware non aggironati.
Anche il supporto Dlink acetta segnalazioni solo su probelamtiche relative a firmware aggiornati.

Il modem si può guastare di suo in condizioni differenti dall'aggiornamento frimware.

bbrun

Citazione di: bovirus il 27 Luglio 2012, 13:49:36@bbrun
Io ho Infostrada e non mi risulta (per esperienza mia personale) che chi è abbonato ad Infostrada abbia particolari limiti.
Infatti le mie ipotesi erano: 1) Infostrada taglia le gambe ai muleggiatori 2) Per far funzionare lo streaming bisogna modificare o attivare delle impostazioni nel router, visto che non è 1) rimane 2).
CitazioneÈ inutile segnalare probelmatiche o chiedere di effettuare verifiche su firmware non aggironati.
Anche il supporto Dlink accetta segnalazioni solo su problematiche relative a firmware aggiornati.
Insomma devo aggiornare per foza il fw? E va bene, ci risentiamo quando lo avrò effettuato.

Ciao.

bovirus

Io ho detto una csoa diversa. Non hod etto che devi aggiornare per forza.
Ma che segnaalzioni su versioni non aggiornate non vengono prese in considerazione.

Io ho infostrada e non mi risultano problemi uso Emule e come detto prima non ho riscontrato colli di bottiglia.
La reti emule una rete al cui disponibilità dei file e relativa velocità sono funzioni di uan serie di parametri non semrpe ripetibili.
E il downlaod non parte a piena velocità da subito ma rcihiede un certo tempo (anche lungo...).

bbrun

Citazione di: bovirus il 27 Luglio 2012, 17:56:55Io ho detto una cosa diversa. Non ho detto che devi aggiornare per forza.
Ma che segnalzioni su versioni non aggiornate non vengono prese in considerazione.
OK, comunque mi devo far passare la strizza, anche io vorrei aggiornarlo, non fosse altro per il fatto che è in Italiano.
Ma la cosa può dipendere dal fw vecchio?

CitazioneIo ho infostrada e non mi risultano problemi uso Emule e come detto prima non ho riscontrato colli di bottiglia.
Io non uso Emule, inoltre, nella mia ignoranza tecnica, scaricarsi un film per vederlo al volo, senza salvarlo, o scaricarlo su disco via Emule è la stessa cosa.
La domanda è diventata: dove devo mettere le mani per far vedere questi film?
Forse la soluzione è qui: http://imageshack.us/f/120/portng8.jpg/ ?
Premetto che non è roba mia, lo ho trovato dentro il forum e vale solo come esempio.
Dimenticavo, un difetto su Youtube c'è, su Telecom potevi metterlo in pausa, intanto il filmato si caricava, con Infostrada se metti in pausa la visione si ferma anche lo scaricamento.

Grazie.

bovirus

Vedere un filmato Youtube e usare emule sono due funzionalità completamente differenti.

Guarda che l'aggiornamento viene effettuato in più fasi.
Il modem carica il firmware effettuta un controllo integrità (CRC) e poi fa partire l'aggiornamento.

bbrun

Abbiamo tentato di collegarci poco fa, FUNZIONA!
Forse Infostrada dopo la pura e semplice attivazione della linea ha bisogno di "assestarsi", o forse è l'effetto della telefonata che gli abbiamo fatto.

Riguardo all'aggiornamento del fw, è questa la procedura? Disabilitare antivirus e firewall - scollegare il router dalla rete telefonica - scompattare il file ZIP -
fare l'aggiornamento, riscrivere i parametri per il collegamento e le varie impostazioni, che andranno persi con l'aggiornamento stesso.
Ho dimenticato/sbagliato qualcosa?
Nel caso qualcosa andasse storto, è possibile riportare il router al fw preinstallato?

Grazie.

bovirus

E tutto spiegato nel primo post. Leggiamolo per favore.
Va fatto un reset delle impostazioni PRIMA di aggiornare e DOPO aver aggiornato.
Si può caricare qualsiais firmware (anche rpecedenet) semrpe con lo stesso sistema.

bbrun

Bovirus, nel primo post non c'è nessuna procedura di aggiornamento del fw.
Ce ne sono due di recupero del vecchio fw, una via cavo Ethernet e una via console seriale.
A meno che tu non ti riferisca alla pagina 66 del manuale in Inglese, che però non mi sembra (non conoscendo l'Inglese) una procedura adatta a chi lo faccia la prima volta.

Ciao.

bovirus

La procedura è semplice. Scarichi il file del firmware (file compresso). Lo decomprimi.
Apri il browser web (suggerito IE 7.x o superiore). Digiti l'indirizzo IP del modem (di solito 192.168.1.1).
Ti si apre l'interfaccia web del modem. Accedi alla pagina di aggiornamento del firmware (vedi manuale utente).
Selezioni il caricamento del file del firmware. Scegli il file compresso (di solito pesa sopra i 2MB e può avere una estensione .bin).

E' la procedura che viene illustrata a pagina 66 del manuale utente (inglese).
Non esiste differenza sul modo di aggiornare per la prima volta o le successive.

Puoi comunque usare anche la procedura di recovery indicata in prima pagina.

jabba

Buongiorno, ho cambiato T3d :-/

Click

Ora, nella schermata del Router mi appare:

CitazioneFirmware Version: EU_4.01B Hardware Version: B2

Via Telnet:

CitazioneBCM96348 ADSL Router
Login: admin
Password:
> swversion show
EU_3-10-02-3B00.A2pB022g2.d20h

 ???

Ancora, utilizzando il Tool DMT mi dice User e Password errate  ???

Altro Router, altri problemi :@

P.S. I problemi dell'altro (E1) sembrano essere spariti ...



Pondera

No! Perché si tratta di un link che punta ad un file .ZIP da decomprimere! :D

jabba

Citazione di: Pondera il 07 Agosto 2012, 18:05:30No! Perché si tratta di un link che punta ad un file .ZIP da decomprimere! :D

Sì, ma dentro al .zip c'è il file senza estensione: EU_DSL-2640B_EU_4.01B1_310023E00B1_cfe_fs_kernel

Occorre aggiungere .bin

jabba

Ho aggiornato (lo carica anche senza rinominarlo).

Ora per cortesia due cose:

Via Telnet mi mostra una versione strana:

CitazioneBCM96348 ADSL Router
Login: admin
Password:
> swversion show
EU_3-10-02-3E00B1.A2pB022g2.d20h

Nella pagina del dispositivo:

CitazioneFirmware Version : EU_4.01B1

Il Tool DMT mi risponde che è sbagliata la password (sempre stata admin e admin).

Grazie per ora  ^-^

Pondera

Prova root admin!
Per la decodifica del codice interno di versione Broadcom cerca nella discussione della B3! :D

jabba

Citazione di: Pondera il 07 Agosto 2012, 23:53:17Prova root admin!
Per la decodifica del codice interno di versione Broadcom cerca nella discussione della B3! :D

Neanche root ed admin :@

Ho provato anche lasciando in bianco, ma niente.

Riguardo i comandi del B3, sw version mi rende lo stesso risultato (la codifica non saprei interpretarla).

Il segno # non lo accetta >#: not found (occorre una procedura particolare?).

In tutti i casi per ora, rispetto il E1 non dà problemi di sorta  ^-^

Magari me lo tengo, vedrò (cosa ne pensi ...).

Se andasse il DMT mi farebbe piacere 8-)

P.S. Scalda molto, è bollente  :o

bovirus

@jabba
Il tool DMT non è trasparente a tutti i modem. E' compatibile con alcuni modelli e incompatibile con altri.
Esistono versioni custom di DMT per diversi modem.

Per il calore potrebbe essere perchè essendo un modello più vecchio del 2640B E1 (che avvi prima) ha un chip meno recente che "probabilmente2 scalda di più.

Metti 4 piedini sotto al modem per far grare un pò d'aria.

Pondera


jabba

Citazione di: "bovirus"Il tool DMT non è trasparente a tutti i modem. E' compatibile con alcuni modelli e incompatibile con altri

Sì, con l'altro funzionava ma non credo mi sia indispensabile.

Citazione di: "jabba"P.S. Scalda molto, è bollente
Citazione di: "bovirus"Metti 4 piedini sotto al modem per far grare un pò d'aria
Citazione di: "Pondera"Tienilo dritto

Chiaro, era solo una considerazione.

Ricapitolando:

  • Il primo (anzi il secondo sostituito E1) non teneva le impostazioni se non con la configurazione del CD (rimasto comunque un mistero).

  • Se si provava a cambiare qualche parametro perdeva i valori in Up e Down.

  • Tramite configurazione manuale i valori in Up e Down si dimezzavano.

  • Una volta spento il dispositivo, occorreva eseguire sempre il Reboot o riaccenderlo o staccare il cavo RJ11 o usare DMT > DSL Resync per risincronizzare la linea.

  • Con altri apparati (Alice Gate2 Plus Wi-Fi e DSL-320B nessun problema).
Riguardo il lato Wi-Fi non mi pronuncio, non ne faccio uso.

Citazione di: "jabba"In tutti i casi per ora, rispetto il E1 non dà problemi di sorta ... Magari me lo tengo

... cosa ne pensate :-/

Licenza Creative Commons
Il contenuto dei messaggi del forum è distribuito con
Licenza Creative Commons Attribuzione Non commerciale 4.0
Tutti i marchi registrati citati appartengono ai legittimi proprietari